Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Kodi 14 not available. Reason?

  1. #11

    Default Re: Kodi 14 not available. Reason?

    Quote Originally Posted by Miuku View Post
    Since I didn't have a 13.2 installation, I set it up in a VM and installed Kodi. After the installation and upon launch it complained about UnboundLocalError: local variable 'bitDepth' referenced before assignment. Simply installing xdpyinfo resolved this problem.

    What error message does it output upon launching it (kodi) from a terminal?
    Hi Miuku,
    I also get the UnboundLocalError even though I have reinstalled xdpyinfo.

  2. #12
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,035

    Default Re: Kodi 14 not available. Reason?

    Could you run this command from a terminal and copy paste the output here, enclose it in code blocks, like this:
    Code:
    Cats are cute!
    The command being: strace -e open kodi

    You can run it as your normal user, no root privileges necessary nor sudo.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #13

    Default Re: Kodi 14 not available. Reason?

    Here you go:

    Code:
    strace -e open kodiopen("/lib64/bash/4.2/tls/x86_64/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/lib64/bash/4.2/tls/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/lib64/bash/4.2/x86_64/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/lib64/bash/4.2/libreadline.so.6", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libreadline.so.6", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libtinfo.so.5", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libdl.so.2", O_RDONLY|O_CLOEXEC) = 3
    open("/lib64/libc.so.6", O_RDONLY|O_CLOEXEC) = 3
    open("/dev/tty", O_RDWR|O_NONBLOCK)     = 3
    open("/usr/lib/locale/locale-archive", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
    open("/usr/share/locale/locale.alias", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_IDENTIFICATION", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib64/gconv/gconv-modules.cache", O_RDONLY) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MEASUREMENT", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_TELEPHONE", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_ADDRESS", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_NAME", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_PAPER", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MESSAGES", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MESSAGES/SYS_LC_MESSAGES", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_MONETARY", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_COLLATE", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_TIME", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_NUMERIC", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/lib/locale/en_US.utf8/LC_CTYPE", O_RDONLY|O_CLOEXEC) = 3
    open("/proc/meminfo", O_RDONLY|O_CLOEXEC) = 3
    open("/usr/bin/kodi", O_RDONLY)         = 3
    --- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=22932, si_status=0, si_utime=0, si_stime=0} ---
    xdpyinfo: error while loading shared libraries: libXxf86dga.so.1: cannot open shared object file: No such file or directory
    Traceback (most recent call last):
      File "/usr/share/kodi/FEH.py", line 174, in <module>
        if (1 == 1 and badColorDepth()):
      File "/usr/share/kodi/FEH.py", line 153, in badColorDepth
        return bitDepth
    UnboundLocalError: local variable 'bitDepth' referenced before assignment
    --- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=22933, si_status=1, si_utime=7, si_stime=2} ---
    +++ exited with 1 +++

  4. #14
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,035

    Default Re: Kodi 14 not available. Reason?

    The output means you're lacking the libXxf86dga1 package - you should see if your system has this package installed.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  5. #15

    Default Re: Kodi 14 not available. Reason?

    Quote Originally Posted by Miuku View Post
    The output means you're lacking the libXxf86dga1 package - you should see if your system has this package installed.
    Thank you. It was installed but I updated it unconditionally and that made my previous problem go away. Now it seems I need to install libmicrohttpd though.

    Code:
    kodi/usr/lib64/kodi/kodi.bin: error while loading shared libraries: libmicrohttpd.so.10: cannot open shared object file: No such file or directory
    Weird. Now it is complaining about libtinyxml0 and libyajl even though they too are installed.

  6. #16
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,035

    Default Re: Kodi 14 not available. Reason?

    Could you post the output of: zypper lr -d

    and enclose that in code blocks too, also the output of; cat /etc/os-release
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  7. #17

    Default Re: Kodi 14 not available. Reason?

    I had too update the two last mentioned packages using update unconditionally and NOW Kodi starts. What have I done to my OpenSUSE installation to get these problems? Regards.

  8. #18

    Default Re: Kodi 14 not available. Reason?

    Quote Originally Posted by Miuku View Post
    Could you post the output of: zypper lr -d

    and enclose that in code blocks too, also the output of; cat /etc/os-release
    Here you go:

    Code:
    zypper lr -d#  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                  | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
     1 | Application:Geo           | Application:Geo                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_13.2/            |        
     2 | Packman Repository        | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2                              |        
     3 | google-chrome             | google-chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                  |        
     4 | home:Lazy_Kent            | home:Lazy_Kent                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Lazy_Kent/openSUSE_13.2/             |        
     5 | home:happenpappen         | home:happenpappen                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/happenpappen/openSUSE_13.2/          |        
     6 | libdvdcss repository      | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                                                 |        
     7 | multimedia:libs           | multimedia:libs                    | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_13.2/            |        
     8 | openSUSE-13.2-0           | openSUSE-13.2-0                    | No      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Corsair_Flash_Voyager_AA04012700010300-0:0-part2   |        
     9 | openSUSE_13.1             | openSUSE_13.1                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/lxde:/lxqt/openSUSE_13.1/             |        
    10 | openSUSE_13.2             | openSUSE_13.2                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Enlightenment:/Nightly/openSUSE_13.2/ |        
    11 | openSUSE_13.2_1           | openSUSE_13.2                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/patrickmcdonough/openSUSE_13.2/      |        
    12 | openSUSE_13.2_2           | openSUSE_13.2                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_13.2/                 |        
    13 | repo-debug                | openSUSE-13.2-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.2/repo/oss/                       |        
    14 | repo-debug-update         | openSUSE-13.2-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2/                                      |        
    15 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.2-non-oss/                              |        
    16 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/                         |        
    17 | repo-oss                  | openSUSE-13.2-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/                             |        
    18 | repo-source               | openSUSE-13.2-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.2/repo/oss/                      |        
    19 | repo-update               | openSUSE-13.2-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                                            |        
    20 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/                                    |        
    21 | standard                  | standard                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/stable/standard/                   |
    Code:
    cat /etc/os-releaseNAME=openSUSE
    VERSION="13.2 (Harlequin)"
    VERSION_ID="13.2"
    PRETTY_NAME="openSUSE 13.2 (Harlequin) (x86_64)"
    ID=opensuse
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:opensuse:13.2"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://opensuse.org/"
    ID_LIKE="suse"

  9. #19
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,035

    Default Re: Kodi 14 not available. Reason?

    I wonder if the 13.1 repo for lxde:/lxqt/ is causing issues.

    Hard to say since you have so many home repos that may or may not have conflicting files. Anyway as long as it works, s'all good I guess.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  10. #20

    Thumbs up Re: Kodi 14 not available. Reason?

    Quote Originally Posted by Miuku View Post
    I wonder if the 13.1 repo for lxde:/lxqt/ is causing issues.

    Hard to say since you have so many home repos that may or may not have conflicting files. Anyway as long as it works, s'all good I guess.
    Thank you very much for your help, Miuku. I will delete the LXQT repository since I do not use it anymore.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •