Results 1 to 2 of 2

Thread: Bumblebee not behaving correctly

  1. #1

    Question Bumblebee not behaving correctly

    Hello,

    I have been an avid openSUSE user for the past year beginning with 13.1 and now on 13.2 and loving it! I recently installed an Intel 730 480GB SSD for my laptop and installed openSUSE 13.2 on it with the Gnome DE, dual booting with Windows 7. I have a Lenovo y580, which has switchable nvidia graphics with an Geforce GTX 660M. Installing bumblebee on it never seems to "just work" the first time. I followed the installation instructions https://en.opensuse.org/SDB:NVIDIA_Bumblebee, excluding the "OPTIONAL: Install NVIDIA driver" as I never have any luck with it. From past experience with 13.1, using powertop my laptop consumes about 20W before installing bumblebee, and 12W after.

    My laptop is currently consuming 20W of power, after bumblebee has been installed. To verify my installation, and that bumblebee is running correctly, I have run
    Code:
    optirun --status
    with a result of "Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off." Which I had believed was the desired result. Also,
    Code:
    cat /proc/acpi/bbswitch
    returns "0000:01:00.0 OFF" as expected.

    Problems occur when I try to run
    Code:
    optirun glxspheres
    with a result of:

    Code:
    [ 3612.723697] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card1: failed to set DRM interface version 1.4: Permission denied
    
    [ 3612.723763] [ERROR]Aborting because fallback start is disabled.
    Another error I see, is when the computer is booting it displays "Failed to start Load Kernel Modules. See 'systemctl status systemd-modules-load.service' for details." When I check the systemctl output of said command, I get:

    Code:
    systemd-modules-load.service - Load Kernel Modules   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
       Active: active (exited) since Mon 2015-01-05 14:04:42 CST; 3min 24s ago
         Docs: man:systemd-modules-load.service(8)
               man:modules-load.d(5)
      Process: 428 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
     Main PID: 428 (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/systemd-modules-load.service
    which seems to be perfectly fine to me with no indicated errors.

    Help with this would be greatly appreciated, my laptop is not usable in a state such as this given the power consumption is twice as high as it should be. Any other power management tips would be greatly appreciated!

    Cheers,
    Eric

  2. #2

    Default Re: Bumblebee not behaving correctly

    Update:

    I completed the "OPTIONAL: Install NVIDIA Driver" section from the bumblebee page, as I remembered from my previous installations that I did this. When I did a "modprobe nvidia" and resulted with a 'FATAL Driver does not exist" warning I realized my mistake. This eliminates the "Failed to Load Kernel Modules" error I was getting on bootup which makes sense, but I still have an outrageous power consumption of 26W. Running "optirun glxspheres" now gives me a result of:

    Code:
    [  467.024076] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver
    
    [  467.024108] [ERROR]Aborting because fallback start is disabled.
    Thanks,
    Eric

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •