Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Setting gnucash language

  1. #1

    Default Setting gnucash language

    I am running gnucash 2.6.4-65.9 on Gnome 3.14.1. My locale is English(GB). However, since I am living in Germany, I want to run gnucash (only gnucash) in German.

    I can do it from a Gnome terminal by
    Code:
    LANGUAGE=de_DE.UTF-8 LANG=de_DE.UTF-8 gnucash
    But I prefer to start gnucash from my desktop rather than opening a terminal each time.

    Gnucash itself does not have a language setting, the properties behind the desktop icon does not allow me to enter the language settings on launching gnucash, the dconf editor does not have a language setting for gnucash.

    Can anyone help me to find a more convenient way of starting gnucash in German than the above?

    Cheers
    Harvey

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Setting gnucash language

    You should be able to do that by editing the menu entry

  3. #3

    Default Re: Setting gnucash language

    Quote Originally Posted by gogalthorp View Post
    You should be able to do that by editing the menu entry
    Which 'menu entry' are you referring to?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Setting gnucash language

    The menu entry to start the program. In KDE it is easy I don't do Gnome but would suspect it is not hard. Try a right click on the menu icon. If you use a shortcut you can edit the call to the program there also just edit the properties of the short cut.

  5. #5

    Default Re: Setting gnucash language

    Quote Originally Posted by gogalthorp View Post
    The menu entry to start the program. In KDE it is easy I don't do Gnome but would suspect it is not hard. Try a right click on the menu icon.
    I don't think GNOME comes with a menu editor any more.

    But you can copy the file /usr/share/applications/gnucash.desktop to ~/.local/share/applications/ and edit the copy manually with a text editor (change the "Exec=" line accordingly).
    You could edit /usr/share/applications/gnucash.desktop directly as well (for system-wide effect), but then your changes would get lost whenever gnucash is updated/reinstalled.
    You could of course also create a file /usr/share/applications/german-gnucash.desktop (or ~/.local/share/applications/german-gnucash.desktop) with the same content as the original, only the Exec line changed (and maybe "Name=" as well to keep them apart), to have an additional, german, menu entry... This wouldn't even get overwritten by updates, as no package contains a file /usr/share/applications/german-gnucash.desktop.

  6. #6

    Default Re: Setting gnucash language

    Quote Originally Posted by wolfi323 View Post
    I don't think GNOME comes with a menu editor any more.

    But you can copy the file /usr/share/applications/gnucash.desktop to ~/.local/share/applications/ and edit the copy manually with a text editor (change the "Exec=" line accordingly).
    You could edit /usr/share/applications/gnucash.desktop directly as well (for system-wide effect), but then your changes would get lost whenever gnucash is updated/reinstalled.
    You could of course also create a file /usr/share/applications/german-gnucash.desktop (or ~/.local/share/applications/german-gnucash.desktop) with the same content as the original, only the Exec line changed (and maybe "Name=" as well to keep them apart), to have an additional, german, menu entry... This wouldn't even get overwritten by updates, as no package contains a file /usr/share/applications/german-gnucash.desktop.
    There is indeed something that looks like a menu editor in Gnome called 'Main Menu' under 'All settings'. But it is apparently not possible to apply changes to the command line if it is different from the system default. In other words, it seems not to be very useful.

    I have tried wolfi323's suggestion to edit the /usr/share/applications/gnucash.desktop without success (but I don't really understand what I am doing!):
    1. I can find no file gnucash.desktop in /usr/share/applications/, only one called gnucash.
    2. Even if I copy the file called gnucash to ~/.local/share/applications/gnucash.desktop and edit the command line with success, it seems to have no effect when starting gnucash from the desktop. I always get the English version (and by the way, the 'Main Menu' entry for gnucash then shows the edited command line.
    Lost and unhappy

  7. #7

    Default Re: Setting gnucash language

    Quote Originally Posted by hnimmo View Post
    There is indeed something that looks like a menu editor in Gnome called 'Main Menu' under 'All settings'. But it is apparently not possible to apply changes to the command line if it is different from the system default. In other words, it seems not to be very useful.
    Hm, I don't have anything like that at all here in GNOME's settings.
    Maybe that's some extension?

    1. I can find no file gnucash.desktop in /usr/share/applications/, only one called gnucash.
    It must be called gnucash.desktop, otherwise you wouldn't have a menu entry at all.
    And you state in 2. that you copied gnucash.desktop, so how did you do that if it isn't there?

    Does GNOME now omit the file endings like Windows does?

    2. Even if I copy the file called gnucash to ~/.local/share/applications/gnucash.desktop and edit the command line with success, it seems to have no effect when starting gnucash from the desktop. I always get the English version (and by the way, the 'Main Menu' entry for gnucash then shows the edited command line.
    You might have to logout/login that GNOME recognizes the change.
    I don't use GNOME, so cannot help further I'm afraid. In KDE you could run "kbuildsycoca4" to refresh its menu cache.

    Maybe post your file if you are not sure whether you edited it correctly.
    Last edited by wolfi323; 05-Jan-2015 at 13:19.

  8. #8

    Default Re: Setting gnucash language

    Quote Originally Posted by wolfi323 View Post
    Does GNOME now omit the file endings like Windows does?
    Well, I ran nautilus now, and if you enter the folder /usr/share/application, it indeed shows the "Name" entry of the .desktop file instead of the filename.
    Great thing to do for a _file_ manager...
    And so predictable, why doesn't it do the same for .desktop files in ~/.local/share/applications/?

    Well, I know why I don't use GNOME...

    But believe me, the file is actually called "gnucash.desktop".
    Last edited by wolfi323; 05-Jan-2015 at 13:28.

  9. #9

    Default Re: Setting gnucash language

    Quote Originally Posted by wolfi323 View Post
    Well, I ran nautilus now, and if you enter the folder /usr/share/application, it indeed shows the "Name" entry of the .desktop file instead of the filename.
    Great thing to do for a _file_ manager...
    And so predictable, why doesn't it do the same for .desktop files in ~/.local/share/applications/?

    Well, I know why I don't use GNOME...

    But believe me, the file is actually called "gnucash.desktop".
    I agree, it seems to be sheer chaos! I extended the command line in /usr/share/applications/ in the gnucash properties as root. Of course, it was accepted. On logging in again as a normal (Gnome) user, however, Gnucash was no longer available as an application! - just gone, completely disappeared from the Gnome applications, zilch. Why? Because the gnucash file in /usr/share/applications/ had renamed itself as gnucash.desktop! (I say 'renamed itself' because I did not do it, I had just closed the properties window and everything had seemed as before). I could only start gnucash from a terminal... and got the English version, although the command line in /usr/share/applications/gnucash.desktop asked for German.

    After I had reset the command line in /usr/share/applications/gnucash.desktop everything returned to 'normal'. I cannot fathom this out at all! As I say ... sheer chaos!

  10. #10

    Default Re: Setting gnucash language

    Quote Originally Posted by hnimmo View Post
    On logging in again as a normal (Gnome) user, however, Gnucash was no longer available as an application! - just gone, completely disappeared from the Gnome applications, zilch. Why? Because the gnucash file in /usr/share/applications/ had renamed itself as gnucash.desktop! (I say 'renamed itself' because I did not do it, I had just closed the properties window and everything had seemed as before).
    No, the file definitely did _not_ "rename itself".
    I would guess that you did something wrong when editing it, or GNOME does not like setting environment variables in the Exec line.
    At least this sounds like GNOME/nautilus did not recognize the file "gnucash.desktop" as valid desktop file any more. (and before you logged out, nautilus probably just didn't refresh its directory view to the new content)

    I could only start gnucash from a terminal... and got the English version, although the command line in /usr/share/applications/gnucash.desktop asked for German.
    Of course. If you run it from the command line, the .desktop file is not used at all.

    After I had reset the command line in /usr/share/applications/gnucash.desktop everything returned to 'normal'. I cannot fathom this out at all! As I say ... sheer chaos!
    Well, you could try to put the Exec command into quotes, like this:
    Code:
    Exec="LANGUAGE=de_DE.UTF-8 LANG=de_DE.UTF-8 gnucash %f"
    In KDE it definitely works fine (even without quotes). I'll have to try myself in GNOME first though.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •