Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Firefox has started a very annoying behaviour!

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Firefox has started a very annoying behaviour!

    Quote Originally Posted by wakou View Post
    Thanks again, Wolfie. But this has not worked either.....
    Take a look at /usr/share/applications/mimeinfo.cache and ~/.local/share/applications/mimeapps.list , specifically the 'inode/directory=' entry

    For reference, I have
    Code:
    cat /usr/share/applications/mimeinfo.cache|grep inode
    inode/directory=kde4-dolphin.desktop;kde4-dolphinsu.desktop;kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;nautilus.desktop;
    In my home directory, I have it configured as
    Code:
     cat ~/.local/share/applications/mimeapps.list|grep inode
    inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;

  2. #12
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Firefox has started a very annoying behaviour!

    FWIW, here's some nautilus history

    Code:
    commit f01e2e9b5fa6dcd0514bdf5efe5f76b4312f1fd3
    Author: Federico Mena Quintero <federico gnome org>
    Date:   Wed Dec 14 12:12:04 2011 -0600
    
        Add an org.freedesktop.FileManager1.service file for DBus
        
        Even though this registers a service for a freedesktop name with a Gnome-specific
        program (Nautilus), we'll just do this for now.
        
        Later we can discuss in the DBus list how to launch services with generic
        interfaces, but specific implementations for each desktop environment.
        
        Signed-off-by: Federico Mena Quintero <federico gnome org>
    kolAflash reported it here too

    https://bugs.launchpad.net/ubuntu/+s...33/comments/78

  3. #13
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Firefox has started a very annoying behaviour!

    For now, I suppose you could edit org.freedesktop.FileManager1.service, and comment the entry
    Code:
    #Exec=/usr/bin/nautilus --no-default-window
    or delete it. If using KDE, nautilus should then use the Dolphin file manager instead. You could also lock the nautilus package, so that an update won't rewrite the file, (or maybe via Apparmor).

  4. #14
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Firefox has started a very annoying behaviour!

    Quote Originally Posted by deano_ferrari View Post
    For now, I suppose you could edit org.freedesktop.FileManager1.service, and comment the entry
    Code:
    #Exec=/usr/bin/nautilus --no-default-window
    or delete it. If using KDE, nautilus should then use the Dolphin file manager instead. You could also lock the nautilus package, so that an update won't rewrite the file, (or maybe via Apparmor).
    Thank you Deano. Reading that bug report, and your advice, I have commented that entry, and firefox now launches Dolphin on request. I think this means that when nautilus updates, it will refresh that file, but I know where to look now. In the bug thread, someone suggests:

    My workaround was to "sabotage" the org.freedesktop.Filemanager1 dbus service by creating:
    Code:
     ~/.local/share/dbus-1/services/org.freedesktop.FileManager1.service
    and changing the Exec line to e.g. /usr/bin/false or /usr/bin/true;
    this is better since it's persistent and isn't affected by system updates... etc.
    This makes Firefox use whatever file manager I set in ~/.local/share/applications/defaults.list
    I notice that Dropbox still launches Nautilus, which is annoying, but less so than firefox, as the dropbox folder is always in the same place and I can simply launch dolphin myself when I need my dropbox folder.

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  5. #15
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Firefox has started a very annoying behaviour!

    Quote Originally Posted by wakou View Post
    Thank you Deano. Reading that bug report, and your advice, I have commented that entry, and firefox now launches Dolphin on request. I think this means that when nautilus updates, it will refresh that file, but I know where to look now.
    That's what I've done for now. Easy enough to lock nautilus too. I'm sure a more permanent fix will come.

  6. #16

    Default Re: Firefox has started a very annoying behaviour!

    Quote Originally Posted by wakou View Post
    I notice that Dropbox still launches Nautilus, which is annoying, but less so than firefox, as the dropbox folder is always in the same place and I can simply launch dolphin myself when I need my dropbox folder.
    ...I noted that dropbox uses files..., free software..., but also me prefere dolphin, ...any workaround?? :-)

  7. #17
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Firefox has started a very annoying behaviour!

    Quote Originally Posted by pier_andreit View Post
    ...I noted that dropbox uses files..., free software..., but also me prefere dolphin, ...any workaround?? :-)
    Dropbox for me has changed recently, since it upgraded. The icon in the tray changed and where it used to launch from a click on the tray icon, it no longer does. Now you have to right click the icon to get a context menu. Mine though does launch Dolphin. I don't have Nautilus installed. And so of course too, Firefox is fine.

    I have though noticed some apps present me with some kind of gtk style file manager
    IIRC Gimp did so yesterday
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #18

    Default Re: Firefox has started a very annoying behaviour!

    Quote Originally Posted by caf4926 View Post
    I have though noticed some apps present me with some kind of gtk style file manager
    IIRC Gimp did so yesterday
    Well, GIMP is actually a GTK application (GTK originally stood for GIMP ToolKit, before it became the GNOME ToolKit).
    So it is normal that it shows the GTK file select dialog when you open/save a file.
    But that's totally unrelated to launching a file manager...

    Note: file select dialog != file manager.
    The former one is a function of the used toolkit, the latter one is an application like any other.
    Last edited by wolfi323; 08-Jan-2015 at 03:56.

  9. #19

    Default Re: Firefox has started a very annoying behaviour!

    Hi!
    The problem is caused by Firefox, as described in this Firefox bugreport.

    https://bugzilla.mozilla.org/show_bug.cgi?id=266600


    The following should solve/workaround the problem for current Firefox versions (e.g. Firefox 34).

    Create a textfile (and folders if necessary): /home/YOUR-USER/.local/share/dbus-1/services/org.freedesktop.FileManager1.service
    Code:
    [D-BUS Service]
    Name=org.freedesktop.FileManager1
    Exec=/usr/bin/xdg-open
    Now Firefox should respect the filemanager set by xdg-mime.
    Use this, to set the filemanager by xdg-mime (for current user only):
    Code:
    xdg-mime default dolphin.desktop inode/directory
    Check current xdg-mime setting:
    Code:
    xdg-mime query default inode/directory

    I'm currently running quite well with this setting on my system!
    Nevertheless this might has bad side effects. For details, have a look here:
    https://bugzilla.opensuse.org/show_bug.cgi?id=904229#c2

  10. #20
    Join Date
    Jan 2015
    Location
    United Kingdom
    Posts
    1

    Default Re: Firefox has started a very annoying behaviour!

    Somebody solve this?

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •