Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: OpenSUSE 13.2 x64 - AMD fglrx Issues

  1. #1
    Join Date
    Jan 2014
    Posts
    28

    Default OpenSUSE 13.2 x64 - AMD fglrx Issues

    Due to the dual processor, my laptop screen requires that I unify outputs to align the messages and programs on the screen. Having said this, if one does not install the AMD fglrx drivers first, the screen goes completely black on startup, and one must enter "recovery mode" and install the AMD fglrx drivers to resume normal function.

    Going to the AMD fglrx page (https://en.opensuse.org/SDB:AMD_fglrx), one can manually install or use the 1-click install option. The 1-click install option now works for OpenSUSE 13.2, yet if one installs the fglrx drivers this way, or manually, one can no longer use the "Online Update" feature in OpenSUSE 13.2 to install/uninstall software. Also, automatic detection of printers after this installation fails.

    I have reinstalled the OS a bunch of times testing these outcomes, and every single time this happens, including these strange, seemingly unrelated issues. The only solution that seems to work is if one manually installs the core component, and only the core component (http://geeko.ioda.net/mirror/amd-fgl...3-1.x86_64.rpm). I have used the 1-click install in this latest instance, which installs the entire set of drivers. How do I get the system working properly again with the complete set of drivers installed?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    On Sun, 04 Jan 2015 00:06:07 +0000, BMor wrote:

    > yet if one installs the fglrx drivers this way, or manually, one can no
    > longer use the "Online Update"
    > feature in OpenSUSE 13.2 to install/uninstall software. Also, automatic
    > detection of printers after this installation fails.


    There's no reason this should cause a problem - when you say something
    fails, it would be useful to have exact error messages rather than a
    generic description like that. Generic descriptions can't be diagnosed -
    exact error messages can.

    If you need to, launch the utility in question from the command line (a
    terminal window) to get an error message if none is produced.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jan 2014
    Posts
    28

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    Quote Originally Posted by hendersj View Post
    On Sun, 04 Jan 2015 00:06:07 +0000, BMor wrote:

    > yet if one installs the fglrx drivers this way, or manually, one can no
    > longer use the "Online Update"
    > feature in OpenSUSE 13.2 to install/uninstall software. Also, automatic
    > detection of printers after this installation fails.


    There's no reason this should cause a problem - when you say something
    fails, it would be useful to have exact error messages rather than a
    generic description like that. Generic descriptions can't be diagnosed -
    exact error messages can.

    If you need to, launch the utility in question from the command line (a
    terminal window) to get an error message if none is produced.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

    I would have provided the error message if one was produced. The GUI for the online update noticably stops working every single time the fglrx drivers are installed from the aforementioned site. Yast can still be launched via the terminal. From here, repositories can still be added or removed, software can still be installed or deleted, etc. The GUI frontend for this feature; however, no longer works after the fglrx packages are all installed. I try to launch the application. I get the expected "run as root" password box. Yet after I enter the correct password, nothing happens. No error message is produced and nothing noticeable further happens to the system. The only work-around I found so far was to manually install the core package as mentioned above, installing no other packages. Would there be a diagnostic utility I can run that can provide a little more information as to why the GUI frontend fails in this instance?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,585

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    Ok the GUI does not works at without the fglrx driver right?? What video chip? AMD drops older chips rather frequently. Also What Desktop?

    When it works some programs notably some form of installer does not work? Right?

    You have not tried to start the program(s) that cause problems from the command line to see if they spit out some error messages? right? Why not??

    It all works if you only install the core. So again what chip??

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    On Sun, 04 Jan 2015 04:06:01 +0000, BMor wrote:

    > The GUI for the online update noticably stops working every single time
    > the fglrx drivers are installed from the aforementioned site.


    Define "stops working".

    Remember that nobody here knows what you know about your system, or is
    seeing what you're seeing on your system.

    You say Yast can be launched via the terminal (which sounds like you're
    running it from a console, not from, say, gnome-terminal or konsole).
    You can launch it there as well, using kdesu or gnomesu (as appropriate),
    and you should get (a) a gui, and (b) messages in the terminal window
    that show what's going wrong.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6
    Join Date
    Jan 2014
    Posts
    28

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    Quote Originally Posted by gogalthorp View Post
    Ok the GUI does not works at without the fglrx driver right?? What video chip? AMD drops older chips rather frequently. Also What Desktop?

    When it works some programs notably some form of installer does not work? Right?

    You have not tried to start the program(s) that cause problems from the command line to see if they spit out some error messages? right? Why not??

    It all works if you only install the core. So again what chip??

    If I understand correctly, from the command line the program is Yast, which I did run. I can interact with Yast via the Konsole (which I was referring to as the "terminal"), but not the interface that allows for one to select and delete software via the mouse (which I was calling the GUI program).

  7. #7
    Join Date
    Jan 2014
    Posts
    28

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    Sorry, the above message was accidentally sent before complete.


    Quote Originally Posted by gogalthorp View Post
    Ok the GUI does not works at without the fglrx driver right?? What video chip? AMD drops older chips rather frequently. Also What Desktop?

    When it works some programs notably some form of installer does not work? Right?

    You have not tried to start the program(s) that cause problems from the command line to see if they spit out some error messages? right? Why not??

    It all works if you only install the core. So again what chip??

    If I understand correctly, from the command line the program is Yast, which I did run. I can interact with Yast via the Konsole (which I was referring to as the "terminal"), but not the interface that allows for one to select and delete software via the mouse (which I was calling the GUI program). My machine is old, a Lenovo T500. The card on it is a Intel GMA 4500 MHD ATI Switchable 256MB graphics card. If AMD drops cards frequently, this could be the problem. The system is approaching its 6th year. I am running OpenSUSE 13.2 x64 with the KDE platform.


    In reponse to Mr. Henderson:

    I took your advice and downloaded kdesu via Yast running in the Konsole. I ran the command kdesu yast which brought up the GUI root password box - the same as what would happen if I clicked on the program. The line indicator drops to the next line after executing the command, which is expected when running a program from the Konsole. No error message is produced in the Konsole; however. I look at the Konsole and it appears as if the program is running, yet no GUI appears on screen for this specific program. So far, running any other program in the Konsole brings up the GUI. It seems restricted to just this program. I wish there was something more I could provide. Any further suggestions?

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,012
    Blog Entries
    1

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    I took your advice and downloaded kdesu via Yast running in the Konsole. I ran the command kdesu yast which brought up the GUI root password box - the same as what would happen if I clicked on the program. The line indicator drops to the next line after executing the command, which is expected when running a program from the Konsole. No error message is produced in the Konsole;
    Instead, try
    Code:
    su -c /sbin/yast2
    or
    Code:
    /usr/bin/xdg-su -c /sbin/yast2

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,012
    Blog Entries
    1

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    I took your advice and downloaded kdesu via Yast running in the Konsole. I ran the command kdesu yast which brought up the GUI root password box - the same as what would happen if I clicked on the program. The line indicator drops to the next line after executing the command, which is expected when running a program from the Konsole. No error message is produced in the Konsole; however. I look at the Konsole and it appears as if the program is running, yet no GUI appears on screen for this specific program. So far, running any other program in the Konsole brings up the GUI. It seems restricted to just this program. I wish there was something more I could provide. Any further suggestions?
    You need to understand that 'kdesu' is for running graphical applications with root privileges, and 'yast' is a 'text-mode' (ncurses) application, so this won't work. You need to use 'yast2' to launch the graphical version of the YaST utilities.

    Code:
     /sbin/yast2 --help
    Usage: /sbin/yast2 [OPTIONS] [MODULE] [module specific parameters]
    
    OPTIONS:
            -h, --help      this message
            -l, --list      list all available modules
            --qt            use the QT graphical user interface
            --gtk           use the GTK graphical user interface
            --ncurses       use the NCURSES text-mode user interface
            -g, --geometry  default window size (qt only)
            --noborder      no window manager border for main window
            --fullscreen    use full screen

  10. #10
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: OpenSUSE 13.2 x64 - AMD fglrx Issues

    On Mon, 05 Jan 2015 09:26:02 +0000, BMor wrote:

    > It seems restricted to just this program. I wish there was something
    > more I could provide. Any further suggestions?


    Nope, it's the path. Try:

    kdesu -c '/sbin/yast2'

    I often forget that it's not in other peoples' path because /sbin/ isn't
    in the normal user path.

    You would have the same issue if you launched it outside a terminal.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •