Results 1 to 6 of 6

Thread: Fehler bei Owncloud-RPM-Requirements (v7.0.4)?

  1. #1

    Question Fehler bei Owncloud-RPM-Requirements (v7.0.4)?

    Hallo zusammen!

    Ich bin neu im Forum und begrüße alle herzlich. Kenntnisse mit Linux sind bei mir vorhanden aber können wohl eher als im Aufbau betrachtet werden.

    Vorgeschichte:
    Meine openSUSE 13.2 minimal-server-Installation (folglich ohen GUI), will ich um einen Owncloud-Server für das syncen von Kontakten und einem eigenen Kalender erweitern.
    Ich folge dabei dieser Anleitung >>Link<< und habe das notwendige Repo hinzugefügt und mit Installation gestartet.

    Problem:
    zypper will daraufhin das Libreoffice-Paket plus diverse GTK-Pakete zusätzlich zu den wirklich benötigten Paketen installieren, was aus meiner Sicht wenig Sinn macht und nur unnötig Speicherplatz braucht.

    Code:
    zypper in owncloud
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 219 NEW packages are going to be installed:
      PackageKit PackageKit-backend-zypp PackageKit-branding-openSUSE PackageKit-gstreamer-plugin PackageKit-gtk3-module adwaita-icon-theme 
      at-spi2-atk-common at-spi2-atk-gtk2 at-spi2-core bundle-lang-gnome-en cantarell-fonts fuse gcr-data gcr-prompter gcr-viewer gdk-pixbuf-query-loaders 
      glib-networking gnome-online-accounts google-carlito-fonts gsettings-desktop-schemas gstreamer gstreamer-plugins-base gtk2-branding-openSUSE 
      gtk2-data gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-metatheme-adwaita 
      gtk2-theming-engine-adwaita gtk2-tools gtk3-branding-openSUSE gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut gtk3-immodule-thai 
      gtk3-immodule-vietnamese gtk3-metatheme-adwaita gtk3-tools gvfs gvfs-backend-afc gvfs-backends gvfs-fuse hicolor-icon-theme 
      hicolor-icon-theme-branding-openSUSE hunspell hunspell-tools java-1_7_0-openjdk java-1_7_0-openjdk-headless lcms2 libFLAC8 libGLEW1_10 libGLU1 
      libXcomposite1 libXcursor1 libXevie1 libXft2 libXi6 libXinerama1 libXrandr2 libXtst6 libXv1 libabw-0_1-1 libasound2 libaspell15 libatasmart4 
      libatk-1_0-0 libatk-bridge-2_0-0 libatspi0 libavahi-client3 libavahi-common3 libavahi-glib1 libbluetooth3 libbluray1 libboost_date_time1_54_0 
      libboost_iostreams1_54_0 libcairo-gobject2 libcdda_interface0 libcdda_paranoia0 libcdio14 libcdio_cdda1 libcdio_paranoia1 libcdr-0_1-1 
      libclucene-contribs-lib1 libclucene-core1 libclucene-shared1 libcmis-0_4-4 libcolord2 libe-book-0_1-1 libenchant1 liberation-fonts libetonyek-0_1-1 
      libexif12 libexttextcat libexttextcat-2_0-0 libfbembed2_5 libfreebl3 libfreehand-0_1-1 libgck-1-0 libgcr-3-1 libgd3 libgdk_pixbuf-2_0-0 libgeoclue0 
      libgif6 libgltf-0_0-0 libgnutls28 libgoa-1_0-0 libgoa-backend-1_0-1 libgphoto2-6 libgraphite2-3 libgstapp-1_0-0 libgstaudio-1_0-0 libgstfft-1_0-0 
      libgstpbutils-1_0-0 libgstreamer-1_0-0 libgstriff-1_0-0 libgsttag-1_0-0 libgstvideo-1_0-0 libgthread-2_0-0 libgtk-2_0-0 libgtk-3-0 libharfbuzz-icu0 
      libharfbuzz0 libhogweed2 libhyphen0 libicu53_1 libicu53_1-ledata libixion-0_8-0 libjasper1 libjavascriptcoregtk-3_0-0 libjson-c2 libjson-glib-1_0-0 
      liblangtag1 liblockdev1 liblpsolve55-0 libltdl7 libmpfr4 libmspub-0_1-1 libmtp9 libmwaw-0_3-3 libmysqlcppconn6 libmythes-1_2-0 libneon27 libnettle4 
      libodfgen-0_1-1 libogg0 libopenobex2 liborc-0_4-0 liborcus-0_8-0 libpackagekit-glib2-18 libpango-1_0-0 libproxy1-pacrunner-webkit libpulse0 
      libpython3_4m1_0 libraptor2-0 librasqal3 librdf0 libreoffice libreoffice-base libreoffice-base-drivers-mysql libreoffice-branding-openSUSE 
      libreoffice-calc libreoffice-draw libreoffice-filters-optional libreoffice-icon-theme-galaxy libreoffice-icon-theme-hicontrast 
      libreoffice-icon-theme-sifr libreoffice-impress libreoffice-l10n-en libreoffice-mailmerge libreoffice-math libreoffice-pyuno 
      libreoffice-templates-en libreoffice-templates-labels-a4 libreoffice-templates-labels-letter libreoffice-templates-presentation-layouts 
      libreoffice-writer librest0 librevenge-0_0-0 libsecret-1-0 libsndfile1 libsoftokn3 libsoup-2_4-1 libspeex1 libtelepathy-glib0 libtheoradec1 
      libtheoraenc1 libudisks2-0 libvisio-0_1-1 libvisual libvorbis0 libvorbisenc2 libwayland-cursor0 libwebkitgtk-3_0-0 libwebp5 libwpd-0_10-10 
      libwpg-0_3-3 libwps-0_3-3 libxkbcommon-0_4_3 libxslt1 lockdev metatheme-adwaita-common mozilla-nss mozilla-nss-certs myspell-dictionaries myspell-en 
      myspell-lightproof-en obex-data-server owncloud owncloud-3rdparty pango-tools python python3 python3-base python3-pip python3-setuptools 
      timezone-java udisks2 zip 
    
    The following 28 recommended packages were automatically selected:
      PackageKit PackageKit-gstreamer-plugin bundle-lang-gnome-en cantarell-fonts gcr-viewer gnome-online-accounts gtk2-branding-openSUSE gtk2-data 
      gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai gtk2-immodule-vietnamese gtk3-branding-openSUSE gtk3-immodule-amharic 
      gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese gvfs gvfs-backend-afc gvfs-backends gvfs-fuse hunspell-tools java-1_7_0-openjdk 
      libreoffice-writer myspell-lightproof-en obex-data-server python3-pip udisks2 
    
    219 new packages to install.
    Overall download size: 245.5 MiB. Already cached: 0 B  After the operation, additional 744.2 MiB will be used.
    Continue? [y/n/? shows all options] (y): n
    Ursache/Wirkung?:
    Ich habe das Owncloud-Source-RPM heruntergeladen (Link) und mir das File "owncloud.spec" genauer angeschaut, wo ich aber nur eine Recommendation für libreoffice-writer gefunden habe (Zeile 113) und kein Requirement.
    Auf der Owncloud-Homepage wird der libreoffice-writer auch als optional beschrieben (notwendig für Previews).

    Meine Frage ist ob ich etwas übersehen habe oder falsch verstehe und der writer vielleicht doch benötigt wird, da mir das Blockieren von Paketen als ungeschickt vorkommt?
    Beziehungsweise stehen die Requirements vl. in einer anderen Datei?


    Liebe Grüße,

    Ramuel

    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Meine bisherige Lösung:
    Ich habe das Libreoffice-Paket mittels zypper blockiert,

    Code:
    zypper addlock libreoffice
    Specified lock has been successfully added.
    wodurch sich die Installation aus meiner Sicht auf das Notwendige reduziert hat:

    Code:
    zypper in owncloud
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 2 NEW packages are going to be installed:
      owncloud owncloud-3rdparty 
    
    The following package is recommended, but will not be installed due to conflicts or dependency issues:
      libreoffice-writer 
    
    2 new packages to install.
    Overall download size: 23.4 MiB. Already cached: 0 B  After the operation, additional 93.6 MiB will be used.
    Continue? [y/n/? shows all options] (y): 
    Retrieving package owncloud-3rdparty-7.0.4-16.1.noarch                                                            (1/2), 243.5 KiB (  1.5 MiB unpacked)
    Retrieving: owncloud-3rdparty-7.0.4-16.1.noarch.rpm .............................................................................................[done]
    Retrieving package owncloud-7.0.4-16.1.noarch                                                                     (2/2),  23.2 MiB ( 92.0 MiB unpacked)
    Retrieving: owncloud-7.0.4-16.1.noarch.rpm ..........................................................................................[done (1.7 MiB/s)]
    Checking for file conflicts: ....................................................................................................................[done]
    (1/2) Installing: owncloud-3rdparty-7.0.4-16.1 ..................................................................................................[done]
    (2/2) Installing: owncloud-7.0.4-16.1 ...........................................................................................................[done]
    tl;dr
    Zypper will bei der Owncloud-Installation auf einem Minimal-Server (kein GUI) als Requirement Libreoffice-Writer mitinstallieren. Das ist aus meiner Sicht nicht notwendig und ein Fehler!

  2. #2
    Join Date
    Jan 2013
    Location
    Germany
    Posts
    289

    Default Re: Fehler bei Owncloud-RPM-Requirements (v7.0.4)?

    Hallo und herzlich Willkommen bei openSUSE!

    Das ist kein Fehler von openSUSE, dass LibreOffice mit installiert werden soll. Es wird genau das umgesetzt und installiert, was ownCloud benötigt.
    Schau auf Seite 24 der Dokumentation http://doc.owncloud.org/server/6.0/o...dminManual.pdf. Dort steht "LibreOffice oder OpenOffice" als optional required.

    Wir wollen eine funktionstüchtige ownCloud mit allen Features anbieten können. Deshalb wird LibreOffice über zypper automatisch mit installiert.
    Würde das nicht gemacht werden, würde es nach kurzer Zeit einen Haufen Anfragen geben, warum man über die ownCloud keine Dokumente lesen kann und alles zuerst herunter laden muss.

    Ich hoffe, ich konnte hiermit Deine Frage beantworten und begründen, warum LibreOffice benötigt wird.

  3. #3

    Default Re: Fehler bei Owncloud-RPM-Requirements (v7.0.4)?

    Und zur Ergänzung:
    Um zu verhindern dass emfohlene ("recommended") Pakete automatisch installiert werden, gibts bei zypper die "--no-recommends" Option, also z.B.:
    Code:
    zypper in --no-recommends ownclod
    Sh. auch "zypper in --help".

    Oder du kannst es per default deaktivieren, indem du die Option "installRecommends = no" in /etc/zypp/zypper.conf setzt:
    Code:
    ## Do not install soft dependencies (recommended packages)
    ##
    ## Valid values: boolean
    ## Default value: yes
    ##
    # installRecommends = yes
    Systemweit gibts dann auch noch die Option "solver.onlyRequires" in /etc/zypp.conf, die global für den Solver gilt, also auch z.B. YaST beeinflusst:
    Code:
    ##
    ## Whether required packages are installed ONLY
    ## So recommended packages, language packages and packages which depend
    ## on hardware (modalias) will not be regarded.
    ##
    ## Valid values: boolean
    ## Default value: false
    ##
    # solver.onlyRequires = false
    Last edited by wolfi323; 04-Jan-2015 at 04:31.

  4. #4

    Thumbs up Re: Fehler bei Owncloud-RPM-Requirements (v7.0.4)?

    Quote Originally Posted by AdaLovelace View Post
    Hallo und herzlich Willkommen bei openSUSE!

    Das ist kein Fehler von openSUSE, dass LibreOffice mit installiert werden soll. Es wird genau das umgesetzt und installiert, was ownCloud benötigt.
    Schau auf Seite 24 der Dokumentation http://doc.owncloud.org/server/6.0/o...dminManual.pdf. Dort steht "LibreOffice oder OpenOffice" als optional required.

    Wir wollen eine funktionstüchtige ownCloud mit allen Features anbieten können. Deshalb wird LibreOffice über zypper automatisch mit installiert.
    Würde das nicht gemacht werden, würde es nach kurzer Zeit einen Haufen Anfragen geben, warum man über die ownCloud keine Dokumente lesen kann und alles zuerst herunter laden muss.

    Ich hoffe, ich konnte hiermit Deine Frage beantworten und begründen, warum LibreOffice benötigt wird.
    Quote Originally Posted by wolfi323 View Post
    Und zur Ergänzung:
    Um zu verhindern dass emfohlene ("recommended") Pakete automatisch installiert werden, gibts bei zypper die "--no-recommends" Option, also z.B.:
    Code:
    zypper in --no-recommends ownclod
    Sh. auch "zypper in --help".

    Oder du kannst es per default deaktivieren, indem du die Option "installRecommends = no" in /etc/zypp/zypper.conf setzt:
    Code:
    ## Do not install soft dependencies (recommended packages)
    ##
    ## Valid values: boolean
    ## Default value: yes
    ##
    # installRecommends = yes
    Systemweit gibts dann auch noch die Option "solver.onlyRequires" in /etc/zypp.conf, die global für den Solver gilt, also auch z.B. YaST beeinflusst:
    Code:
    ##
    ## Whether required packages are installed ONLY
    ## So recommended packages, language packages and packages which depend
    ## on hardware (modalias) will not be regarded.
    ##
    ## Valid values: boolean
    ## Default value: false
    ##
    # solver.onlyRequires = false
    Viel Dank euch beiden für die rasche und ausführliche Antwort

    @AdaLovelace
    Ich habe wohl ein Opt-in und kein Opt-Out erwartet, aber so ist es schlüssiger.

    @wolfi323
    Sieht nach einem praktischen Befehl aus von dem ich noch nicht wusste ^^ vor allem das man Recommends generell unterdrücken kann.

    Bin leider erst jetzt zum Weiterarbeiten an meiner kleiner Homecloud gekommen, deshalb auch die verspätete Antwort.

    lg r

  5. #5

    Default Re: Fehler bei Owncloud-RPM-Requirements (v7.0.4)?

    Ich weiß jetzt nicht genau wie es gehandhabt wird aber aus meiner Sicht kann der Thread geschlossen werden.

    Solved and solution provided!

  6. #6

    Default Re: Fehler bei Owncloud-RPM-Requirements (v7.0.4)? - GELÖST

    Quote Originally Posted by ramuel View Post
    Ich weiß jetzt nicht genau wie es gehandhabt wird aber aus meiner Sicht kann der Thread geschlossen werden.
    Threads werden hier nicht geschlossen.

    Du kannst aber ein "GELÖST", "SOLVED" oder so beim Titel anhängen wenn du willst.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •