Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

  1. #1

    Default GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    Hi all,

    I use the GMT software suite, which I normally download from the openSUSE Application:Geo site.
    After upgrading from 13.1 to 13.2 I discovered that the GMT software from this site needs the HDF5
    library v1.8.11 whereas the openSUSE 13.2 uses the HDF5 library v1.8.13. This causes a lot of conflicts
    and my GMT shell scripts are not working anymore!!

    Is somebody out there who can give me some advice?

    Any help greatly appreciated and a happy New Year to you all,

    Uwe.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,127

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    You did not explain how you "upgraded" from 3.1 to 13.2. Did you not forget to change your Geo repos' URL to the 13.2 version?

    Just an idea.
    Henk van Velden

  3. #3

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    Hi Henk,

    of course I changed everything accordingly.

    Greetings,

    Uwe.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,127

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    Quote Originally Posted by unass View Post
    .. . of course ...
    Maybe logical for you, but difficult to be sure of from this distance.

    Isn't is possible to contact the packager or the builder of this product?
    Henk van Velden

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    On 2015-01-02 14:56, unass wrote:
    >
    > Hi Henk,
    >
    > of course I changed everything accordingly.


    You could verify it...

    Code:
    rpm -q -a --queryformat "%{INSTALLTIME}\t%{INSTALLTIME:day} \
    %{BUILDTIME:day} %-30{NAME}\t%15{VERSION}-%-7{RELEASE}\t%{arch} \
    %25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}\n" \
    | sort | cut --fields="2-" | tee rpmlist \
    | egrep -v "openSUSE.13\.2" | less -S
    Any output is suspect. Maybe right, maybe not.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,270
    Blog Entries
    2

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    From what you posted, I don't suspect an upgrade issue, the app upgrade went well but your custom scripts are broken? Or are the broken scripts part of the app?

    If the broken scripts are custom, you may need to modify the scripts by simply using something like sed to replace the required character strings specifying the library version.

    If the broken scripts are part of the packages, then you might be able to fix them yourself as I described above but a bug should be opened at http://bugzilla.opensuse.org

    TSU

  7. #7

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    I use the GMT software suite, which I normally download from the openSUSE Application:Geo site.
    After upgrading from 13.1 to 13.2 I discovered that the GMT software from this site needs the HDF5
    library v1.8.11 whereas the openSUSE 13.2 uses the HDF5 library v1.8.13.
    have you set the GEO repo priority ?
    to force the system to use the hdf5 from the geo repo
    set it's priority lower than 99

    HOWEVER the current version i have installed from the geo repo is
    Code:
    Repository: Application:Geo
    Name: hdf5
    Version: 1.8.14-59.6
    Arch: x86_64
    Vendor: obs://build.opensuse.org/Application:Geo
    Installed: Yes
    Status: up-to-date
    Installed Size: 3.5 MiB



  8. #8

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    Hi all,

    thanks for your advices, but...... I have now installed both libraries libhdf5-9 and libhdf5-8 and also
    both libraries libhdf5-hl9 and libhdf5-hl8. I always get the error:

    Headers are 1.8.11, library is 1.8.13

    Any other hints?

    Uwe.

  9. #9

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    then you are likely not using the version from the geo repo
    you did not set the prioritey for the geo repo
    and THAT WILL cause conflicts

    please post the output
    Code:
    su -
    zypper info hdf5
    that will tell yopu what repo it is from



  10. #10

    Default Re: GMT (Generic Mapping Tools Graphics) and SuSE 13.2

    Quote Originally Posted by JohnVV View Post
    then you are likely not using the version from the geo repo
    you did not set the prioritey for the geo repo
    and THAT WILL cause conflicts

    please post the output
    Code:
    su -
    zypper info hdf5
    that will tell yopu what repo it is from
    Hi JohnVV,

    I now REALLY use the Application:Geo packages.

    zypper info gmt gives:

    "Information for package GMT:
    ----------------------------
    Repository: Geo
    Name: GMT
    Version: 5.1.1-2.10
    Arch: x86_64
    Vendor: obs://build.opensuse.org/Application:Geo
    Installed: Yes"

    zypper info hdf5 gives:

    "Information for package hdf5:
    -----------------------------
    Repository: Geo
    Name: hdf5
    Version: 1.8.14-59.6
    Arch: x86_64
    Vendor: obs://build.opensuse.org/Application:Geo
    Installed: Yes"

    When I now use gmt I got

    "gmt: error while loading shared libraries: libhdf5_hl.so.8: cannot open shared object file: No such file or directory"

    and

    "gmt: error while loading shared libraries: libhdf5.so.8: cannot open shared object file: No such file or directory"

    I then linked this two *.8 libraries to the *.9 libraries and got

    "Headers are 1.8.11, library is 1.8.14"

    So I think, that the gmt binaries are still looking for the old library version 1.8.11. What's next?

    Thanks again for your help,

    Uwe.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •