Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Unable to install updates

  1. #1

    Default Unable to install updates

    Hey all, I have a Dell Latitude D630 running 13.1 with a Core 2 Duo, 250GB SSD and 8 gigs of RAM and I can't get it to install updates. When I click on the update bug in the lower right-hand corner I get this error:

    Code:
    The package glibc is essential to correct operation and cannot be removed using this tool.
    When I try to run zypper update from a terminal I get variations of this error:

    Code:
    Retrieving: vorbis-tools-1.4.0-14.1.1_14.4.1.x86_64.drpm .......................................................................[done]
    Applying delta: ./vorbis-tools-1.4.0-14.1.1_14.4.1.x86_64.drpm .................................................................[done]
    (  1/591) Installing: libvpx1-1.3.0-51.1 ......................................................................................[error]
    Installation of libvpx1-1.3.0-51.1 failed:
    Error: Subprocess failed. Error: RPM failed: error: db4 error(-30986) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30986) getting "System/Libraries" records from Group index
    error: libvpx1-1.3.0-51.1.x86_64: install failed
    
    
    Abort, retry, ignore? [a/r/i] (a): a
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    
    Please see the above error message for a hint.
    I tried Retry a few times on some of my previous attempts at updating this machine but no joy.

    This is a new install of OpenSUSE. I did have a problem getting the wireless card to work but the following command got me up and running:

    Code:
    su -c "echo blacklist b43 > /etc/modprobe.d/50-b43.conf"
    I checked the last couple of entries in dmesg but I have no idea what I'm reading:

    Code:
    [  121.909785] SFW2-INext-DROP-DEFLT IN=enp9s0 OUT= MAC= SRC=fe80:0000:0000:0000:021c:23ff:fe3f:b3b8 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44 
    [  185.917974] SFW2-INext-DROP-DEFLT IN=enp9s0 OUT= MAC= SRC=fe80:0000:0000:0000:021c:23ff:fe3f:b3b8 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44 
    [  201.226109] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
    [  313.922246] SFW2-INext-DROP-DEFLT IN=enp9s0 OUT= MAC= SRC=fe80:0000:0000:0000:021c:23ff:fe3f:b3b8 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44 
    [  569.952332] SFW2-INext-DROP-DEFLT IN=enp9s0 OUT= MAC= SRC=fe80:0000:0000:0000:021c:23ff:fe3f:b3b8 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44 
    Sutude:/home/jobee #
    I Googled the glibc error but I found nothing regarding my update problem. Does anyone see anything in the above error messages?

    Thanks,

    Joe B

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Unable to install updates

    Please can we see

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Unable to install updates

    Oh yeah, I added the Packman repository because of the wireless issue. I've also Refreshed and Cleaned the repositories a few times.

    Thanks,

    Joe B

  4. #4

    Default Re: Unable to install updates

    Hi caf4926, here's the zypper lr -d:

    Code:
    Sutude:/home/jobee # zypper lr -d
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
     1 | ftp.gwdg.de-suse          | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                           |        
     2 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Lexar_USB_Flash_Drive_AADERAIXQUTEOS5U-0:0-part2 |        
     3 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                     |        
     4 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                                    |        
     5 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                            |        
     6 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                       |        
     7 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                           |        
     8 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/                    |        
     9 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                          |        
    10 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                  |        
    Sutude:/home/jobee #
    I just saw my Flash Drive (install media) and removed it, reran Zypper Update but still no joy.

    Thanks,

    Joe B

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Unable to install updates

    OK
    Please try the following

    Code:
    zypper clean --all
    Code:
    zypper ref
    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Unable to install updates

    Well, I got quite a bit further this time. I made it all the way through the downloads and then this happened:

    Code:
    Retrieving package gnome-online-accounts-3.10.5-14.7.x86_64                                         (584/584), 344.9 KiB (  1.0 MiB unpacked)
    Retrieving delta: ./x86_64/gnome-online-accounts-3.10.1_3.10.5-1.1_14.7.x86_64.drpm, 50.1 KiB
    Retrieving: gnome-online-accounts-3.10.1_3.10.5-1.1_14.7.x86_64.drpm ..................................................................[done]
    Applying delta: ./gnome-online-accounts-3.10.1_3.10.5-1.1_14.7.x86_64.drpm ............................................................[done]
    (  1/584) Installing: libva1-1.2.1-2.2.1 .............................................................................................[error]
    Installation of libva1-1.2.1-2.2.1 failed:
    Error: Subprocess failed. Error: RPM failed: error: db4 error(-30986) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30986) getting "System/Libraries" records from Group index
    error: libva1-1.2.1-2.2.1.x86_64: install failed
    
    
    Abort, retry, ignore? [a/r/i] (a):
    What do you suggest next?

    Thanks,

    Joe B

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Unable to install updates

    OK
    Lets try this

    Code:
    zypper rr 1
    Code:
    zypper ar -f http://packman.inode.at/suse/openSUSE_13.1/ packman
    Code:
    zypper ref
    Code:
    zypper dup --from packman
    always select the change to packman versions

    then
    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Unable to install updates

    Hi,

    You can try to rebuild the rpm data base.

    Code:
    rpm  --rebuilddb
    for a more verbose output

    Code:
    rpm -vv --rebuilddb
    But that output is so fast you need to be a meta human to catch it all . You can log the output to tmp ( or some place and some arbitrary file name ) and review it later.

    Code:
    rpm -vv --rebuilddb > >(tee -a /tmp/rpmrebuilddb.log) 2>&1
    Good Luck.
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Unable to install updates

    Quote Originally Posted by jetchisel View Post
    Hi,

    You can try to rebuild the rpm data base.

    Code:
    rpm  --rebuilddb
    for a more verbose output

    Code:
    rpm -vv --rebuilddb
    But that output is so fast you need to be a meta human to catch it all . You can log the output to tmp ( or some place and some arbitrary file name ) and review it later.

    Code:
    rpm -vv --rebuilddb > >(tee -a /tmp/rpmrebuilddb.log) 2>&1
    Good Luck.

    Hey, good point
    Try it
    It completely slipped my mind
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Unable to install updates

    --> caf4926, I got as far as zypper dup --from packman and made it to here:

    Code:
    Retrieving: sox-14.4.1-38.2.x86_64.rpm ................[done (52.9 KiB/s)]
    ( 1/49) Installing: libmediastreamer_base3-2.9.0-3.4 ..............[error]
    Installation of libmediastreamer_base3-2.9.0-3.4 failed:
    Error: Subprocess failed. Error: RPM failed: error: db4 error(-30986) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30986) getting "System/Libraries" records from Group index
    error: libmediastreamer_base3-2.9.0-3.4.x86_64: install failed
    error: libmediastreamer_base3-2.9.0-3.1.1.x86_64: erase skipped
    
    
    Abort, retry, ignore? [a/r/i] (a):
    Next up is jetchisel's reccommendaion to rebuild the database...

    Thanks,

    Joe B

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •