Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to disable automounting in 13.2?

  1. #1

    Default How to disable automounting in 13.2?

    I disabled automounting in previous versions of OS successfuly but this time I don't have a clue how to do it?

    Whenever I plug in USB drive it is automounted -- in my case it is not desired effect. I would like to mount and unmount device manully only.

    So how to disable automount?

    I already have file
    Code:
    /etc/udev/rules.d/85-no-automount.rules
    with content

    Code:
    SUBSYSTEMS=="usb", ENV{UDISKS_AUTO}="0", ENV{UDISKS_IGNORE}="1"

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,893
    Blog Entries
    3

    Default Re: How to disable automounting in 13.2?

    Quote Originally Posted by truemacias View Post
    I disabled automounting in previous versions of OS successfuly but this time I don't have a clue how to do it?
    You need to tell us which desktop you are using.

    I'm using KDE, and it has never automounted anything, though I think I know how to configure it to do that.

    This is a function of your desktop environment -- whatever that is.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: How to disable automounting in 13.2?

    Thank you for your answer. I was using previous OS (11.4) for so many years that I forgot where and what I set up :-) I use KDE 3.5.10 (no joke).

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: How to disable automounting in 13.2?

    It should not be automounted you will get a notice and if you use the device and options if don't select an option no mount. If you need some security on usage look at configure desk top - Removable Devices. several options there and that is where you would turn off the mount if that is on. Also device action may help. If not tell us what you want or need to happen.

  5. #5

    Default Re: How to disable automounting in 13.2?

    @gogalthorp I am unable to understand the sentences you wrote.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: How to disable automounting in 13.2?

    Ok simple steps

    1) open Configure Desktop
    2) look at device actions and removable devices
    3) If they don't provide what you need tell use exactly what you need

    Default an inserted device is not auto-mounted. It is mounted if you choose to open it in anyway don't open it won't be mounted.
    remove the device action associated with USBs and won't mount any way but command line or if you browse for it. Or more drasticly you can remove the dev notifier. With out know exactly what you want to accomplish we have no way to know exactly how to help but point you to existing tools.

  7. #7

    Default Re: How to disable automounting in 13.2?

    Quote Originally Posted by gogalthorp View Post
    Ok simple steps

    1) open Configure Desktop
    Done.



    Quote Originally Posted by gogalthorp View Post
    2) look at device actions and removable devices
    There is no such thing.


    After some googling I sense I am (and days of KDE 3.5.10) doomed -- KDE assumed and relied on existence of HAL.

    So if automounting is desktop environment responsibility it might be the case for KDE 3.5.10 it is no longer solvable.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: How to disable automounting in 13.2?

    I'm wondering if perhaps
    Code:
    SUBSYSTEMS=="usb", ENV{UDISKS_AUTO}="0", ENV{UDISKS_IGNORE}="1"
    might need to be
    Code:
    SUBSYSTEMS=="usb", ENV{UDISKS_AUTO}="0", ENV{UDISKS_IGNORE}:="1"
    just in case some other rule is changing the device property value later.
    Code:
    ":="Assign  a  value  to  a key finally; disallow any later changes.

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: How to disable automounting in 13.2?

    Oh dear I missed that you were running KDE 3.5. I got no idea. In 4.X it is default not to mount on insertion.

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,495
    Blog Entries
    2

    Default Re: How to disable automounting in 13.2?

    IMO you might have more success asking your question in the KDE forums since I doubt that KDE 3.5 would be using something in a modern openSUSE to mount (although who knows? Could someone have built some kind of kludge up to 13.1 to emulate a HAL when it should have been removed long ago? If some kludge existed, then maybe the solution might be to install 13.1 with KDE 3.5, then upgrade to 13.2).

    In the meantime, there is one possible Google hit,
    - If a "plugdev" group exists, remove your user from that group
    http://www.linuxquestions.org/questi...nt-kde-891757/

    My recommendation is...
    If your primary concern is using KDE 3.5 apps, AFAIK you can still install those apps in a KDE 4.x environment. You'd be running KDE 4.x with all its improvements and goodness (stable for some time now) but you can run your familiar legacy apps. If you do this, then you should be able to disable automounting using KDE 4.x methods.

    HTH,
    TSU

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •