Results 1 to 2 of 2

Thread: Can not find vncserver on OpensSuse 13.2

  1. #1

    Default Can not find vncserver on OpensSuse 13.2

    I have the following installed on my OpenSuse 13.2 machine.
    • x11vnc-0.9.13-9.1.4.x86_64
    • tigervnc-1.3.1-6.3.1.x86_64
    • xorg-x11-Xvnc-7.6_1.12.3-1.5.1.x86_64
    • libgtk-vnc-2_0-0-0.5.3-2.1.4.x86_64
    • gtk-vnc-lang-0.5.3-2.1.4.noarch
    • libgvnc-1_0-0-0.5.3-2.1.4.x86_64
    • libvncserver0-0.9.9-10.2.1.x86_64
    • libgtk-vnc-1_0-0-0.5.3-2.1.4.x86_64


    But no vncserver executable is found . On my Suse 13.1 , vncserver is provide by tightvnc-1.3.10-14.2.1.x86_64 and that package appears to not be available on OpenSuse 13.2.

    Any help would be appreciated . thank you.
    Keith

  2. #2

    Default AW: Can not find vncserver on OpensSuse 13.2

    Quote Originally Posted by keithvbk View Post
    But no vncserver executable is found . On my Suse 13.1 , vncserver is provide by tightvnc-1.3.10-14.2.1.x86_64 and that package appears to not be available on OpenSuse 13.2.
    On my 13.2 system:
    Code:
    wolfi@linux-lf90:~> rpm -qf `which vncserver`
    xorg-x11-Xvnc-1.3.1-6.14.1.x86_64
    You have xorg-x11-Xvnc-7.6_1.12.3-1.5.1.x86_64 installed, that's the package from openSUSE 12.2!
    Upgrade the package to the version included in 13.2 and you should have your vncserver executable.
    Code:
    sudo zypper in -f xorg-x11-Xvnc
    And please post your repo list, maybe something is wrong there. There must be a reason why you still have that 12.2 package installed...
    Code:
    zypper lr -d
    Your other packages seem to be the 13.2 versions. Probably you didn't correctly upgrade to 13.2, as 7.6_1.12.3 is a higher version than 1.3.1, "zypper up" e.g. will not install the newer version in that case. "zypper dup" is what you have to use for upgrades, that will handle such a situation correctly, if your repos are correct.
    But you should update your system, there are two newer tigervnc packages in the update repo already...
    Last edited by wolfi323; 30-Dec-2014 at 11:22.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •