Results 1 to 9 of 9

Thread: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

  1. #1

    Default cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    on my PC=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz, OS=opensuse 13.1 KDE= 4.14.3 kernel=3.11.10-25-desktop
    I installed phlip and
    cups - The Common UNIX Printing System Installed Version:1.7.5-2.1
    from http://download.opensuse.org/reposit...openSUSE_13.1/
    switching the packages
    it seems the only way to have my printer HP laserjet cp1025nw to work properly
    but very often cups fail to start, I have to go to yast2>services manager and start cups and cupsd manually
    is there any solution to solve this??

    manythanks, ciao :-) pier

  2. #2

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    Hi,

    in that place where you start cups via yast there is also an option to enable that cups service. or you can enable it via cli with sysmtemctl (If it is not enabled already)

    Check for the status

    Code:
    systemctl status cups
    Start the service

    Code:
    systemctl start cups
    Enable the service (start at boot time)

    Code:
    systemctl enable cups
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  3. #3

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    Quote Originally Posted by jetchisel View Post
    Hi,

    in that place where you start cups via yast there is also an option to enable that cups service. or you can enable it via cli with sysmtemctl (If it is not enabled already)
    ...yes it was and it is enabled, but often it result enabled and inactive
    now not:
    Code:
    pla@suseST-pla:~> systemctl status cups
    cups.service - CUPS Printing Service
       Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
       Active: active (running) since Mon 2014-12-22 07:03:18 CET; 12h ago
     Main PID: 988 (cupsd)
       CGroup: /system.slice/cups.service
               └─988 /usr/sbin/cupsd -f
    
    Dec 22 07:03:18 suseST-pla.lap systemd[1]: Starting CUPS Printing Service...
    Dec 22 07:03:18 suseST-pla.lap systemd[1]: Started CUPS Printing Service.
    Dec 22 09:43:15 suseST-pla.lap hp[17985]: prnt/backend/hp.c 375: read new pjl status: 10023
    pla@suseST-pla:~>
    Quote Originally Posted by jetchisel View Post
    Check for the status

    Code:
    systemctl status cups
    Start the service

    Code:
    systemctl start cups
    Enable the service (start at boot time)

    Code:
    systemctl enable cups
    ...as it is not my laptop but my son's one, in case the problem be hard, is it possible to have a script/icon-on-desktop to click to start cups when it needs?? :-)
    manythanks, :-) ciao :-) pier

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,398
    Blog Entries
    1

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    [QUOTE=pier_andreit;2684660]...yes it was and it is enabled, but often it result enabled and inactive
    now not:[/QUOTE
    Some users have had problems with socket activation which was brought in with the move to using systemd. Maybe you're being impacted by that?

    https://bugzilla.novell.com/show_bug.cgi?id=861734#c3
    https://forums.opensuse.org/showthre...81#post2620581

  5. #5

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    Quote Originally Posted by deano_ferrari View Post
    Quote Originally Posted by pier_andreit View Post
    ...yes it was and it is enabled, but often it result enabled and inactive
    now not:
    Some users have had problems with socket activation which was brought in with the move to using systemd. Maybe you're being impacted by that?

    https://bugzilla.novell.com/show_bug.cgi?id=861734#c3
    https://forums.opensuse.org/showthre...81#post2620581
    well I can try,
    reading #44 https://forums.opensuse.org/showthre...06#post2619906
    I get this:
    make a file called /etc/systemd/system/cups.socket (I suppose not /etc/systemd/system/cupsd.socket as written in #44)
    reading #47 https://forums.opensuse.org/showthre...89#post2619989
    I get this:
    the content of the file is:
    Code:
    [Unit]
    Description=CUPS Printing Service Sockets
    
    [Socket]
    ListenStream=/var/run/cups/cups.sock
    ListenStream=0.0.0.0:631
    ListenDatagram=0.0.0.0:631
    BindIPv6Only=ipv6-only
    
    [Install]
    WantedBy=sockets.target
    but I cannot know where to put what is in #48 https://forums.opensuse.org/showthre...81#post2620581
    Code:
    [Unit]
    Description=CUPS Printing Service
    After=network.target
    
    [Service]
    ExecStart=/usr/sbin/cupsd -f
    
    [Install]
    WantedBy=multi-user.target
    and also this command produce this error:
    Code:
    pla@suseST-pla:~> sudo systemctl enable cups.socket
    root's password:
    Failed to issue method call: File exists
    pla@suseST-pla:~>


    ...manythanks if you can make this more clear for me... :-) ciao :-) pier

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,398
    Blog Entries
    1

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    Your mixing two different approaches. The first related to modifying cups.socket (and keeping socket activation).
    Quote Originally Posted by pier_andreit View Post
    well I can try,
    reading #44 https://forums.opensuse.org/showthre...06#post2619906
    I get this:
    make a file called /etc/systemd/system/cups.socket (I suppose not /etc/systemd/system/cupsd.socket as written in #44)
    reading #47 https://forums.opensuse.org/showthre...89#post2619989
    I get this:
    the content of the file is:
    Code:
    [Unit]
    Description=CUPS Printing Service Sockets
    
    [Socket]
    ListenStream=/var/run/cups/cups.sock
    ListenStream=0.0.0.0:631
    ListenDatagram=0.0.0.0:631
    BindIPv6Only=ipv6-only
    
    [Install]
    WantedBy=sockets.target
    The following is a second approach to remove socket activation, and have cups.service running at boot
    but I cannot know where to put what is in #48 https://forums.opensuse.org/showthre...81#post2620581
    Code:
    [Unit]
    Description=CUPS Printing Service
    After=network.target
    
    [Service]
    ExecStart=/usr/sbin/cupsd -f
    
    [Install]
    WantedBy=multi-user.target
    I'm not sure that you need to apply these approaches. Your problem might be due to something else. I don't know why you updated to CUPS 1.7.x. Were you having problems prior to upgrading? Maybe your problem lies with the upgrade?
    Last edited by deano_ferrari; 23-Dec-2014 at 02:36.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,398
    Blog Entries
    1

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    it seems the only way to have my printer HP laserjet cp1025nw to work properly
    but very often cups fail to start, I have to go to yast2>services manager and start cups and cupsd manually
    is there any solution to solve this??
    Starting from the top...

    1. If I understand your first post, you mentioned that you needed CUPS 1.7.x to have your printer supported, is that correct?
    2. Is it network-attached, or via USB?
    3. Is cups.service inactive after boot?
    Code:
    systemctl status cups
    and if so, do you always need to start it before printing?

  8. #8

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    Quote Originally Posted by deano_ferrari View Post
    Starting from the top...
    ..ok :-)

    Quote Originally Posted by deano_ferrari View Post
    1. If I understand your first post, you mentioned that you needed CUPS 1.7.x to have your printer supported, is that correct?
    yes, correct, with cups 1.7 works with 1.5 don't works
    Quote Originally Posted by deano_ferrari View Post
    2. Is it network-attached, or via USB?
    via USB works, via network not
    Quote Originally Posted by deano_ferrari View Post
    3. Is cups.service inactive after boot?
    often yes, it is enabled and inactive
    Code:
    systemctl status cups
    Code:
    pla@suseST-pla:~> systemctl status cups
    cups.service - CUPS Printing Service
       Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
       Active: inactive (dead)
    
    pla@suseST-pla:~>

    Quote Originally Posted by deano_ferrari View Post
    and if so, do you always need to start it before printing?
    yes, when it is inactive I need to start it before printing and it works...
    manythanks, :-) ciao :-) pier

  9. #9

    Default Re: cups 1.7.5-2.1 in opensuse 13.1 often fail to start

    it seems solved putting
    Code:
     systemctl restart cups.service
    in /etc/init.d/after.local
    I have to try in network connection if it works... manythanx, ciao :-) pier and merry christmas.. :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •