Results 1 to 10 of 10

Thread: /boot/efi -comando

  1. #1
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default /boot/efi -comando

    Greetings to all , I present the problem :
    os suse13.2 disk SSD samsung 840
    windows 7 professional disk SSD 850 pro .
    More mechanical disk for data music etc ...
    everything works wonderfully with dual boot efi , now the question is in msdos partitions / legacy , if aggiornavo the kernel , not by default, so the current kernel3.18.1-1 xx with the command
    grub2 - mkconfig -o /boot/grub2/grub.cfg
    the system immaggine recreated the new kernel , mà having efi partition to separate fat of 500 MB , I can not give that command to enable the new kernel downloaded from
    http://download.opensuse.org/repositories/
    that give the shell command to enable the new Kernel sorry for my bad English

    thank you

  2. #2
    Join Date
    Sep 2012
    Posts
    5,115

    Default Re: /boot/efi -comando

    I suspect you have secure boot enabled in firmware. Try disable it.

  3. #3
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: /boot/efi -comando

    sorry
    Thanks for the answer , but maybe I have explained evil , then I will be more exhaustive .
    My discs are two SSD here one mounts the os windows 7 professional and more
    SSD mounts opensuse 13.2 , partitioned in this way :
    partition / boot / efi in fat 16/32 500 MB
    partition /
    the swapp
    and / home .
    Both systems are gpt , then Mode UEFI / efi , installed in dualboot and all part so well, the dualboot is managed by the / boot / efi of opensuse , with secure boot enabled .
    In suse 13.1 I had the SSD , so the partitions were not gpt and I had the motherboard with UEFI bios , so I used legacy , and installavo the kernel does not default os suse but unloaded and installavo from : http : // download.opensuse.org/repositories/
    once the installavo yast , before restarting the PC , I loaded the kernel with the command
    # gru2 - mkconfig -o /boot/grub2/grub.cfg .
    Now that the system boot / efi is in a dedicated partition , ie / dev / sdc1 / boot / efi , if I install the kernel the last kernel3.18.1-1 .... as is the command to be given to enable the new kernel in the partition for / boot / efi to start the system with the new kernel .
    thank you

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: /boot/efi -comando

    I'm still a bit confused. kernels do not live in the EFI boot partition. Perhaps it is better if you just show us?

    Can you boot to Linux? if so show use output of

    Code:
    fdisk -l
    Please place it in code tages. the # sign in the boards editor window so to keep the format

    the EFI boot partition formatted as FAT only contains code to start grub. It is mounted as /boot/efi on the openSUSE directory tree.

    As a wild guess you seem to be having problems moving to EFI boot from msdos (MBR) boot??? Is this the problem?

  5. #5
    Join Date
    Sep 2012
    Posts
    5,115

    Default Re: /boot/efi -comando

    There is no difference in bootloader configuration between legacy and EFI. When you install new kernel RPM, it normally is added automatically to bootloader menu. Or you can use grub2-mkconfig manually. I still do not understand your problem. Is new kernel missing in bootloader menu? New kernel is present but is not able to boot?

  6. #6
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: /boot/efi -comando

    Code:
    Disk /dev/sda: 238,5 GiB, 256060514304 bytes, 500118192 sectors
    
     Units: sectors of 1 * 512 = 512 bytes
     Sector size (logical/physical): 512 bytes / 512 bytes
     I/O size (minimum/optimal): 512 bytes / 512 bytes
     Disklabel type: gpt
     Disk identifier: 085DA340-B78A-4F53-971D-4507370680BB
     
     
     Device      Start       End   Sectors   Size Type
     /dev/sda1    2048    206847    204800   100M EFI System
     /dev/sda2  206848    468991    262144   128M Microsoft reserved
     /dev/sda3  468992 450068479 449599488 214,4G Microsoft basic data
     
     
     Disk /dev/sdb: 1,4 TiB, 1500301910016 bytes, 2930277168 sectors
     Units: sectors of 1 * 512 = 512 bytes
     Sector size (logical/physical): 512 bytes / 512 bytes
     I/O size (minimum/optimal): 512 bytes / 512 bytes
     Disklabel type: gpt
     Disk identifier: FF25DF4F-3A40-45AE-94BD-557FCA6379E2
     
     
     Device         Start        End    Sectors   Size Type
     /dev/sdb1       2048  844253183  844251136 402,6G Microsoft basic data
     /dev/sdb4  844253184 2930276351 2086023168 994,7G Microsoft basic data
     
     
     Disk /dev/sdc: 477 GiB, 512110190592 bytes, 1000215216 sectors
     Units: sectors of 1 * 512 = 512 bytes
     Sector size (logical/physical): 512 bytes / 512 bytes
     I/O size (minimum/optimal): 512 bytes / 512 bytes
     Disklabel type: gpt
     Disk identifier: D38110B3-8545-4F77-8CE9-B148C7F2402D
     
     
     Device         Start       End   Sectors   Size Type
     /dev/sdc1       2048   1028095   1026048   501M Microsoft basic data
     /dev/sdc2    1028096  95393791  94365696    45G Microsoft basic data
     /dev/sdc3   95393792 103780351   8386560     4G Microsoft basic data
     /dev/sdc4  103780352 910571519 806791168 384,7G Microsoft basic data
    @arvidjaar

    exact not start even giving the command

    Code:
    gbub2-mkconfig -o /boot/grub2/grub.cfg
    @gogalthorp

    nothing msdos mbr , only efi

  7. #7
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: /boot/efi -comando

    So the command
    Code:
    
        
        
        
        
    # Grub2-mkconfig -o /boot/grub2/grub.cfg
    launches , be it in a partition system msdos , that a system with partition efi ?

  8. #8
    Join Date
    Sep 2012
    Posts
    5,115

    Default Re: /boot/efi -comando

    Quote Originally Posted by dragoncello21 View Post
    exact not start even giving the command
    If new kernel does not start I'm sure it is related to secure boot. As already suggested, check if secure boot is disabled in BIOS settings.

  9. #9
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: /boot/efi -comando

    solved as mentioned, the disabled secure boot and everything ok thank you all and Merry Christmas

  10. #10
    Join Date
    Dec 2014
    Location
    Roma
    Posts
    62

    Default Re: /boot/efi -comando (solved)

    solved as mentioned, the disabled secure boot and everything ok thank you all and Merry Christmas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •