Results 1 to 7 of 7

Thread: clamav update bug

  1. #1

    Default clamav update bug

    Hi,

    I updated my clamav 0.98.4 to 0.98.5 because clamav 0.98.5 security update was released.

    After update clamd can not start and I found an error message in the log:

    clamd daemon 0.98.5 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
    Running as user vscan (UID 65, GID 480)
    Log file size limited to 1048576 bytes.
    Reading databases from /var/lib/clamav
    Not loading PUA signatures.
    Bytecode: Security mode set to "TrustSigned".
    Loaded 3703456 signatures.
    ERROR: TCP: getaddrinfo failed: Address family for hostname not
    supported

    If I downgrage clamav to 0.98.4 then this earlier version can start and work me...

    Can somebody talk to me what is the problem? Is it a clamav 0.98.5 bug?

    Thanks.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: clamav update bug

    On 2014-12-21 12:46, iSipi wrote:
    >
    > Hi,
    >
    > I updated my clamav 0.98.4 to 0.98.5 because clamav 0.98.5 security
    > update was released.


    Updated how? What repo? Some other manual method?

    What distribution version are you using?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3

    Default Re: clamav update bug

    Sorry, I forgotten these..

    I updated clamav from openSUSE 13.1 official update repo (http://download.opensuse.org/update/13.1/x86_64/)
    I updated it by Yast (clamav-0.98.5-22.3.x86_64.rpm)
    openSUSE 13.1 x86_64

    If it help then package's maintainer is Marcus Meissner

    Thanks

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: clamav update bug

    On 2014-12-21 16:26, iSipi wrote:
    >
    > Sorry, I forgotten these..
    >
    > I updated clamav from openSUSE 13.1 official update repo
    > (http://download.opensuse.org/update/13.1/x86_64/)
    > I updated it by Yast (clamav-0.98.5-22.3.x86_64.rpm)
    > openSUSE 13.1 x86_64


    Ok, then, the official 13.1 update.

    How exactly do you run clamd? I don't see any problem with mine.

    Code:
    Telcontar:~ # rcclamd restart
    redirecting to systemctl restart clamd.service
    Telcontar:~ # rcclamd status
    Checking for Clam AntiVirus daemon                                                   running
    clamd.service - LSB: virus scanner daemon
    Loaded: loaded (/etc/init.d/clamd)
    Active: active (running) since Sun 2014-12-21 17:54:35 CET; 12s ago
    Process: 8996 ExecStop=/etc/init.d/clamd stop (code=exited, status=0/SUCCESS)
    Process: 9011 ExecStart=/etc/init.d/clamd start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/clamd.service
    └─9032 /usr/sbin/clamd
    
    Telcontar:~ #
    Telcontar:~ # rpm -q clamav
    clamav-0.98.5-22.3.x86_64
    Telcontar:~ #


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  5. #5

    Default Re: clamav update bug

    I run clamd automatically on boot. I enabled it Runlevel Services in Yast.

    After update I restarted my pc and clamd won't start

    +++ Started at Sun Dec 21 18:28:17 2014
    clamd daemon 0.98.5 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
    Running as user vscan (UID 65, GID 480)
    Log file size limited to 1048576 bytes.
    Reading databases from /var/lib/clamav
    Not loading PUA signatures.
    Bytecode: Security mode set to "TrustSigned".
    Loaded 3713238 signatures.
    ERROR: TCP: getaddrinfo failed: Address family for hostname not supported

    Then I can start it manually and works but after every restart I need clamd start manually.

    I read this https://bbs.archlinux.org/viewtopic.php?id=191123 now but suse package uses init.d to start clamd... I tried in moment, what will be happened if I add to init script $network prequisition for Required-Start and I experinced it that clamd can start after reboot...

    I think it is a bug but I don't understand it perfectly...

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: clamav update bug

    On 2014-12-21 18:56, iSipi wrote:
    >
    > I run clamd automatically on boot. I enabled it Runlevel Services in
    > Yast.
    >
    > After update I restarted my pc and clamd won't start


    How do find that out?


    Please, details and proofs, not only interpretations.


    > +++ Started at Sun Dec 21 18:28:17 2014
    > clamd daemon 0.98.5 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
    > Running as user vscan (UID 65, GID 480)
    > Log file size limited to 1048576 bytes.
    > Reading databases from /var/lib/clamav
    > Not loading PUA signatures.
    > Bytecode: Security mode set to "TrustSigned".
    > Loaded 3713238 signatures.
    > ERROR: TCP: getaddrinfo failed: Address family for hostname not
    > supported


    Where and how do you read that data from? If you are running a command,
    you did not paste it. If you get it from a file, you are not saying it.


    > Then I can start it manually and works but after every restart I need
    > clamd start manually.
    >
    > I read this https://bbs.archlinux.org/viewtopic.php?id=191123 now but
    > suse package uses init.d to start clamd... I tried in moment, what will
    > be happened if I add to init script $network prequisition for
    > Required-Start and I experinced it that clamd can start after reboot...


    No. openSUSE uses systemd now, which is totally different.

    After booting, run this in a terminal:

    Code:
    su -
    systemctl status clamd.service
    and post here the entire chunk. And very important, please use code tags
    for pasting all that. Use the '#' button in the forum editor - for
    command outputs and listings


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7

    Default Re: clamav update bug

    I restarted the pc twice and clamd startd at boot normally.

    Code:
    sipi:~ # rcclamd status
    Checking for Clam AntiVirus daemon                                   running
    clamd.service - LSB: virus scanner daemon
       Loaded: loaded (/etc/init.d/clamd)
       Active: active (running) since v 2014-12-21 18:19:38 CET; 2h 36min ago
      Process: 2459 ExecStart=/etc/init.d/clamd start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/clamd.service
               └─3421 /usr/sbin/clamd
    
    
    sipi:~ # systemctl status clamd.service
    clamd.service - LSB: virus scanner daemon
       Loaded: loaded (/etc/init.d/clamd)
       Active: active (running) since v 2014-12-21 18:19:38 CET; 2h 36min ago
      Process: 2459 ExecStart=/etc/init.d/clamd start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/clamd.service
               └─3421 /usr/sbin/clamd
    
    
    dec 21 19:29:45 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 19:39:45 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 19:49:45 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 19:59:45 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 20:09:45 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 20:19:41 server2 clamd[3421]: Reading databases from /var/lib/clamav
    dec 21 20:19:46 server2 clamd[3421]: Database correctly reloaded (3713389 s...s)
    dec 21 20:29:46 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 20:39:46 server2 clamd[3421]: SelfCheck: Database status OK.
    dec 21 20:49:46 server2 clamd[3421]: SelfCheck: Database status OK.
    Hint: Some lines were ellipsized, use -l to show in full.
    clamd runs now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •