Results 1 to 7 of 7

Thread: ZoneMinder stopped working, getting "could not find driver" error

  1. #1
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Angry ZoneMinder stopped working, getting "could not find driver" error

    I've been running ZM for years on openSUSE 13.1 but suddenly I'm getting the following error when browsing to the webpage:

    "Unable to connect to ZM db.could not find driver"

    I haven't made any configuration changes so I'm guessing a recent update of either ZM or PHP is responsible for this. Any suggestions?

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,077

    Default Re: ZoneMinder stopped working, getting "could not find driver"error

    On Fri, 19 Dec 2014 16:56:01 +0000, DiskCrasher wrote:

    > I've been running ZM for years on openSUSE 13.1 but suddenly I'm getting
    > the following error when browsing to the webpage:
    >
    > "Unable to connect to ZM db.could not find driver"
    >
    > I haven't made any configuration changes so I'm guessing a recent update
    > of either ZM or PHP is responsible for this. Any suggestions?


    Where did you get the package to install ZoneMinder? I'm building a 13.1
    image to try this out with, and it doesn't seem to be in the standard
    repositories.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    63

    Default Re: ZoneMinder stopped working, getting "could not find driver"error

    Quote Originally Posted by hendersj View Post
    Where did you get the package to install ZoneMinder? I'm building a 13.1
    image to try this out with, and it doesn't seem to be in the standard
    repositories.
    I got it from the repository located at http://www.liquid-co.de/pub/suse/repositories/13.1/. Supposedly it now requires php-mysqlng which I don't see in the standard repositories either.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,077

    Default Re: ZoneMinder stopped working, getting "could not find driver"error

    On Wed, 31 Dec 2014 03:16:01 +0000, DiskCrasher wrote:

    > hendersj;2686139 Wrote:
    >>
    >> Where did you get the package to install ZoneMinder? I'm building a
    >> 13.1 image to try this out with, and it doesn't seem to be in the
    >> standard repositories.

    >
    > I got it from the repository located at
    > http://www.liquid-co.de/pub/suse/repositories/13.1/. Supposedly it now
    > requires php-mysqlng which I don't see in the standard repositories
    > either.


    I'm not familiar with that particular repository - you might check with
    the maintainer there to find out where to get the new dependency.
    There's not a lot the openSUSE project can do about content or packages
    maintained by third parties - sorry.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: ZoneMinder stopped working, getting "could not find driver"error

    Hello,

    Quote Originally Posted by DiskCrasher View Post
    I got it from the repository located at http://www.liquid-co.de/pub/suse/repositories/13.1/. Supposedly it now requires php-mysqlng which I don't see in the standard repositories either.
    It looks like I mad a type in the dpendencies I will look into this tomorrow.

    Greetings,
    Dirk

  6. #6
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: ZoneMinder stopped working, getting "could not find driver"error

    Hello,
    I've tried to reproduce this problem but I had no success. On my System (openSuSE 13.1) the webfrontend works without any problems.

    I think I need more info. Can you try to create a phpinfo page as described here http://php.net/manual/de/function.phpinfo.php and look at the "mysql" section.

    On my System it looks like this:


    It uses mysqlnd so it looks OK here.

    I have the following php5 packages installed:
    Code:
    rpm -qa | grep php5
    
    php5-xmlwriter-5.4.20-34.3.x86_64
    php5-pdo-5.4.20-34.3.x86_64
    php5-json-5.4.20-34.3.x86_64
    php5-dom-5.4.20-34.3.x86_64
    php5-mcrypt-5.4.20-34.3.x86_64
    php5-mysql-5.4.20-34.3.x86_64
    php5-zip-5.4.20-34.3.x86_64
    php5-iconv-5.4.20-34.3.x86_64
    php5-xmlreader-5.4.20-34.3.x86_64
    php5-sockets-5.4.20-34.3.x86_64
    php5-ctype-5.4.20-34.3.x86_64
    php5-mbstring-5.4.20-34.3.x86_64
    php5-sqlite-5.4.20-34.3.x86_64
    php5-gd-5.4.20-34.3.x86_64
    php5-5.4.20-34.3.x86_64
    php5-bz2-5.4.20-34.3.x86_64
    php5-zlib-5.4.20-34.3.x86_64
    php5-tokenizer-5.4.20-34.3.x86_64
    apache2-mod_php5-5.4.20-34.3.x86_64
    Please try to verify if you are using the same versions (or post back the result of the above command).

    Greetings,
    Dirk

  7. #7

    Default Re: ZoneMinder stopped working, getting "could not find driver" error

    Hi Everyone,
    I recently had the same thing happen on one of my Zoneminder servers. It turned out to be an issue with the /etc/zm.conf file.

    During an update from ZM 1.27 to 1.28 zm.conf was updated (and also a new zm.conf.rpmnew was created) When I diff ed them, I found that the .rpmnew file contained these lines:

    Code:
    # ZoneMinder database type: so far only mysql is supported
    ZM_DB_TYPE=mysql

    My normal/existing /etc/zm.conf file did not have these. After adding and restarting ZM, the connection works fine now.

    HTH someone else.

    -Joel

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •