Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Xlib: extension "GLX" missing on display ":8".

  1. #1
    Join Date
    Nov 2014
    Location
    Netherlands
    Posts
    49

    Default Xlib: extension "GLX" missing on display ":8".

    I've had a lot of trouble with bumblebee lately but it looks like it is finally almost working.
    `optirun glxspheres` output:
    Code:
    Polygons in scene: 62464
    Xlib:  extension "GLX" missing on display ":8".
    ERROR (610): Could not obtain RGB visual with requested properties
    Perhaps there is an easy fix for this...

  2. #2

    Default Re: Xlib: extension "GLX" missing on display ":8".

    Quote Originally Posted by hermanbergwerf View Post
    Code:
    Polygons in scene: 62464
    Xlib:  extension "GLX" missing on display ":8".
    ERROR (610): Could not obtain RGB visual with requested properties
    Perhaps there is an easy fix for this...
    Can you please post /var/log/Xorg.8.log? This should point to the problem.

    My suspicion: did you install the standard proprietary nvidia driver?
    You shouldn't! This will break Mesa's and intel's GLX. And the driver itself will probably not even work as it has provisions to bail out on Optimus systems, the packages in the standard nvidia repo at least.

    If you want to use the nvidia driver with Bumblebee, install the nvidia-bumblebee package from the Bumblebee repo.

    More information about how exactly you installed Bumblebee would be helpful as well, and some information about your openSUSE version and hardware, especially what nvidia card.

  3. #3
    Join Date
    Nov 2014
    Location
    Netherlands
    Posts
    49

    Default Re: Xlib: extension "GLX" missing on display ":8".

    nvidia-bumblebee gave errors for me (something like permission denied while I clearly was member of the video,bumblebee group)
    I installed the nvidia drivers and bumblebee from the opensuse 13.2 repository (after I notices bumblebee was also in the opensuse repository)
    I blocked nvidia-glG03 (after uninstalling it)
    I am using the default kernel (I switched to the default kernel because I hoped this might fix some dependencies or something)
    OpenGL is working perfectly on display :0 with my Intel HD (including GLX)
    Xorg.8.log:
    Code:
    [ 19172.240] X.Org X Server 1.16.1
    Release Date: 2014-09-21
    [ 19172.240] X Protocol Version 11, Revision 0
    [ 19172.240] Build Operating System: openSUSE SUSE LINUX
    [ 19172.240] Current Operating System: Linux opensuse 3.16.6-2-default #1 SMP Mon Oct 20 13:47:22 UTC 2014 (feb42ea) x86_64
    [ 19172.240] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.6-2-default root=UUID=7b1c8a97-24b0-4f5a-9f71-a465a3fc0e01 resume=/dev/sda1 splash=silent quiet showopts
    [ 19172.240] Build Date: 08 October 2014  05:49:10PM
    [ 19172.240]  
    [ 19172.240] Current version of pixman: 0.32.6
    [ 19172.240] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [ 19172.240] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 19172.240] (==) Log file: "/var/log/Xorg.8.log", Time: Tue Dec 16 22:11:56 2014
    [ 19172.240] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
    [ 19172.240] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
    [ 19172.240] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [ 19172.240] (==) ServerLayout "Layout0"
    [ 19172.240] (==) No screen section available. Using defaults.
    [ 19172.240] (**) |-->Screen "Default Screen Section" (0)
    [ 19172.240] (**) |   |-->Monitor "<default monitor>"
    [ 19172.240] (==) No device specified for screen "Default Screen Section".
    	Using the first device section listed.
    [ 19172.240] (**) |   |-->Device "DiscreteNvidia"
    [ 19172.240] (==) No monitor specified for screen "Default Screen Section".
    	Using a default monitor configuration.
    [ 19172.240] (**) Option "AutoAddDevices" "false"
    [ 19172.240] (**) Option "AutoAddGPU" "false"
    [ 19172.240] (**) Not automatically adding devices
    [ 19172.240] (==) Automatically enabling devices
    [ 19172.240] (**) Not automatically adding GPU devices
    [ 19172.240] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 19172.240] 	Entry deleted from font path.
    [ 19172.240] (==) FontPath set to:
    	/usr/share/fonts/misc:unscaled,
    	/usr/share/fonts/Type1/,
    	/usr/share/fonts/100dpi:unscaled,
    	/usr/share/fonts/75dpi:unscaled,
    	/usr/share/fonts/ghostscript/,
    	/usr/share/fonts/cyrillic:unscaled,
    	/usr/share/fonts/truetype/,
    	built-ins
    [ 19172.240] (++) ModulePath set to "/usr/lib64/nvidia/xorg/,/usr/lib64/xorg/modules"
    [ 19172.240] (==) |-->Input Device "<default pointer>"
    [ 19172.240] (==) |-->Input Device "<default keyboard>"
    [ 19172.240] (==) The core pointer device wasn't specified explicitly in the layout.
    	Using the default mouse configuration.
    [ 19172.240] (==) The core keyboard device wasn't specified explicitly in the layout.
    	Using the default keyboard configuration.
    [ 19172.240] (II) Loader magic: 0x80dc60
    [ 19172.240] (II) Module ABI versions:
    [ 19172.240] 	X.Org ANSI C Emulation: 0.4
    [ 19172.240] 	X.Org Video Driver: 18.0
    [ 19172.240] 	X.Org XInput driver : 21.0
    [ 19172.240] 	X.Org Server Extension : 8.0
    [ 19172.240] (II) xfree86: Adding drm device (/dev/dri/card1)
    [ 19172.240] (II) xfree86: Adding drm device (/dev/dri/card0)
    [ 19172.240] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
    [ 19172.241] (--) PCI:*(0:1:0:0) 10de:1391:1462:10e3 rev 162, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
    [ 19172.241] (II) LoadModule: "glx"
    [ 19172.241] (II) Loading /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    [ 19172.241] (EE) Failed to load /usr/lib64/nvidia/xorg/modules/extensions/libglx.so: /usr/lib64/nvidia/xorg/modules/extensions/libglx.so: cannot open shared object file: No such file or directory
    [ 19172.241] (II) UnloadModule: "glx"
    [ 19172.241] (II) Unloading glx
    [ 19172.241] (EE) Failed to load module "glx" (loader failed, 7)
    [ 19172.241] (II) LoadModule: "nvidia"
    [ 19172.241] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
    [ 19172.241] (II) Module nvidia: vendor="NVIDIA Corporation"
    [ 19172.241] 	compiled for 4.0.2, module version = 1.0.0
    [ 19172.241] 	Module class: X.Org Video Driver
    [ 19172.241] (II) LoadModule: "mouse"
    [ 19172.242] (II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
    [ 19172.242] (II) Module mouse: vendor="X.Org Foundation"
    [ 19172.242] 	compiled for 1.16.1, module version = 1.9.0
    [ 19172.242] 	Module class: X.Org XInput Driver
    [ 19172.242] 	ABI class: X.Org XInput driver, version 21.0
    [ 19172.242] (II) LoadModule: "kbd"
    [ 19172.242] (II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
    [ 19172.242] (II) Module kbd: vendor="X.Org Foundation"
    [ 19172.242] 	compiled for 1.16.1, module version = 1.8.0
    [ 19172.242] 	Module class: X.Org XInput Driver
    [ 19172.242] 	ABI class: X.Org XInput driver, version 21.0
    [ 19172.242] (II) NVIDIA dlloader X Driver  340.65  Tue Dec  2 08:47:36 PST 2014
    [ 19172.242] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
    [ 19172.242] (--) using VT number 7
    
    
    [ 19172.242] (II) Loading sub module "fb"
    [ 19172.242] (II) LoadModule: "fb"
    [ 19172.242] (II) Loading /usr/lib64/xorg/modules/libfb.so
    [ 19172.242] (II) Module fb: vendor="X.Org Foundation"
    [ 19172.242] 	compiled for 1.16.1, module version = 1.0.0
    [ 19172.242] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [ 19172.242] (WW) Unresolved symbol: fbGetGCPrivateKey
    [ 19172.242] (II) Loading sub module "wfb"
    [ 19172.242] (II) LoadModule: "wfb"
    [ 19172.242] (II) Loading /usr/lib64/xorg/modules/libwfb.so
    [ 19172.242] (II) Module wfb: vendor="X.Org Foundation"
    [ 19172.242] 	compiled for 1.16.1, module version = 1.0.0
    [ 19172.242] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [ 19172.242] (II) Loading sub module "ramdac"
    [ 19172.242] (II) LoadModule: "ramdac"
    [ 19172.242] (II) Module "ramdac" already built-in
    [ 19172.242] (II) NVIDIA(0): Creating default Display subsection in Screen section
    	"Default Screen Section" for depth/fbbpp 24/32
    [ 19172.242] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
    [ 19172.242] (==) NVIDIA(0): RGB weight 888
    [ 19172.242] (==) NVIDIA(0): Default visual is TrueColor
    [ 19172.242] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    [ 19172.242] (**) NVIDIA(0): Option "NoLogo" "true"
    [ 19172.243] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
    [ 19172.243] (**) NVIDIA(0): Option "UseEDID" "false"
    [ 19172.243] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
    [ 19172.243] (**) NVIDIA(0): Enabling 2D acceleration
    [ 19172.243] (**) NVIDIA(0): Ignoring EDIDs
    [ 19172.243] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
    [ 19172.243] (**) NVIDIA(0):     mode
    [ 19172.243] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
    [ 19172.243] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
    [ 19172.243] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
    [ 19172.243] (EE) NVIDIA(0):     you continue to encounter problems, Please try
    [ 19172.243] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.
    [ 19172.544] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
    [ 19172.545] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 850M (GM107-A) at PCI:1:0:0 (GPU-0)
    [ 19172.545] (--) NVIDIA(0): Memory: 2097152 kBytes
    [ 19172.545] (--) NVIDIA(0): VideoBIOS: 82.07.24.00.1b
    [ 19172.545] (II) NVIDIA(0): Detected PCI Express Link width: 16X
    [ 19172.545] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 850M at PCI:1:0:0
    [ 19172.545] (--) NVIDIA(0):     none
    [ 19172.545] (II) NVIDIA(0): Validated MetaModes:
    [ 19172.545] (II) NVIDIA(0):     "NULL"
    [ 19172.545] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
    [ 19172.545] (WW) NVIDIA(0): Unable to get display device for DPI computation.
    [ 19172.545] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
    [ 19172.545] (--) Depth 24 pixmap format is 32 bpp
    [ 19172.545] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
    [ 19172.545] (II) NVIDIA:     access.
    [ 19172.548] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
    [ 19172.548] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
    [ 19172.548] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
    [ 19172.548] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
    [ 19172.548] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
    [ 19172.548] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
    [ 19172.548] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
    [ 19172.548] (II) NVIDIA(0):     Config Options in the README.
    [ 19172.548] (II) NVIDIA(0): Setting mode "NULL"
    [ 19172.548] (EE) NVIDIA(0): Failed to initiate mode change.
    [ 19172.548] (EE) NVIDIA(0): Failed to complete mode change
    [ 19172.557] (==) NVIDIA(0): Disabling shared memory pixmaps
    [ 19172.557] (==) NVIDIA(0): Backing store enabled
    [ 19172.557] (==) NVIDIA(0): Silken mouse enabled
    [ 19172.557] (==) NVIDIA(0): DPMS enabled
    [ 19172.557] (II) Loading sub module "dri2"
    [ 19172.557] (II) LoadModule: "dri2"
    [ 19172.557] (II) Module "dri2" already built-in
    [ 19172.557] (II) NVIDIA(0): [DRI2] Setup complete
    [ 19172.557] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
    [ 19172.557] (--) RandR disabled
    [ 19172.588] (II) Using input driver 'mouse' for '<default pointer>'
    [ 19172.588] (**) Option "CorePointer" "on"
    [ 19172.588] (**) <default pointer>: always reports core events
    [ 19172.588] (WW) <default pointer>: No Device specified, looking for one...
    [ 19172.644] (II) <default pointer>: Setting Device option to "/dev/input/mice"
    [ 19172.644] (--) <default pointer>: Device: "/dev/input/mice"
    [ 19172.644] (==) <default pointer>: Protocol: "Auto"
    [ 19172.644] (**) <default pointer>: always reports core events
    [ 19172.644] (**) Option "Device" "/dev/input/mice"
    [ 19172.676] (==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
    [ 19172.676] (**) <default pointer>: ZAxisMapping: buttons 4 and 5
    [ 19172.676] (**) <default pointer>: Buttons: 9
    [ 19172.676] (II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE, id 6)
    [ 19172.676] (**) <default pointer>: (accel) keeping acceleration scheme 1
    [ 19172.676] (**) <default pointer>: (accel) acceleration profile 0
    [ 19172.676] (**) <default pointer>: (accel) acceleration factor: 2.000
    [ 19172.676] (**) <default pointer>: (accel) acceleration threshold: 4
    [ 19172.676] (II) <default pointer>: Setting mouse protocol to "ExplorerPS/2"
    [ 19172.968] (II) <default pointer>: ps2EnableDataReporting: succeeded
    [ 19172.968] (II) Using input driver 'kbd' for '<default keyboard>'
    [ 19172.968] (**) Option "CoreKeyboard" "on"
    [ 19172.968] (**) <default keyboard>: always reports core events
    [ 19172.968] (**) <default keyboard>: always reports core events
    [ 19172.968] (**) Option "Protocol" "standard"
    [ 19172.968] (**) Option "XkbRules" "base"
    [ 19172.968] (**) Option "XkbModel" "pc105"
    [ 19172.968] (**) Option "XkbLayout" "us"
    [ 19172.968] (II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD, id 7)
    [ 19172.969] (II) config/udev: Adding input device Power Button (/dev/input/event5)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device Video Bus (/dev/input/event8)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device Video Bus (/dev/input/event7)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device Power Button (/dev/input/event3)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device Sleep Button (/dev/input/event4)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding drm device (/dev/dri/card0)
    [ 19172.969] (II) xfree86: Adding drm device (/dev/dri/card0)
    [ 19172.969] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
    [ 19172.969] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=3 (/dev/input/event12)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=7 (/dev/input/event13)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.969] (II) config/udev: Adding input device HDA Intel HDMI HDMI/DP,pcm=8 (/dev/input/event14)
    [ 19172.969] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event6)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse1)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device BisonCam, NB Pro (/dev/input/event10)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event15)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event16)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event1)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.970] (II) config/udev: Adding input device PC Speaker (/dev/input/event9)
    [ 19172.970] (II) AutoAddDevices is off - not adding device.
    [ 19172.971] (II) config/udev: Adding input device MSI WMI hotkeys (/dev/input/event11)
    [ 19172.971] (II) AutoAddDevices is off - not adding device.
    [ 19173.052] (II) UnloadModule: "kbd"
    [ 19173.052] (II) UnloadModule: "mouse"
    [ 19173.068] (II) NVIDIA(GPU-0): Deleting GPU-0
    [ 19173.069] (EE) Server terminated successfully (0). Closing log file.

  4. #4

    Default Re: Xlib: extension "GLX" missing on display ":8".

    Quote Originally Posted by hermanbergwerf View Post
    nvidia-bumblebee gave errors for me (something like permission denied while I clearly was member of the video,bumblebee group)
    Right, I remember now.
    But funnily, that "permission denied" is still in the log:
    Code:
    [ 19172.240] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
    I installed the nvidia drivers and bumblebee from the opensuse 13.2 repository (after I notices bumblebee was also in the opensuse repository)
    Hm? There is no nvidia driver in the opensuse 13.2 repository.
    I think you mean the nvidia repo?

    I blocked nvidia-glG03 (after uninstalling it)
    And that's why GLX is not working.
    Didn't I explain to you already that installing the standard nvidia driver packages without nvidia-glG03 will make it impossible to run 3D applications on the nvidia chip?
    You can use the nvidia chip only for CUDA that way.

    I am using the default kernel (I switched to the default kernel because I hoped this might fix some dependencies or something)
    The default kernel has exactly the same dependencies.
    The difference is just that the desktop kernel has tuned some settings for desktop use, like lower latency. But I can't tell you the details either.

    OpenGL is working perfectly on display :0 with my Intel HD (including GLX)
    Xorg.8.log:
    Code:
    ...
    [ 19172.241] (II) LoadModule: "glx"
    [ 19172.241] (II) Loading /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    [ 19172.241] (EE) Failed to load /usr/lib64/nvidia/xorg/modules/extensions/libglx.so: /usr/lib64/nvidia/xorg/modules/extensions/libglx.so: cannot open shared object file: No such file or directory
    [ 19172.241] (II) UnloadModule: "glx"
    [ 19172.241] (II) Unloading glx
    [ 19172.241] (EE) Failed to load module "glx" (loader failed, 7)
    Here's your error.
    /usr/lib64/nvidia/xorg/modules/extensions/libglx.so cannot be loaded, because it is not installed. It is part of the package nvidia-glG03 (which installs it to a completely different place btw, so even installing it won't help you with Bumblebee), but installing that will break your intel GLX and Mesa's OpenGL software renderer.
    As your desktop runs on the intel chip, this is really a bad idea, and you noticed that already anyway I think.

    One thought:
    As Bumblebee apparently wants to load libglx from /usr/lib64/nvidia/xorg/modules/extensions/, you could download the nvidia-glG03 package, extract it with Ark or File-Roller e.g., and copy the files to /usr/lib64/nvidia/xorg/modules/extensions/ by hand (create that directory if it doesn't exist). They should not disturb Mesa then, and might work with optirun...
    Last edited by wolfi323; 16-Dec-2014 at 15:38.

  5. #5
    Join Date
    Nov 2014
    Location
    Netherlands
    Posts
    49

    Default Re: Xlib: extension "GLX" missing on display ":8".

    The nvidia rpm is indeed from the nvidia repo but bumblebee is also included in the opensuse repo.
    I installed nvidia-glG03 because it seemed the only obvious solution to me. It looks to me like it doesn't break mesa at all (perhaps a symlink is required to get nvidia-glG03 working?)
    I will try your suggestion of manually installing the shared objects.

  6. #6
    Join Date
    Nov 2014
    Location
    Netherlands
    Posts
    49

    Default Re: Xlib: extension "GLX" missing on display ":8".

    Hmm, interesting, the rpm of nvidia-glG03 contains this file:
    /lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so
    Perhaps bumblebee is outdated...
    Contents of the rpm:

  7. #7

    Default Re: Xlib: extension "GLX" missing on display ":8".

    Quote Originally Posted by hermanbergwerf View Post
    I installed nvidia-glG03 because it seemed the only obvious solution to me. It looks to me like it doesn't break mesa at all (perhaps a symlink is required to get nvidia-glG03 working?)
    I thought you did _not_ install it?

    It is true that on 13.2 a symlink is necessary to get nvidia-glG03 working, yes. This is done via "update-alternatives", the package should do that on installation.
    But since recently there's a check in the package whether it is installed on an Optimus system, and it doesn't activate its libglx in that case.
    Changelog entry:
    Code:
    Wed Nov  5 13:01:10 UTC 2014 - sndirsch@suse.com
    - On Optimus systems disable NVIDIA driver/libs completely by
       default (bnc#902667)
    I will try your suggestion of manually installing the shared objects.
    Since you installed nvidia-glG03 now, creating some symlinks should be fine as well.

    I had a look at the package again, and it installs to /usr/X11R6/lib64/libGL.so*.
    So either copy the files from there to /usr/lib64/nvidia/xorg/modules/extensions/, or create symlinks accordingly. And something similar should be done for the 32bit versions as well (lib instead of lib64) I suppose.
    But I cannot guarantee you that this will work.
    Last edited by wolfi323; 17-Dec-2014 at 07:43.

  8. #8

    Default Re: Xlib: extension "GLX" missing on display ":8".

    Quote Originally Posted by hermanbergwerf View Post
    Hmm, interesting, the rpm of nvidia-glG03 contains this file:
    /lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so
    Yeah, right. I forgot to mention that in my previous post. You'd have to rename this to libglx.so though after you copy it to /usr/lib64/nvidia/xorg/modules/extensions/. Or create a corresponding symlink.

    I have no idea where Bumblebee/optirun would load libGL from though, but you could try the same directory.

    Perhaps bumblebee is outdated...
    No. Bumblebee is just not designed to be used with the official nvidia driver packages.
    nvidia-bumblebee does install the files to /usr/lib64/nvidia/xorg/modules/extensions/.

  9. #9

    Default Re: Xlib: extension "GLX" missing on display ":8".

    Quote Originally Posted by wolfi323 View Post
    I had a look at the package again, and it installs to /usr/X11R6/lib64/libGL.so*.
    So either copy the files from there to /usr/lib64/nvidia/xorg/modules/extensions/, or create symlinks accordingly. And something similar should be done for the 32bit versions as well (lib instead of lib64) I suppose.
    But I cannot guarantee you that this will work.
    PS: Forget about libGL.*. The nvidia packages add /usr/X11/lib(64) to the linker path, so they should be found where they are.
    And this is done even on Optimus systems.

    I believe that on your system Mesa's libGL (and libEGL and others) is not found now any more, thus breaking applications that want to use it on the intel chip.

  10. #10
    Join Date
    Nov 2014
    Location
    Netherlands
    Posts
    49

    Default Re: Xlib: extension "GLX" missing on display ":8".

    I still have mesa installed without any conflicts. I installed nvidia-glG03 before, them removed and blocked it, and now reinstalled it. I copied the libglx to the right directory like this:
    Code:
    sudo cp /usr/lib64/xorg/modules/extensions/nvidia/nvidia-libglx.so /usr/lib64/nvidia/xorg/modules/extensions/libglx.so
    And optirun is working again! I think I got a slightly higher framerate before but I'm cool with this... Perhaps I can even install CUDA now (since bumblebee is now using the nvidia driver)
    I locked all nvidia/bumblebee packages to hopefully avoid future capability issues. Or do you think I should symlink libglx and keep updating nvidia?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •