Results 1 to 6 of 6

Thread: Copy and paste pastes wrong content.

  1. #1

    Default Copy and paste pastes wrong content.

    All of a sudden copy and paste has ceased to work correctly. If I highlight text and hit ctrl+insert, the highlighted text goes to the top of the clipboard as shown in klipper (I am using KDE 4.14.3 under 13.2). However, when I hit shift+insert, some previous entry in the clipboard will be pasted. For example, I just highlighted the word "highlighted" and hit ctrl+insert. The clipboard widget shows it at the top of the clipboard. I will now hit shift+insert. Here's the result: "one". The word "one" happens to be the fifth entry down as shown by klipper. If I open klipper and highlight the top entry, it does insert that entry. For example: "highlighted". "Highlighted" of course is the word at the top of the clipboard as it is the last thing I did a ctrl+insert on. As far as I know this started after an update this weekend.

    Is there a cure?

  2. #2

    Default Re: Copy and paste pastes wrong content.

    One addition: cut (shift+del) and paste works correctly. Shift+del both puts the word in klipper and with shift+insert retrieves it properly. It is only copy and paste that doesn't work.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,770
    Blog Entries
    3

    Default Re: Copy and paste pastes wrong content.

    It's hard to guess what is going wrong.

    Normally, it works for me.

    However, if I use "konqueror" or "rekonq" to read the forum, and I try to paste into the forum, then it all goes haywire. But if I tell "konqueror" to pretend that it is "firefox", then it work properly. There's some sort of forum bug causing that (may flawed javascript).

    But I don't know if your problem was with the forum, so it might be unrelated. Or maybe there's some other software that is similarly messing things up.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: Copy and paste pastes wrong content.

    Right click Klipper select configure check shortcuts and actions and see if things are set as you want/think they are.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,570
    Blog Entries
    1

    Default Re: Copy and paste pastes wrong content.

    Quote Originally Posted by gogalthorp View Post
    Right click Klipper select configure check shortcuts and actions and see if things are set as you want/think they are.
    Further to this, check Configure Klipper > 'Selection and Clipboard' (eg Synchronize contents of the clipbaord and the selection').

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,570
    Blog Entries
    1

    Default Re: Copy and paste pastes wrong content.

    Quote Originally Posted by deano_ferrari View Post
    Further to this, check Configure Klipper > 'Selection and Clipboard' (eg Synchronize contents of the clipbaord and the selection').
    https://docs.kde.org/stable/en/kde-w...ard-modes.html

    I apologize in advance if I'm on the wrong track here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •