Results 1 to 2 of 2

Thread: Nvidia Driver rpm 304.125 OpenSuse 13.2 i386.

  1. #1

    Default Nvidia Driver rpm 304.125 OpenSuse 13.2 i386.

    I've encountered problem installing driver 304.125 from 304.123.

    1) When updating, dependencies were wrong and I was suggested to install version G03 in addition to G02 (which is compatible with my GPU GeForce GT 620). After installation X-server didn't start. I've removed everything according to mask *nvidia* and *G02*, and finally have reinstalled driver according to manual: zypper install x11-video-nvidiaG02.

    2) The X-server didn't start also. The log contained following lines:

    [ 24.777] (II) LoadModule: "glx"
    [ 24.801] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
    [ 24.836] (EE) Failed to load /usr/lib/xorg/modules/updates/extensions/libglx.so: libnvidia-tls.so.304.123: cannot open shared object file: No such file or directory
    [ 24.836] (II) UnloadModule: "glx"
    [ 24.836] (II) Unloading glx
    [ 24.836] (EE) Failed to load module "glx" (loader failed, 7)

    So symbolic link libglx.so remained the same from version 304.123! libglx.so -> libglx.so.304.123
    I've corrected the link: libglx.so -> /usr/lib/xorg/modules/extensions/nvidia/nvidia-libglx.so
    The module "glx" started to load:

    [ 25.922] (II) LoadModule: "glx"
    [ 25.963] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
    [ 27.204] (II) Module glx: vendor="NVIDIA Corporation"
    [ 27.204] compiled for 4.0.2, module version = 1.0.0
    [ 27.204] Module class: X.Org Server Extension
    [ 27.204] (II) NVIDIA GLX Module 304.125 Mon Dec 1 20:21:57 PST 2014

    3) However module "nvidia" failed to start:

    [ 27.204] (II) LoadModule: "nvidia"
    [ 27.204] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
    [ 27.278] (II) Module nvidia: vendor="NVIDIA Corporation"
    [ 27.278] compiled for 4.0.2, module version = 1.0.0
    [ 27.278] Module class: X.Org Video Driver
    [ 27.311] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
    [ 27.311] (EE) NVIDIA: system's kernel log for additional error messages.
    [ 27.311] (II) UnloadModule: "nvidia"

    So I've found, that desktop version of kmp, corresponding to desktop version of kernel, wasn't installed in dependency of x11-video-nvidiaG02:
    i | nvidia-computeG02 | NVIDIA driver for computing with GPGPU | пакет
    i | nvidia-gfxG02-kmp-default | NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs | пакет
    | nvidia-gfxG02-kmp-desktop | NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs | пакет
    | nvidia-gfxG02-kmp-pae | NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs | пакет
    i | x11-video-nvidiaG02 | NVIDIA graphics driver for GeForce 6xxx and newer GPUs | пакет

    I've installed it manually and now everything works fine.
    zypper install nvidia-gfxG02-kmp-desktop

    I clearly remember, that in was installed automatically in previous rpm-versions of NVIDIA driver.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,893
    Blog Entries
    3

    Default Re: Nvidia Driver rpm 304.125 OpenSuse 13.2 i386.

    I have an Nvidia Geforce 6150LE on one box.

    When I did "zypper up" yesterday, it listed the G02 driver as software that would not be updated (even though there's a newer version).

    Checking version info in Yast Software Management, I notice that the updated G02 driver is listed as having a different vendor. That's why it was not updating.

    I told Yast to update regardless of vendor change (forced the update). I did this for all packages from the "nvidia" repo (I seem to recall that there were 3 such packages).

    I rebooted after the update, and all is good.

    This was with opensuse 13.2, 64-bit.

    I still have opensuse 13.1, 32-bit on a different partition on that same computer. So I booted that, and forced the update of the nvidia drivers in the same way. Then I rebooted. And, again, all was well.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •