Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Where is the JavaLoader?

  1. #21

    Default Re: Where is the JavaLoader?

    I wrote this in the bug report, but I'll post it here as well in case somebody stumbles over this thread...

    I did some more experiments today, and the problem is gone when you install the libreoffice packages from the LibreOffice:4.3 repo (actually you only need the package "libreoffice" from there).
    http://download.opensuse.org/reposit...openSUSE_13.2/
    Also the wizards to create a report (and a form) are working as well.

    For actually being able to open a report, you'll have to manually install the package pentaho-reporting-flow-engine as well though, included in the distribution.

    I find that a bit surprising though, as the 13.2 updates are submitted from exactly that repo AFAIK...

  2. #22

    Default Re: Where is the JavaLoader?

    Quote Originally Posted by wolfi323 View Post
    No idea.
    I plan to investigate a bit tomorrow. (it's too late here now already)
    But I have no idea yet how to debug this.


    Ok. Another thing that's probably worth a try is to test whether the problem also exists with the packages from libreoffice.org.
    Someone who understands this better than I, might like to verify if the missing package we have been looking for is one of the four 'pentaho' packages in the OS reposistory.

    After switching to KDE from Gnome, I got an error message with the LibreOffice Base report function that suggested I needed a pentaho module. Since I could not decide which of the 4 available packages it might be, I installed them all. It worked!

    For me, for now, the problem is SOLVED!

  3. #23

    Default Re: Where is the JavaLoader?

    Quote Originally Posted by hnimmo View Post
    Someone who understands this better than I, might like to verify if the missing package we have been looking for is one of the four 'pentaho' packages in the OS reposistory.

    After switching to KDE from Gnome, I got an error message with the LibreOffice Base report function that suggested I needed a pentaho module. Since I could not decide which of the 4 available packages it might be, I installed them all. It worked!

    For me, for now, the problem is SOLVED!
    ....but please note: this is not the solution under Gnome.

  4. #24

    Default Re: Where is the JavaLoader?

    Quote Originally Posted by hnimmo View Post
    Someone who understands this better than I, might like to verify if the missing package we have been looking for is one of the four 'pentaho' packages in the OS reposistory.
    No. As I wrote, this doesn't help with the JavaLoader not found error.

    After switching to KDE from Gnome, I got an error message with the LibreOffice Base report function that suggested I needed a pentaho module. Since I could not decide which of the 4 available packages it might be, I installed them all. It worked!
    I wrote this as well already: I _am_ using KDE. And I tried in GNOME and IceWM as well. Actually first thing I tried weeks ago was to disable the KDE integration.
    This problem is definitely not desktop related.

    For me this is fixed when installing libreoffice from LibreOffice:4.3 or LibreOffice:Factory (or the upstream packages). Switching back to the 13.2 packages (which should be exactly the same as they are built from the same sources with exactly the same patches and eactly the same specfile) reliably breaks it again, regardless whether I use KDE, GNOME, or whatever.

  5. #25

    Default Re: Where is the JavaLoader?

    To close this thread: an update that fixes this problem has been released today.

    pentaho-reporting-flow-engine still has to be installed manually for reports to work, but a dependency has been added in the devel repos already and will be part of the next update to 4.3.7 which should be released in the next weeks.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •