Results 1 to 4 of 4

Thread: Restarting with Option disables Grub2-Menu

  1. #1
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Restarting with Option disables Grub2-Menu

    The Grub2-Bootmenu is permanently hidden, whenever I select any specific target for a restart within KDE's shutdown.

    Expected: Normally, i.e. before installing 13.2 (install, not upgrade), when I selected "restart" with "windows", the machine would reboot straight into "windows" once (without displaying a boot menu), but for the next boot therereafter, the Grub boot menu would be shown again as normal.
    Observed: Now, when I select "restart" with "windows", the machine reboots into Linux, and for good measure, the Grub2-Boot menu never ever appears again to leave me another choice.
    (Now, I do get the message here that I shouldn't use Windows any more, but this seems to be quite a drastic measure. )

    I am on a fresh 13.2 install, having Btrfs for root and XFS for home as suggested. In order to make this work, I used PartEd to shrink and move the initial Windows partitions, so that Grub2 fits into MBR. Restoring the boot menu by reinstalling Grub2 through {YaST -> Boot Loader} did work, but the problem occurs again as soon as I restart with any chosen target in the Retstart-Menu. Restarting without a target works normally, i.e. always showing the boot menu as expected.

    Note:
    I always see a "failed" message during booting 13.2 after Grub2, but I would guess that this is entirely unrelated, since it happens after Grub2? I do see no other bad side-effects from it yet and searching for this problem here revealed only similar problem descriptions with certainly unrelated causes.
    Code:
    # systemctl --failed
    UNIT                         LOAD   ACTIVE SUB    DESCRIPTION
    plymouth-start.service       loaded failed failed Show Plymouth Boot Screen
    systemd-modules-load.service loaded failed failed Load Kernel Modules
    Last edited by STurtle; 09-Dec-2014 at 05:57. Reason: spelling

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,739
    Blog Entries
    3

    Default Re: Restarting with Option disables Grub2-Menu

    Quote Originally Posted by STurtle View Post
    (Now, I do get the message here that I shouldn't use Windows any more, but this seems to be quite a drastic measure. )
    That's not actually an intended message.

    I can explain what is happening. The information on restarting is in "/boot/grub2/grubenv". When you reboot, grub2 is supposed to rewrite that file so that you don't get a specific boot the next time.

    Unfortunately, "grub2" doesn't currently know how to write to "btrfs". So it doesn't change that file.

    If you simply delete that file (maybe with a live CD boot or similar), that should restore the menu. There's no need to reinstall grub2.

    I guess it will be best to not specify which system to reboot next.

    If that ability is important to you, and if you have some spare space, then you could try making "/boot" a separate partition (perhaps 500M in size), and format that to "ext2".

    Or, if this is mostly a convenience for booting Windows, you could consider making Windows the default boot and set a shortish timeout, so it will boot to Windows unless you are there in time to select something else from the menu.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Restarting with Option disables Grub2-Menu

    Quote Originally Posted by STurtle View Post
    The Grub2-Bootmenu is permanently hidden, whenever I select any specific target for a restart within KDE's shutdown.
    See also this thread or this bug for more details.

  4. #4
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Thumbs up Re: Restarting with Option disables Grub2-Menu

    Thanks for clarifying this!

    It is a bit annoying that the suggested default breaks existing behaviour.

    My workaround will be to simply increase the timeout for the boot menu. Before, I used to always boot into Linux immediately and then restart to Windows occasionally.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •