Results 1 to 3 of 3

Thread: rsync error

  1. #1
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default rsync error

    Hello,

    I regularly backup my laptop with an rsync script. It has been a working
    like a charm for a long time until a couple of weeks ago when I started
    getting this error:

    Code:
    rsync: xattrs.c:572: send_xattr_request: Assertion `f_out >= 0' failed.
    rsync: connection unexpectedly closed (16759 bytes received so far) [sender]
    rsync error: error in rsync protocol data stream (code 12) at io.c(235)
    [sender=3.1.0]
    My setup for using rsync to backup my entire hard drive is like this. My
    partitions are as follows:
    Code:
    tribetreklap:/home/george # fdisk -l
    
    Disk /dev/sda: 750.2 GB, 750156374016 bytes, 1465149168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disk label type: dos
    Disk identifier: 0x5a684d71
    
    Device Boot      Start         End      Blocks   Id  System
    /dev/sda1            2048    52430847    26214400   1c  Hidden W95 FAT32
    (LBA)
    /dev/sda2        52430848   158926847    53248000    7  HPFS/NTFS/exFAT
    /dev/sda3       158926848   175704063     8388608   82  Linux swap / Solaris
    /dev/sda4   *   175704064  1465147391   644721664    5  Extended
    /dev/sda5       175706112   217649151    20971520   83  Linux
    /dev/sda6       217651200   259594239    20971520   83  Linux
    /dev/sda7       259596288   976773119   358588416   83  Linux
    /dev/sda8       976775168  1465147391   244186112   83  Linux
    tribetreklap:/home/george #
    My backup drive has exactly the same setup and all the same sector
    divisions between the partitions.

    The first 2 partitions are my windows drives, which I don't backup
    normally (I have an ntfs clone script for that).

    I googled this error and found that there was an rsync error in
    archlinux and redhat, and maybe some other distributions, but it was all
    resolved back in January, and it was some sort of bug with rsync. Their
    errors seemed to prevent the rsync from happening at all.

    I don't think there is a bug in rsync, but I don't know for sure. How
    would I find out?

    My error is different from the ones I found that affected the other
    distributions- when I run my backup script, I run a separate rsync
    script for each partition, and the only one that doesn't work is on
    /dev/sda7. The others all complete the rsync without any problems.

    Here is my rsync command that I use for the partition that doesn't finish:
    Code:
    rsync -auxzHAXS --delete --progress /home/ --exclude=.kde4
    --exclude=.thunderbird --exclude=.cache --exclude=.gstreamer
    /mounters/homemnt/
    where you can see that I have the backup partition mounted on
    /mounters/homemnt/.

    When I run the script, it runs through and backs up most of the files
    (don't know if more or less than half), and often stops with the error
    at the same spot in the sync procedure. But sometimes it stops at a
    different spot.

    I thought that perhaps it was some kind of disk error on the partition,
    so I ran fsck on both my home partition /dev/sda7, and also on the same
    partition on the backup drive. No errors were detected.

    Any suggestions on what else I might do? I am really scratching my head
    here, and I need to be able to backup my data.

    --
    G.O.
    Box #1: 13.1 | KDE 4.12 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB

  2. #2

    Default Re: rsync error

    Have you tried the --protocol=30 option with your path that is failing?

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default Re: rsync error

    On 12/08/2014 09:27 PM, ab wrote:
    > Have you tried the --protocol=30 option with your path that is failing?
    >


    Thanks for the tip. I put in that line, and it started syncing like it
    was supposed to!

    This makes me wonder about a few things.

    First, how did you know that might work?

    Second, what exactly does --protocol=30 do?

    Third, sas there a recent change to rsync that came out in the updates
    and/or patches?

    --
    G.O.
    Box #1: 13.1 | KDE 4.12 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 13.1 | KDE 4.12 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.12 | Core i7-2620M | 64 | 8GB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •