Results 1 to 4 of 4

Thread: 13.1 to 13.2 upgrade problems

  1. #1

    Default 13.1 to 13.2 upgrade problems


    this is not a question strictly related to on application so maybe this is not the section to ask but i can't find better

    I noticed two problems after upgrading the system from 13.1 to 13.2 version.

    - the visual version of yast doesn't open: i click on the icon, it seems to do something but in the end nothing happens.

    - i have some scripts that use python-matplotlib to plot some graphs, since the upgrade it just don't show the graphs anymore,
    the code work correctly but nothing is displayed. I tried to reinstall the library but nothing changed. A similar problem has occurred in the previous distro upgrade and at the time since i wasn't able to find a solution i finished to reinstall the system, witch i really want to avoid.

    The main problem is that in booth cases no error is shown (maybe there some log to check ?) so i can't figure out what's going wrong.

    Can they be somehow related (they are booth windows that doesn't show up) ?

    Did someone have any idea on how to solve those problems ?

    thanks everybody.

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: 13.1 to 13.2 upgrade problems

    This post is probably more appropriate for the Install Forum for the YAST issue, this forum for your Matlab issues.

    YAST issue
    Recommend try re-installing YAST. The yast package is the console version of YAST, and the yast2 package is the graphic version, so...
    zypper in -f yast2
    I don't know what the problem may be with your matlab app, a starting point is to check your system logs, since you upgraded the following should return the last 100 lines of your syslog
    tail -n 100 /var/log/messages
    Whether you upgrade or not, you can pipe journalctl to tail to get the last 100 lines
    journalctl | tail -n 100
    If 100 lines isn't enough, then you need to either
    - Run one of the above commands <immediately> after a problem is observed
    - Change the number of lines to be returned.


  3. #3

    Default Re: 13.1 to 13.2 upgrade problems

    Thanks for answer,

    i tried reinstalling yast but nothing has changed.

    looking at the logs i didn't find any errors (at least from what i've understand).

    Meanwhile i've also noticed problems with the graphic card drivers, X configuration and usb devices, so probably something went wrong during the upgrade.

    At this point i think that reinstall the system from scratch will be the better solution.

  4. #4
    Join Date
    Nov 2009
    West Virginia Sector 13

    Default Re: 13.1 to 13.2 upgrade problems

    What card? What driver? If propritary driver was installed you have to manually add them again.

    I assume you did an online upgrade? If so then maybe you did not get all the packages updated. Show use the repos you used.

    zypper lr -d

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts