Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Stopping Program from Auto-Starting

  1. #1

    Default Stopping Program from Auto-Starting

    Hello All,

    Running the following on a CuBox-i2 (*arm mini-pc):
    Code:
    WINDOW MANAGER --> XFCE version 4.10
    
    # cat SuSE-release
    # /etc/SuSE-release is deprecated and will be removed in the future, use /etc/os-release instead
    openSUSE 13.1 (armv7hl)
    VERSION = 13.1
    CODENAME = Bottle
    
    # cat os-release
    NAME=openSUSE
    VERSION="13.1 (Bottle)"
    VERSION_ID="13.1"
    PRETTY_NAME="openSUSE 13.1 (Bottle) (armv7hl)"
    ID=opensuse
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:opensuse:13.1"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://opensuse.org/"
    ID_LIKE="suse"
    
    # uname -a
    Linux CuBox-ExtonHQ 3.14.14-cubox-i #1 SMP Sat Sep 13 03:48:24 UTC 2014 armv7l armv7l armv7l GNU/Linux
    So I've been running this for a few weeks now and suddenly yesterday when I booted up the PC after I get auto-logged-in, a xfce4-terminal window opens on the desktop fully maximized... While this is not so much a bad thing that's happening, I have no idea why and I can't figure out how to prevent it from starting by itself like that...

    I checked in:
    XFCE's Settings Manager > Session and Startup, but there was nothing in there about that.
    I also check in, YaST > Service Manager, but nothing in there about that either (*probably wouldn't be in here anyway since it's not a service)...

    But does anyone know where I can look to try and stop this from starting on its own?

    Any thoughts or suggestions would be greatly appreciated!

    Thanks in Advance,
    Matt

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,486
    Blog Entries
    3

    Default Re: Stopping Program from Auto-Starting

    You possibly have it set to save your session on logout and restore it on login. As far as I know, the only place to set that is on the logout menu.

    I think the sessions are saved in "$HOME/.config/sessions"
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: Stopping Program from Auto-Starting

    Quote Originally Posted by nrickert View Post
    You possibly have it set to save your session on logout and restore it on login. As far as I know, the only place to set that is on the logout menu.

    I think the sessions are saved in "$HOME/.config/sessions"
    Yes,
    And of course if this is the case the easiest solution is to manually close all running apps (Inspect the taskbar) before shutting down.

    TSU

  4. #4

    Default Re: Stopping Program from Auto-Starting

    Hey Guys, thank you both for the replies, much appreciated!

    You possibly have it set to save your session on logout and restore it on login. As far as I know, the only place to set that is on the logout menu.

    I think the sessions are saved in "$HOME/.config/sessions"
    Yea I had thought about that, but I checked for that directory and it is not in the ~/.config directory... I made sure to check ALL sub-dirs in .config too, so I'm pretty sure it doesn't exist, at least not in that dir. But, I don't remember ever messing with save session or anything like that, but I guess anything is possible...


    Yes,
    And of course if this is the case the easiest solution is to manually close all running apps (Inspect the taskbar) before shutting down.
    Yea, but I always try and make sure to close out everything that is open on the desktop before I shutdown. And anyway I don't ever usually maximize terminal windows either... The strange thing it this just started happening a few days ago, and it does the exact same thing on each login... No clue why though?

    Is there any log I could/should look at that might give a hint as to who or what is starting the terminal window?
    I guess I can reboot and when I get logged back in check ps -ef to see who started that terminal window...

    Thanks again for your replies fellas, much appreciated!

    Thanks Again,
    Matt

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,486
    Blog Entries
    3

    Default Re: Stopping Program from Auto-Starting

    I can't really check on my own systems, because I have not recently saved an XFCE session. That's because I mainly use KDE. You might also check under "$HOME/.cache". I have a vague memory that it might have been there.

    When I was trying XFCE more extensively, here's what I would do:

    1. Login, and setup a session exactly as I wanted it.
    2. Logout. On the logout menu, I would check the box to save the current session on logout.
    3. Login again. Make sure everything is as I want it.
    4. Logout again. This time, uncheck the box about saving the current session.


    Thereafter, I would get that same saved session, and the logout menu would default to not saving.

    The best fix is to delete the save session, if you can find it. The alternative would be to save an empty session, using roughly the steps above.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Stopping Program from Auto-Starting

    On 2014-12-05 22:46, mmartin0926 wrote:

    > Is there any log I could/should look at that might give a hint as to who
    > or what is starting the terminal window?
    > I guess I can reboot and when I get logged back in check *ps **-ef* to
    > see who started that terminal window...


    That's a good idea. But no need to reboot, just log out, then log back in.


    For instance, on every login, in xfce, I get a popup message with this "warning":

    Code:
    Could not open or invalid data: %U
    which I know where it comes from, but I haven't killed because I wanted to do a bug report, which I keep forgetting to do.

    Closing the popup, saving the session, doesn't help, it reappears. It is some other program, not session start directly, which calls it.


    Running "ps afxu" I can see it:

    Code:
    cer       5632  0.0  0.0  13112   496 ?        S    Dec04   0:00 /bin/sh /usr/bin/oyranos-profile-install %U
    cer       5643  0.0  0.0  30820   772 ?        S    Dec04   0:00  \_ oyranos-profiles --gui --install -u %U
    cer       5672  0.0  0.1 578564 11876 ?        Sl   Dec04   0:00      \_ zenity --warning --text Could not open or invalid data: %U
    (ps aef doesn't find it)


    Who exactly is calling "/usr/bin/oyranos-profile-install" I don't know, or I have forgotten. Probably the latter ;-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: Stopping Program from Auto-Starting

    I'm not running XFCE but your answer is probably here...
    Scroll down (or search) on this page "Disable sessions"
    https://wiki.archlinux.org/index.php/xfce

    TSU

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Stopping Program from Auto-Starting

    Quote Originally Posted by tsu2 View Post
    Yes,
    And of course if this is the case the easiest solution is to manually close all running apps (Inspect the taskbar) before shutting down.

    TSU
    ... or set it to NOT save your sessions, which is my preference.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: Stopping Program from Auto-Starting

    Quote Originally Posted by Fraser_Bell View Post
    ... or set it to NOT save your sessions, which is my preference.
    Which should now be known how to configure with my last previous post


    TSU

  10. #10
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Stopping Program from Auto-Starting

    Quote Originally Posted by tsu2 View Post
    Which should now be known how to configure with my last previous post


    TSU
    Cross-posting at its best ...
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •