Results 1 to 6 of 6

Thread: Dracut incomplete update

  1. #1

    Default Dracut incomplete update

    today, after updating packages, Dracut seems not be updated properly. Zypper output:
    Code:
    ( 1/15) Installing: btrfsprogs-3.16.2-4.1 ................................[done]
    ( 2/15) Installing: iproute2-3.16-2.4.1 ..................................[done]
    ( 3/15) Installing: libbtrfs0-3.16.2-4.1 .................................[done]
    ( 4/15) Installing: libudev1-210-25.8.1 ..................................[done]
    ( 5/15) Installing: pm-utils-1.4.1-38.4.1 ................................[done]
    ( 6/15) Installing: systemd-32bit-210-25.8.1 .............................[done]
    ( 7/15) Installing: systemd-bash-completion-210-25.8.1 ...................[done]
    ( 8/15) Installing: tigervnc-1.3.1-6.6.1 .................................[done]
    ( 9/15) Installing: xorg-x11-Xvnc-1.3.1-6.6.1 ............................[done]
    (10/15) Installing: systemd-210-25.8.1 ...................................[done]
    (11/15) Installing: systemd-sysvinit-210-25.8.1 ..........................[done]
    (12/15) Installing: dracut-037-17.9.1 ....................................[done]
    (13/15) Installing: udev-210-25.8.1 ......................................[done]
    (14/15) Installing: systemd-logger-210-25.8.1 ............................[done]
    (15/15) Installing: libgudev-1_0-0-210-25.8.1 ............................[done]
    Output of udev-210-25.8.1.x86_64.rpm %posttrans script:
        Creating initrd: /boot/initrd-3.16.6-2-desktop
        Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-3.16.6-2-desktop 3.16.6-2-desktop
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        *** Including module: bash ***
        *** Including module: warpclock ***
        *** Including module: i18n ***
        *** Including module: ifcfg ***
        *** Including module: drm ***
        *** Including module: plymouth ***
        *** Including module: btrfs ***
        *** Including module: kernel-modules ***
        Omitting driver i2o_scsi
        *** Including module: resume ***
        *** Including module: rootfs-block ***
        *** Including module: terminfo ***
        *** Including module: udev-rules ***
        Skipping udev rule: 91-permissions.rules
        Skipping udev rule: 80-drivers-modprobe.rules
        *** Including module: systemd ***
        *** Including module: usrmount ***
        *** Including module: base ***
        *** Including module: fs-lib ***
        *** Including module: shutdown ***
        *** Including module: suse ***
        *** Including modules done ***
        *** Installing kernel module dependencies and firmware ***
        *** Installing kernel module dependencies and firmware done ***
        *** Resolving executable dependencies ***
        *** Resolving executable dependencies done***
        *** Hardlinking files ***
        *** Hardlinking files done ***
        *** Stripping files ***
        *** Stripping files done ***
        *** Generating early-microcode cpio image ***
        *** Store current command line parameters ***
        Stored kernel commandline:
         resume=UUID=6b84b64d-de80-4503-9d1c-3720ded0307b
        root=UUID=0baa3efe-1cec-4ba9-810d-777dc342ed6c rootflags=rw,relatime,space_cache rootfstype=btrfs
        *** Creating image file ***
        *** Creating image file done ***
        Update bootloader...
    
    
    There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps' to list these programs.
    I hope it wouldn't affect booting. Should I remove Dracut, install required packages then reinstall it?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Dracut incomplete update

    On 2014-12-05 14:06, sherif6 wrote:
    >
    > today, after updating packages, Dracut seems not be updated properly.
    > Zypper output:


    No, I *guess* it is dracut evaluating how to build the initrd image. It
    searchs for many things, and lists what it finds and what it doesn't,
    verbosely. I know very little about dracut, but I think it is working
    properly.

    Wait for comments from others.


    ....

    > Stored kernel commandline:
    > resume=UUID=6b84b64d-de80-4503-9d1c-3720ded0307b
    > root=UUID=0baa3efe-1cec-4ba9-810d-777dc342ed6c rootflags=rw,relatime,space_cache rootfstype=btrfs
    > *** Creating image file ***
    > *** Creating image file done ***
    > Update bootloader...


    At the end, it doesn't say the word "error" or "failed". The image is built.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,767
    Blog Entries
    3

    Default Re: Dracut incomplete update

    Quote Originally Posted by sherif6 View Post
    today, after updating packages, Dracut seems not be updated properly. Zypper output:
    ...
    Code:
       Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-3.16.6-2-desktop 3.16.6-2-desktop
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'dcbtool' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'fipvlan' could not be found!
        dracut module 'fcoe-uefi' will not be installed, because command 'lldpad' could not be found!
    I hope it wouldn't affect booting. Should I remove Dracut, install required packages then reinstall it?
    I've been seeing those messages. My system still boots.

    I use an encrypted LVM for root, swap, home. That still works.

    I don't fully understand the messages, but it seems that they can be ignored.

    It looks to me as if they might be tools for a dracut recovery shell if there are booting problems, and I guess the messages indicate that is not fully implemented. I don't expect to ever need that anyway. I would rather boot from the live rescue image (which I have on a USB), and use that for any repairs.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Post Re: Dracut incomplete update

    Quote Originally Posted by nrickert View Post
    I've been seeing those messages. My system still boots.

    I use an encrypted LVM for root, swap, home. That still works.

    I don't fully understand the messages, but it seems that they can be ignored.

    It looks to me as if they might be tools for a dracut recovery shell if there are booting problems, and I guess the messages indicate that is not fully implemented. I don't expect to ever need that anyway. I would rather boot from the live rescue image (which I have on a USB), and use that for any repairs.
    I could successfully boot, but I hope I don't need this module. It seems to be used to connect to something from https://www.kernel.org/pub/linux/uti...cut.html#_fcoe.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Dracut incomplete update

    On 2014-12-05 20:36, sherif6 wrote:

    > I could successfully boot, but I hope I don't need this module. It seems
    > to be used to connect to something from
    > https://www.kernel.org/pub/linux/uti...cut.html#_fcoe.


    Try bugzilla? :-?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  6. #6

    Default Re: Dracut incomplete update

    I posted the same a couple of weeks ago
    https://forums.opensuse.org/showthre...nitrd-question
    People who do not break things first will never learn to create anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •