Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: ssh to local machine fails unless tricked

  1. #1
    Join Date
    May 2012
    Location
    Northeast US
    Posts
    116

    Default ssh to local machine fails unless tricked

    Hi,

    I have a raspberry pi which I have installed freebsd on. It is a Model "B" 512 MB version.

    I have been asking around and had a great deal of trouble connecting via shh to this via ethernet cable (Cat 5E).
    The Pi is only connected to this machine (workstation-xw62.home) via a cable from the ethernet plug in the rear of the computer, and, likewise on the front of the Raspberry Pi.
    When I am connected to the Pi from xw62.home I am not connected to the internet or modem/router/bridge.

    I was just looking through some previous posts before and I saw mention of wicked, so I thought I would try it. In the process of doing this the initialization of the network interface allowed me to connect or something. I switched back to network manager after reading some of the help on the dialogue. After that I just plugged the computer into the internet so that network manager would initialize and it worked... I could ssh to the Pi.

    My network setup is not well done. For now though I would like to fix the ssh behaviour so that I can connect to the Pi. I have spent some time investigating the FreeBSD end of the problem and am trying this side now.

    Thanks,

    a5'

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,740
    Blog Entries
    3

    Default Re: ssh to local machine fails unless tricked

    Quote Originally Posted by a59303 View Post
    For now though I would like to fix the ssh behaviour so that I can connect to the Pi.
    Maybe you could tell us what is this ssh behavior that you are seeing, and that you want to fix.

    I am not having any problems at all with ssh to connect to local machines (or remote machines where I have an account).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    May 2012
    Location
    Northeast US
    Posts
    116

    Default Re: ssh to local machine fails unless tricked

    Hello,

    Specifically, I think I get Network is unreachable or, Name or service not known.

    Thanks,

    a5'

    Code:
    ito@xw62-work:~> ssh root@70.44.113.89
    ssh: connect to host 70.44.113.89 port 22: Network is unreachable
    ito@xw62-work:~> host -a 70.44.113.89
    Trying "89.113.44.70.in-addr.arpa"
    ;; connection timed out; no servers could be reached
    ito@xw62-work:~> ssh root@snaokwrx
    ssh: Could not resolve hostname snaokwrx: Name or service not known
    ito@xw62-work:~> ssh root@snaokwrx.com
    ssh: Could not resolve hostname snaokwrx.com: Name or service not known
    ito@xw62-work:~> host -a snaokwrx.com
    Trying "snaokwrx.com"
    ;; connection timed out; no servers could be reached
    ito@xw62-work:~> host -a snaokwrx
    Trying "snaokwrx.home"
    ;; connection timed out; no servers could be reached
    ito@xw62-work:~> 
    
    
    ito@xw62-work:~> netstat -a
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    tcp        0    118 70.44.113.83:43524      74.125.225.147:https    FIN_WAIT1   
    tcp        0    118 70.44.113.83:43100      204.186.215.53:https    FIN_WAIT1   
    tcp        0    118 70.44.113.83:44724      74.125.226.77:https     FIN_WAIT1   
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:53646                 *:*                                 
    udp        0      0 *:ipp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 xw62-work.local:ntp     *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 *:50654                 *:*                                 
    raw        0      0 *:ipv6-icmp             *:*                     7     
    
    ito@xw62-work:~> sudo ifconfig 
    root's password:
    enp1s0    Link encap:Ethernet  HWaddr 00:17:08:2A:25:A5  
              inet6 addr: fe80::217:8ff:fe2a:25a5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:90175 errors:0 dropped:0 overruns:0 frame:0
              TX packets:70663 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:108999445 (103.9 Mb)  TX bytes:8036569 (7.6 Mb)
              Interrupt:16 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:164 errors:0 dropped:0 overruns:0 frame:0
              TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:13616 (13.2 Kb)  TX bytes:13616 (13.2 Kb)
    
    
        
    AFTER PLUGGING IN MACHINE xw62 to INTERNET
    
    
    
    ito@xw62-work:~> sudo ifconfig 
    enp1s0    Link encap:Ethernet  HWaddr 00:17:08:2A:25:A5  
              inet6 addr: fe80::217:8ff:fe2a:25a5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:90175 errors:0 dropped:0 overruns:0 frame:0
              TX packets:70679 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:108999445 (103.9 Mb)  TX bytes:8040373 (7.6 Mb)
              Interrupt:16 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:164 errors:0 dropped:0 overruns:0 frame:0
              TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:13616 (13.2 Kb)  TX bytes:13616 (13.2 Kb)
    
    ito@xw62-work:~> 
    
    ito@xw62-work:~> netstat -a
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    udp        0      0 *:bootpc                *:*                                 
    udp        0      0 70.44.113.83.res-cm:ntp *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:53646                 *:*                                 
    udp        0      0 *:ipp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 *:tl1-raw-ssl           *:*                                 
    udp        0      0 xw62-work.local:ntp     *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 *:50654                 *:*                                 
    udp        0      0 *:60656                 *:*                                 
    raw        0      0 *:ipv6-icmp             *:*                     7           
    Active UN
    
    
    
    AFTER PLUGGING RPi BACK INTO XW62
    
    
    ito@xw62-work:~> host -a snaokwrx
    Trying "snaokwrx.ptd.net"
    ;; connection timed out; no servers could be reached
    ito@xw62-work:~> host -a 70.44.113.89
    Trying "89.113.44.70.in-addr.arpa"
    ;; connection timed out; no servers could be reached
    ito@xw62-work:~> 
    
    
    ito@xw62-work:~> netstat -a
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    udp        0      0 *:bootpc                *:*                                 
    udp        0      0 70.44.113.83.res-cm:ntp *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:53646                 *:*                                 
    udp        0      0 *:ipp                   *:*                                 
    udp        0   1536 70.44.113.83.res-:33849 24.229.54.212:domain    ESTABLISHED 
    udp        0      0 *:tl1-raw-ssl           *:*                                 
    udp        0      0 xw62-work.local:ntp     *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 *:50654                 *:*                                 
    udp        0      0 *:60656                 *:*                                 
    raw        0      0 *:ipv6-icmp             *:*                     7           
    Active UNIX domain sockets (servers and established)
    Proto RefCnt Fla
    
    
    
    
    AFTER CONNECTING VIA SSH
    
    ito@xw62-work:~> ssh root@70.44.113.89
    Password for root@:
    Password for root@:
    Last login: Wed Dec  3 07:31:32 2014 from 70.44.113.83
    FreeBSD 10.1-RELEASE (RPI-B) #0 r274401: Wed Nov 12 04:42:19 UTC 2014
    
    Welcome to FreeBSD!
    
    Release Notes, Errata: https://www.FreeBSD.org/releases/
    Security Advisories:   https://www.FreeBSD.org/security/
    FreeBSD Handbook:      https://www.FreeBSD.org/handbook/
    FreeBSD FAQ:           https://www.FreeBSD.org/faq/
    Questions List: https://lists.FreeBSD.org/mailman/listinfo/freebsd-questions/
    FreeBSD Forums:        https://forums.FreeBSD.org/
    
    Documents installed with the system are in the /usr/local/share/doc/freebsd/
    directory, or can be installed later with:  pkg install en-freebsd-doc
    For other languages, replace "en" with a language code like de or fr.
    
    Show the version of FreeBSD installed:  freebsd-version ; uname -a
    Please include that output and any error messages when posting questions.
    Introduction to manual pages:  man man
    FreeBSD directory layout:      man hier
    
    Edit /etc/motd to change this login announcement.
    root@:~ # 
    
    
    
    LOCAL
    
    
    ito@xw62-work:~> netstat -a
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    tcp        0      0 70.44.113.83.res-:46688 70.44.113.89:ssh        ESTABLISHED 
    tcp        0      0 *:ssh                   *:*                     LISTEN      
    tcp        0      0 localhost:ipp           *:*                     LISTEN      
    tcp        0      0 localhost:smtp          *:*                     LISTEN      
    udp        0      0 *:bootpc                *:*                                 
    udp        0      0 70.44.113.83.res-cm:ntp *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:53646                 *:*                                 
    udp        0      0 *:ipp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 *:tl1-raw-ssl           *:*                                 
    udp        0      0 xw62-work.local:ntp     *:*                                 
    udp        0      0 localhost:ntp           *:*                                 
    udp        0      0 *:ntp                   *:*                                 
    udp        0      0 *:mdns                  *:*                                 
    udp        0      0 *:50654                 *:*                                 
    udp        0      0 *:60656                 *:*                                 
    raw        0      0 *:ipv6-icmp             *:*                     7           
    Active UNIX domain sockets (servers and established)
    
    
    
    
    RPi
    
    root@:~ # netstat -a
    Active Internet connections (including servers)
    Proto Recv-Q Send-Q Local Address          Foreign Address        (state)
    tcp4       0      0 70.44.113.89.ssh       70.44.113.83.46688     ESTABLISHED
    tcp4       0      0 *.ftp                  *.*                    LISTEN
    tcp6       0      0 *.ftp                  *.*                    LISTEN
    tcp4       0      0 70.44.113.89.telnet    *.*                    LISTEN
    tcp4       0      0 70.44.113.89.ssh       *.*                    LISTEN
    tcp4       0      0 70.44.113.89.ftp       *.*                    LISTEN
    tcp4       0      0 *.ssh                  *.*                    LISTEN
    tcp6       0      0 *.ssh                  *.*                    LISTEN
    Active UNIX domain sockets
    Address  Type   Recv-Q Send-Q    Inode     Conn     Refs  Nextref Addr
    c2a77b00 stream      0      0 c2a5ec60        0        0        0 /var/run/devd.pipe
    c2a77a50 seqpac      0      0 c2a5eb40        0        0        0 /var/run/devd.seqpacket.pipe
    root@:~ #

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,740
    Blog Entries
    3

    Default Re: ssh to local machine fails unless tricked

    Quote Originally Posted by a59303 View Post
    Specifically, I think I get Network is unreachable or, Name or service not known.
    Okay.

    That's a network problem, rather than an "ssh" problem. You just happen to notice it when using "ssh".

    Your "ifconfig" outputs show a link-local IPv6 address, but no IPv4 address.

    AFTER PLUGGING IN MACHINE xw62 to INTERNET
    I'm not sure what you are saying there.

    If your computer was not connected to a network, then it is not surprising that you could not make a network connection. And it is not surprising that plugging in to a network changed this.

    If your ssh is just back to the same computer, then use "ssh localhost" to connect. That only depends on a virtual local network. If you ssh is to another home computer, then you need some sort of connection to the local network for that.

    I am probably still not understanding the problem.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    May 2012
    Location
    Northeast US
    Posts
    116

    Default Re: ssh to local machine fails unless tricked

    Quote Originally Posted by nrickert View Post
    Okay.

    That's a network problem, rather than an "ssh" problem. You just happen to notice it when using "ssh".

    Your "ifconfig" outputs show a link-local IPv6 address, but no IPv4 address.
    you mean

    Code:
    inet6 addr: fe80::217:8ff:fe2a:25a5/64
    but nothing like

    Code:
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1
    in other words no inet but inet6. I was thinking that is the problem because the FreeBSD is set up to use ipv4.

    On the RPi when it is connected
    Code:
    ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=80001<RXCSUM,LINKSTATE>
        ether b8:27:eb:20:0e:71
        inet 70.44.113.89 netmask
    but the entire ifconfig of that interface is missing ipv6 info, maybe. Unfortunately I um unsure which to change and how to do it the Raspberry Pi or The xw6200. On the xw6200 which is running OpenSUSE, I can go into the Network dialog in YAST and turn ipv6 off. I tried that though and it does not seem to work.

    Code:
    ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=80001<RXCSUM,LINKSTATE>
        ether b8:27:eb:20:0e:71
        inet 70.44.113.89 netmask 0xff000000 broadcast 70.255.255.255 
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    Quote Originally Posted by nrickert View Post
    I'm not sure what you are saying there.

    If your computer was not connected to a network, then it is not surprising that you could not make a network connection. And it is not surprising that plugging in to a network changed this.

    If your ssh is just back to the same computer, then use "ssh localhost" to connect. That only depends on a virtual local network. If you ssh is to another home computer, then you need some sort of connection to the local network for that.

    I am probably still not understanding the problem.


    Thats Ok, when I end up looking for help I am usually exasperated. I am typing on a hp xw6200 workstation, this is my main computer. After I connect the ethernet from the modem to this machine (xw62.home), I can access the internet. Once Network Manager or some subsystem establishes a connection, I can then unplug the ethernet cable from the modem and plug the ethernet cable from the RPi into it establishing a connection that I can use for ftp and ssh. If I don't do this trick it does not work.

    So the sequence relative to the code I pasted is this;

    1.) Starts without label, at this point the xw6200(xw62.home) is disconnected from everything.

    2.) AFTER PLUGGING IN MACHINE xw62 to INTERNET -- corresponds to the main computer getting connected to modem via ethernet.

    3.) AFTER PLUGGING RPi BACK INTO XW62 --- corresponds to unplugging the ethernet cable (from the modem) and replacing it
    with the ethernet cable (from the RPi).

    4.) AFTER CONNECTING VIA SSH -- corresponds to connecting with ssh after this sequence which results in a successful ssh
    session

    INFO

    LOCAL -- readouts from the xw6200, my main computer and the machine I am typing and using ssh from (to RPi), which is running
    OpenSUSE openSUSE 13.2 (Harlequin) (x86_64) 64-bit and Gnome Version 3.14.1

    RPi --- readouts from Raspberry Pi running FreeBSD while connected via ssh (from xw6200)


    Thanks a bunch,

    a5'
    Last edited by a59303; 02-Dec-2014 at 12:19. Reason: formating

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,740
    Blog Entries
    3

    Default Re: ssh to local machine fails unless tricked

    Quote Originally Posted by a59303 View Post
    in other words no inet but inet6. I was thinking that is the problem because the FreeBSD is set up to use ipv4.
    That's not really a problem. I have only had IPv6 from my ISP for around 6 months. Before that, it was all IPv4, which should be fine.

    On the RPi when it is connected
    Code:
    ue0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=80001<RXCSUM,LINKSTATE>
        ether b8:27:eb:20:0e:71
        inet 70.44.113.89 netmask
    but the entire ifconfig of that interface is missing ipv6 info, maybe.
    That should not matter.

    Thats Ok, when I end up looking for help I am usually exasperated. I am typing on a hp xw6200 workstation, this is my main computer. After I connect the ethernet from the modem to this machine (xw62.home), I can access the internet. Once Network Manager or some subsystem establishes a connection, I can then unplug the ethernet cable from the modem and plug the ethernet cable from the RPi into it establishing a connection that I can use for ftp and ssh. If I don't do this trick it does not work.
    Okay. I think I'm beginning to understand your problem.

    Your issue is that your network card is not initialized unless you are connected to the modem. But you want to disconnect that, so that you can plug the RPI into the same connector.

    The best way of solving your problem, is to use a home router.

    Your router plugs into the modem (or not, if you don't want that).

    You connect both your main computer and your RPI to the router.

    Your computer will then have an IP address from the router, even if the router is not connected to the modem. And you won't have to switch cables around to connect your RPI.

    Okay, that takes a router and maybe an additional ethernet cable. I'm not sure of your budget, but there are probably low cost routers available.

    If you lived in the Chicago area, I'd tell you to buy me a coffee and give you an old router (no longer used) and a short cable. But that's too long a drive from where you live. Maybe there's a local computer hobbyists club where somebody has a working but no-longer-used router.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    May 2012
    Location
    Northeast US
    Posts
    116

    Default Re: ssh to local machine fails unless tricked

    Quote Originally Posted by nrickert View Post
    That's not really a problem. I have only had IPv6 from my ISP for around 6 months. Before that, it was all IPv4, which should be fine.



    That should not matter.
    I was under the impression that they had to have the same type to interface, but this is vague knowledge.


    Quote Originally Posted by nrickert View Post
    Okay. I think I'm beginning to understand your problem.

    Your issue is that your network card is not initialized unless you are connected to the modem. But you want to disconnect that, so that you can plug the RPI into the same connector.

    The best way of solving your problem, is to use a home router.

    Your router plugs into the modem (or not, if you don't want that).

    You connect both your main computer and your RPI to the router.

    Your computer will then have an IP address from the router, even if the router is not connected to the modem. And you won't have to switch cables around to connect your RPI.

    Okay, that takes a router and maybe an additional ethernet cable. I'm not sure of your budget, but there are probably low cost routers available.

    If you lived in the Chicago area, I'd tell you to buy me a coffee and give you an old router (no longer used) and a short cable. But that's too long a drive from where you live. Maybe there's a local computer hobbyists club where somebody has a working but no-longer-used router.

    Budget OK, I appreciate the thought, really! That is very kind of you. That is not really what I am looking for. I intend to have the raspberry as a server and connected to the internet all the time. The only reason I am connecting to it from the xw6200 is to configure it and tinker. I do not think I need a router although I think it would make the current problem go away. I am trying to figure out the configuration details to get it to work, when I plug it in (the Pi).

    I mean, I guess simply put, I want the raspberry pi to recognize the xw6200 everytime I connect them via ethernet not only when I switch the xw6200 from the raspberry pi to the modem back to the raspberry pi.

    Like I said I have looked at the network configuration stuff in YAST but don't really get it. Suffice it to say I think it is this end (xw6200, OpenSUSE) that needs to be configured.

    thanks,

    a5'

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,740
    Blog Entries
    3

    Default Re: ssh to local machine fails unless tricked

    To configure a network connection, you need to give it an IP address.

    The standard practice is to use "DHCP" to request an IP address from a DHCP server somewhere.

    The trick you are using allows your main system to request an IP address, probably from an ISP provided server. And that allows the network to be configured.

    An alternative would be for you to manually configure an IP address. But since this has to match what your ISP expects, that can cause problems if the ISP ever changes how it is assigning and routing IP addresses.

    When you use a SOHO router ("Small Office Home Office"), that router will run a local DHCP server. The router DHCP server gives out private IP addresses such as 192.168.1.5. When you communicate with the Internet, the router translates all of the packets so that they go out using the public IP address provided by the ISP.

    You could still manually assign IP addresses that way. But you would assign addresses within the private IP range supported by the router. Then, even if your ISP changes how it is routing, your home router will manage that part and it won't affect what you are doing. That will make it a lot easier to do what you are trying.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    May 2012
    Location
    Northeast US
    Posts
    116

    Default Re: ssh to local machine fails unless tricked

    So, is it possible all I have to do is change the /etc/hosts file to something that is reasonable and it will all work? I have purchased a static ip but am learning how to use it..

    a5'

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,740
    Blog Entries
    3

    Default Re: ssh to local machine fails unless tricked

    Quote Originally Posted by a59303 View Post
    So, is it possible all I have to do is change the /etc/hosts file to something that is reasonable and it will all work?
    No, that's not enough.

    If you are using NetworkManager, then you will need to edit the settings for your ethernet connection. Otherwise, use:
    Yast --> Network Devices --> Network Settings
    and edit the settings for the ethernet device (give it a fixed IP address).

    You may also need to edit "/etc/hosts".
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •