Results 1 to 7 of 7

Thread: Update - a bit confused

  1. #1

    Default Update - a bit confused

    hi

    i'm a bit confused by the update process. ive installed 13.2 kde from the official source and i've added a few repos, e.g packman, libdvdcss.

    when i zypper up i get the following:

    Code:
    sudo zypper up
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following 6 package updates will NOT be installed:
      amarok gstreamer-0_10-plugin-gnomevfs gstreamer-plugins-good libgstsdp-1_0-0 
      libsox2 sox 
    
    Nothing to do.

    now if i zypper dup i get

    Code:
    sudo zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    The following 2 NEW packages are going to be installed:
      libid3tag0 openSUSE-release-ftp 
    
    The following application is going to be REMOVED:
      Apper 
    
    The following 6 packages are going to be upgraded:
      amarok gstreamer-0_10-plugin-gnomevfs gstreamer-plugins-good libgstsdp-1_0-0 
      libsox2 sox 
    
    The following 33 packages are going to be downgraded:
      apper appmenu-qt bluedevil bluedevil-lang choqok cln digikam-doc 
      gtk2-engine-oxygen gtk2-theme-oxygen kde-gtk-config kio_iso konversation 
      konversation-lang ksshaskpass ktorrent kvkbd lensfun-data libbluedevil2 
      libepub0 libkgeomap-lang liblensfun0 libmediawiki1 libodfgen-0_1-1 
      libqalculate5 libraw10 libtag-extras1 libtelepathy-qt4-2 python3-setuptools 
      python-setuptools skanlite skanlite-doc skanlite-lang synaptiks 
    
    The following 39 packages are going to change vendor:
      amarok                          openSUSE -> http://packman.links2linux.de
      apper                           obs://build.opensuse.org/KDE -> openSUSE 
      appmenu-qt                      obs://build.opensuse.org/KDE -> openSUSE 
      bluedevil                       obs://build.opensuse.org/KDE -> openSUSE 
      bluedevil-lang                  obs://build.opensuse.org/KDE -> openSUSE 
      choqok                          obs://build.opensuse.org/KDE -> openSUSE 
      cln                             obs://build.opensuse.org/KDE -> openSUSE 
      digikam-doc                     obs://build.opensuse.org/KDE -> openSUSE 
      gstreamer-0_10-plugin-gnomevfs  openSUSE -> http://packman.links2linux.de
      gstreamer-plugins-good          openSUSE -> http://packman.links2linux.de
      gtk2-engine-oxygen              obs://build.opensuse.org/KDE -> openSUSE 
      gtk2-theme-oxygen               obs://build.opensuse.org/KDE -> openSUSE 
      kde-gtk-config                  obs://build.opensuse.org/KDE -> openSUSE 
      kio_iso                         obs://build.opensuse.org/KDE -> openSUSE 
      konversation                    obs://build.opensuse.org/KDE -> openSUSE 
      konversation-lang               obs://build.opensuse.org/KDE -> openSUSE 
      ksshaskpass                     obs://build.opensuse.org/KDE -> openSUSE 
      ktorrent                        obs://build.opensuse.org/KDE -> openSUSE 
      kvkbd                           obs://build.opensuse.org/KDE -> openSUSE 
      lensfun-data                    obs://build.opensuse.org/KDE -> openSUSE 
      libbluedevil2                   obs://build.opensuse.org/KDE -> openSUSE 
      libepub0                        obs://build.opensuse.org/KDE -> openSUSE 
      libgstsdp-1_0-0                 openSUSE -> http://packman.links2linux.de
      libkgeomap-lang                 obs://build.opensuse.org/KDE -> openSUSE 
      liblensfun0                     obs://build.opensuse.org/KDE -> openSUSE 
      libmediawiki1                   obs://build.opensuse.org/KDE -> openSUSE 
      libodfgen-0_1-1                 obs://build.opensuse.org/KDE -> openSUSE 
      libqalculate5                   obs://build.opensuse.org/KDE -> openSUSE 
      libraw10                        obs://build.opensuse.org/KDE -> openSUSE 
      libsox2                         openSUSE -> http://packman.links2linux.de
      libtag-extras1                  obs://build.opensuse.org/KDE -> openSUSE 
      libtelepathy-qt4-2              obs://build.opensuse.org/KDE -> openSUSE 
      python3-setuptools              obs://build.opensuse.org/KDE -> openSUSE 
      python-setuptools               obs://build.opensuse.org/KDE -> openSUSE 
      skanlite                        obs://build.opensuse.org/KDE -> openSUSE 
      skanlite-doc                    obs://build.opensuse.org/KDE -> openSUSE 
      skanlite-lang                   obs://build.opensuse.org/KDE -> openSUSE 
      sox                             openSUSE -> http://packman.links2linux.de
      synaptiks                       obs://build.opensuse.org/KDE -> openSUSE 
    
    
    6 packages to upgrade, 33 to downgrade, 2 new, 39  to change vendor.
    Overall download size: 33.9 MiB. Already cached: 6.9 MiB  After the operation, 
    additional 126.6 KiB will be used.
    Continue? [y/n/? shows all options] (y)
    seems like it would remedy the packages not being upgraded by switching the source, however i assume the zypper dup is a distribution upgrade? would that take me away from 13.2?

    a little advice would be appreciated here.

    thanks.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Update - a bit confused

    On 2014-11-28 23:36, cliffordjnr wrote:



    > Code:
    > --------------------
    > sudo zypper up
    > root's password:
    > Loading repository data...
    > Reading installed packages...
    >
    > The following 6 package updates will NOT be installed:
    > amarok gstreamer-0_10-plugin-gnomevfs gstreamer-plugins-good libgstsdp-1_0-0
    > libsox2 sox
    >
    > Nothing to do.
    > --------------------


    So? That's GOOD.


    > now if i zypper dup i get



    Don't use dup, unless you have a specific and good reason to do so.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,702

    Default Re: Update - a bit confused

    Package that are announced not to be installed/updated are often from a different repo So say you have a package from regular repo but the same package may be in packman. And maybe packman is newer but in order to use packman you have to preform a vendor change (read vendor = repo). ie vendors are not changed unless you tell the system to change vendors. So zypper sees that there are newer package and notifies you that these packages won't be upgraded (because of a different vendor)

    You only use dup for a distribution upgrade. or if you happen to be using tumbleweed. Tumbleweed is the cutting edge version of openSUSE and you should know what you are doing if you go there.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Update - a bit confused

    Maybe you should post your repos list
    zypper lr -d

    But the behaviour you are seeing is typical

    More especially if you have followed the multimedia guide here:
    https://forums.opensuse.org/entry.ph...ltimedia-Guide
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Update - a bit confused

    ok thanks guys that clears up a lot for me. ive switched from debian where i never had to deal with vendor changes at least manually anyway. im assuming vendor change still keeps me on 13.2?

    i had installed the multimedia libraries but hadnt perfomed that switch the packman in yast. i've now done so and is i zypper up i now only recieve

    Code:
    sudo zypper up
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following 2 package updates will NOT be installed:
      libmediastreamer_base3 libmediastreamer_voip3 
    
    Nothing to do.
    in terms of repositores i just have the standard ones as well as packman and libdvdcss

    Code:
    zypper lr -d
    # | Alias                | Name                         | Enabled | Refresh | Priority | Type   | URI                                                          | Service
    --+----------------------+------------------------------+---------+---------+----------+--------+--------------------------------------------------------------+--------
    1 | ftp.gwdg.de-suse     | Packman Repository           | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.2/     |        
    2 | libdvdcss repository | libdvdcss repository         | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.2/                         |                    
    3 | repo-non-oss         | openSUSE-13.2-Non-Oss        | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/non-oss/ |                    
    4 | repo-oss             | openSUSE-13.2-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.2/repo/oss/     |                    
    5 | repo-update          | openSUSE-13.2-Update         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2/                    |                    
    6 | repo-update-non-oss  | openSUSE-13.2-Update-Non-Oss | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.2-non-oss/            |

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Update - a bit confused

    13.2 yes

    It looks fine to me
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,702

    Default Re: Update - a bit confused

    Vendors are just another name for repositories so a vendor change means change to another repository.

    Since repos can have the same packages but may not be the save build versions you don't want to mix them that is why zypper does not simply take the newest no matter what repo. This can cause mixed libraries and that leads to trouble with a capital T. So the choice is put into the users capable hands and thus the vendor change functionality

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •