Results 1 to 5 of 5

Thread: Gwenview plays videos with blue tint

  1. #1

    Exclamation Gwenview plays videos with blue tint

    Ahoy!
    Looks like the old and know problem is back in OpenSUSE 13.2 64 bit, with KDE 4.14.
    It had to be resolved in KDE 4.8: https://community.kde.org/Phonon/Rel...Streamer/4.8.0
    But now the bug is still here.
    I've installed all gstreamer codecs, but still no luck. Standalone media players have no problems with MP4 videos, but Gwenview plays them with ugly blue tone.
    If I switch to phonon-vlc in systemsettings, the problem is gone, but this is unacceptable because I don't like VC backend.
    Is there any solution?
    I also wonder how other distros coped with it. I had OpenMandriva on another partition, and Gwenview there plays all videos beautifully.
    Please help!

  2. #2

    Default Re: Gwenview plays videos with blue tint

    Quote Originally Posted by tolstoy View Post
    Looks like the old and know problem is back in OpenSUSE 13.2 64 bit, with KDE 4.14.
    It had to be resolved in KDE 4.8: https://community.kde.org/Phonon/Rel...Streamer/4.8.0
    That's Phonon-Gstreamer 4.8, _not_ KDE 4.8.
    Phonon's version numbers are independent of KDE.

    But openSUSE 13.2 does contain phonon-backend-gstreamer-4.8.0.

    But now the bug is still here.
    I've installed all gstreamer codecs, but still no luck. Standalone media players have no problems with MP4 videos, but Gwenview plays them with ugly blue tone.
    What standalone players have you tried?
    VLC e.g. doesn't use gstreamer.
    Try with Totem and/or dragonplayer (uses phonon as well, just like gwenview).
    If dragonplayer doesn't have this problem, it must be a bug in gwenview.
    If Totem has this problem as well, it must be a bug in gstreamer.
    Otherwise it seems to be a bug in gstreamer-backend-gstreamer.

    If I switch to phonon-vlc in systemsettings, the problem is gone, but this is unacceptable because I don't like VC backend.
    Why don't you like it?
    I actually much prefer it over gstreamer any day.

    Is there any solution?
    Yes. Use phonon-backend-vlc, or use a video player for watching videos. Gwenview is a picture viewer...

    I also wonder how other distros coped with it. I had OpenMandriva on another partition, and Gwenview there plays all videos beautifully.
    Maybe this is a bug in gstreamer?
    Your OpenMandriva might have had a different version, or phonon might even still use gstreamer-0_10 there. (like in openSUSE upto and including 13.1)
    Or it's related to the graphics driver. Which one are you using?

    Btw, I don't see (and never have) anything like this here on my radeon system, even if I switch to phonon-backend-gstreamer.

  3. #3

    Default Re: Gwenview plays videos with blue tint

    Quote Originally Posted by wolfi323 View Post
    That's Phonon-Gstreamer 4.8, _not_ KDE 4.8.
    Why don't you like it?
    I actually much prefer it over gstreamer any day.
    When I use VLC backend, my Multimedia section in Systemsettings doesn't allow me to change device priority. I have two mikes and I need to set em up for correct work with Skype. VLC merges evrything into one input and one output.

    Quote Originally Posted by wolfi323 View Post
    Maybe this is a bug in gstreamer?
    I noticed that 13.2 has an updated package for phonon-backend-gstreamer. I'm gonna try it soon.

  4. #4

    Default Re: Gwenview plays videos with blue tint

    Quote Originally Posted by tolstoy View Post
    When I use VLC backend, my Multimedia section in Systemsettings doesn't allow me to change device priority. I have two mikes and I need to set em up for correct work with Skype. VLC merges evrything into one input and one output.
    AFAIK that's a PulseAudio feature, no?
    I don't either use PA, nor Skype, nor microphones, so no idea.

    I noticed that 13.2 has an updated package for phonon-backend-gstreamer. I'm gonna try it soon.
    Yeah, right.
    13.2 shipped with 0.7.80, 0.8.0 was released as update, but nearly 2 weeks ago already.

  5. #5

    Default Re: Gwenview plays videos with blue tint

    Quote Originally Posted by wolfi323 View Post
    AFAIK that's a PulseAudio feature, no?
    I don't either use PA, nor Skype, nor microphones, so no idea.
    In theory, I can use phonon-backend-vlc and control my audio sinks in PA GUI, which is used for Gnome. But I just don't want to. KDE has a perfect integration with Gstreamer, so no extra quirks are needed, Systemsettungs in enough.


    Quote Originally Posted by wolfi323 View Post
    13.2 shipped with 0.7.80, 0.8.0 was released as update, but nearly 2 weeks ago already.
    The problem was solved after I updated the system and phonon-backend-gstreamer 4.8 arrived.
    Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •