Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: 13.2: Kaffeine spielt keine mp4-Dateien ab

  1. #11

    Default Re: 13.2: Kaffeine spielt keine mp4-Dateien ab

    Quote Originally Posted by RRatse View Post
    Wow das wars. Noch ein paar Anbieterwechsel bei anderen Libs und jetzt läufts wieder . Ich hatte vorher das System aber ganz neu aufgespielt vorher gings noch nicht.
    Tja, kommt vor.
    Gewisse Bibliotheken gibts ja auch in der Distribution, die sind dann eingeschränkt.
    Ist leider aus rechtlichen Gründen so.

    Grade bei Kaffeine sollte aber an sich die Installation von libxine2-codecs ausreichen.

    Danke Ich nehme alles von vorhin zurück Suse ist eben doch das einzige System dem man vertrauen kann.
    Tja, das "einzige" würde ich auch nicht sagen, aber ich benutze seit 11 Jahren nur (open)SUSE, und bereue es bis heute nicht...

    Jetzt müssen meine Drucker wieder so drucken wie es vor den Updates war(anderrer Threat) dann ist alles wieder in Ordnung
    Hm, ja.
    Ich hoffe, das ist auch noch in den Griff zu bekommen.
    Persönlich hab ich kein Problem mit Druckern hier, aber ich muss zugeben dass ich mir 13.2 eigentlich selber noch gar nicht probiert habe zu drucken...

  2. #12

    Default Re: 13.2: Kaffeine spielt keine mp4-Dateien ab

    Hallo zusammen,

    ich bin erst seit 2 Tagen Linux Nutzer, bitte also schon mal vorab um Vergebung für dumme Fragen. Ich habe mir jetzt schon zwei Abende einen Wolf gesucht, um zu verstehen, wie ich diese Lösung hier nachvollziehen kann, aber ich kriege das nicht auf die Kette. Beim Öffnen einer MP4 Datei mit Kaffeine kommt die erwähnte Fehlermeldung, das automatische YaST2 Update läuft ins leere und findet nichts. Meine Repo Liste sieht so aus:

    # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisieren | Priorität | Typ | URI | Dienst
    --+---------------------------+------------------------------------+-----------+-----------------+---------------+-----------+--------+-----------------------------------------------------------------+-------
    1 | openSUSE-13.2-0 | openSUSE-13.2-0 | Ja | ( p) Ja | Nein | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-PIONEER_DVD+_-RW_DR-K17Y |
    2 | repo-debug | openSUSE-13.2-Debug | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/debug/d...13.2/repo/oss/ |
    3 | repo-debug-update | openSUSE-13.2-Update-Debug | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2/ |
    4 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/debug/update/13.2-non-oss/ |
    5 | repo-non-oss | openSUSE-13.2-Non-Oss | Ja | ( p) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    6 | repo-oss | openSUSE-13.2-Oss | Ja | ( p) Ja | Ja | 99 | yast2 | http://download.opensuse.org/distrib...13.2/repo/oss/ |
    7 | repo-source | openSUSE-13.2-Source | Ja | (r ) Ja | Ja | 99 | yast2 | http://download.opensuse.org/source/...13.2/repo/oss/ |
    8 | repo-update | openSUSE-13.2-Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/13.2/ |
    9 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Ja | ( p) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/13.2-non-oss/ |

    Wenn ich mir unter YaST2 -> Software installieren oder löschen -> Paketgruppen -> Productivity -> Multimedia -> Video anzeigen lassen, was installiert ist, dann sehe ich da eine Zeile libxine2 und libxine2-pulse mit einem Häkchen dran, sieht für den Anfänger so aus, als wäre das geforderte Paket installiert.

    Und wenn ich eine DVD einlege, zeigt Kaffeine kurz den Titel an, weiteres Abspielen findet aber ohne Fehlermeldung nicht statt.

    Könnt ihr mit diesen Infos erkennen, wo der Fehler liegt?

    Danke.
    Mark

  3. #13
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,975

    Default AW: 13.2: Kaffeine spielt keine mp4-Dateien ab

    Könnt ihr mit diesen Infos erkennen, wo der Fehler liegt?
    openSUSE liefert keine patentbehaftetetn Codecs mit, die muss man mit Einbinden des Packman Repos selbst machen.
    Das kann man durch Installation hier machen:
    http://opensuse-community.org/

  4. #14

    Default Re: 13.2: Kaffeine spielt keine mp4-Dateien ab

    Quote Originally Posted by Sauerland View Post
    openSUSE liefert keine patentbehaftetetn Codecs mit, die muss man mit Einbinden des Packman Repos selbst machen.
    Das kann man durch Installation hier machen:
    http://opensuse-community.org/
    Und als zusätzliche Information: für Kaffeine im speziellen benötigst du das Paket "libxine2-codecs".
    Das Packman-Repo findest du übrigens auch in YaST->Software-Repositories wenn du auf "Hinzufügen" klickst und "Gemeinschafts-/Community-Repositories" auswählst, falls du es lieber händisch machen willst...

  5. #15

    Default Re: 13.2: Kaffeine spielt keine mp4-Dateien ab

    Super, danke! Dachte irgendwie, ich hätte diese libxine2 codecs schon drauf, weil sie im YaST zu sehen waren. Egal, jetzt geht's.
    Danke,
    Mark

  6. #16

    Default Re: 13.2: Kaffeine spielt keine mp4-Dateien ab

    hallo - habe exakt dasselbe problem - kann in kaffeine keine mp4 videos abspielen

    was kann ich tun

    mein Problem - ich hab hier noch opensuse 13.2 am laufen

    freu mich auf tipps

    vg

    update: habe dann mal folgendes gemacht: ##

    Code:
    s
    #  | Alias                     | Name                               | Aktiviert | Aktualisieren
    ---+---------------------------+------------------------------------+-----------+--------------
     1 | All_of_Packman            | Packman                            | Ja        | Nein         
     2 | home:Herbster0815         | home:Herbster0815                  | Ja        | Ja           
     3 | openSUSE-13.2-0           | openSUSE-13.2-0                    | Ja        | Nein         
     4 | repo-debug                | openSUSE-13.2-Debug                | Nein      | Ja           
     5 | repo-debug-update         | openSUSE-13.2-Update-Debug         | Nein      | Ja           
     6 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | Nein      | Ja           
     7 | repo-non-oss              | openSUSE-13.2-Non-Oss              | Ja        | Ja           
     8 | repo-oss                  | openSUSE-13.2-Oss                  | Ja        | Ja           
     9 | repo-source               | openSUSE-13.2-Source               | Nein      | Ja           
    10 | repo-update               | openSUSE-13.2-Update               | Ja        | Ja           
    11 | repo-update-non-oss       | openSUSE-13.2-Update-Non-Oss       | Ja        | Ja           
    martin@linux-afmk:~> 
    martin@linux-afmk:~> 
    martin@linux-afmk:~> sudo zypper dup --from "Packman Repository"
    Die Systemverwaltung ist durch die Anwendung mit dem PID 19543 (/usr/lib/YaST2/bin/y2base) gesperrt.
    Schließen Sie diese Anwendung, bevor Sie es erneut probieren.
    martin@linux-afmk:~> zypper install libxine2-codecs k3b-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 
    Zum Installieren oder Deinstallieren von Paketen werden root-Rechte benötigt.
    martin@linux-afmk:~> su
    Passwort: 
    linux-afmk:/home/martin # zypper install libxine2-codecs k3b-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2                                                                         
    3 Probleme:
    Problem: libpng15.so.15, benötigt von gstreamer-0_10-plugins-bad-0.10.23-172.1.i586, wird von keinem Repository angeboten
    Problem: libavcodec.so.52, benötigt von gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586, wird von keinem Repository angeboten
    Problem: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 benötigt k3b = 2.0.80+git20150209.2250-1.2, was aber nicht angeboten werden kann
    
    Problem: libpng15.so.15, benötigt von gstreamer-0_10-plugins-bad-0.10.23-172.1.i586, wird von keinem Repository angeboten
    Lösung 1: gstreamer-0_10-plugins-bad-0.10.23-172.1.i586 nicht installieren
    Lösung 2: gstreamer-0_10-plugins-bad-0.10.23-172.1.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/u/w/b] (b): u 
    
    Problem: libavcodec.so.52, benötigt von gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586, wird von keinem Repository angeboten
    Lösung 1: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586 nicht installieren
    Lösung 2: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/u/w/b] (b): u
    
    Problem: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 benötigt k3b = 2.0.80+git20150209.2250-1.2, was aber nicht angeboten werden kann
      Nicht installierbare Anbieter: k3b-2.0.80+git20150209.2250-1.2.i586[All_of_Packman]
    Lösung 1: k3b-2.0.80+git20150209.2250-1.2.i586 installieren (mit Anbieterwechsel)
      openSUSE --> http://packman.links2linux.de
    Lösung 2: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 nicht installieren
    Lösung 3: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/3/u/w/b] (b): u
    Abhängigkeiten auflösen ...
    Paketabhängigkeiten auflösen ...
    3 Probleme:
    Problem: libpng15.so.15, benötigt von gstreamer-0_10-plugins-bad-0.10.23-172.1.i586, wird von keinem Repository angeboten
    Problem: libavcodec.so.52, benötigt von gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586, wird von keinem Repository angeboten
    Problem: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 benötigt k3b = 2.0.80+git20150209.2250-1.2, was aber nicht angeboten werden kann
    
    Problem: libpng15.so.15, benötigt von gstreamer-0_10-plugins-bad-0.10.23-172.1.i586, wird von keinem Repository angeboten
    Lösung 1: gstreamer-0_10-plugins-bad-0.10.23-172.1.i586 nicht installieren
    Lösung 2: gstreamer-0_10-plugins-bad-0.10.23-172.1.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/u/w/b] (b): 1
    
    Problem: libavcodec.so.52, benötigt von gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586, wird von keinem Repository angeboten
    Lösung 1: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586 nicht installieren
    Lösung 2: gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.7.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/u/w/b] (b): 1
    
    Problem: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 benötigt k3b = 2.0.80+git20150209.2250-1.2, was aber nicht angeboten werden kann
      Nicht installierbare Anbieter: k3b-2.0.80+git20150209.2250-1.2.i586[All_of_Packman]
    Lösung 1: k3b-2.0.80+git20150209.2250-1.2.i586 installieren (mit Anbieterwechsel)
      openSUSE --> http://packman.links2linux.de
    Lösung 2: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 nicht installieren
    Lösung 3: k3b-codecs-2.0.80+git20150209.2250-1.2.i586 beschädigen durch Ignorieren einiger Abhängigkeiten
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder (b)rechen ab. [1/2/3/u/w/b] (b): 2
    Abhängigkeiten auflösen ...
    Paketabhängigkeiten auflösen ...
    
    Die folgenden 9 NEUEN Pakete werden installiert:
      gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon lame liba52-0 libfaad2 libmad0 libmpeg2-0 libsidplay1 libxine2-codecs 
    
    Die folgenden 2 Pakete werden aktualisiert:
      libxine2 libxine2-pulse 
    
    2 Pakete werden aktualisiert, 9 neue.
    Gesamtgröße des Downloads: 3,7 MiB. Bereits zwischengespeichert: 0 B  Nach der Operation werden zusätzlich 3,8 MiB belegt.
    Fortfahren? [j/n/? zeigt alle Optionen] (j): j
    Paket libmpeg2-0-0.5.1-3.1.i586 wird abgerufen                                                                                                            (1/11),  54,6 KiB (159,8 KiB entpackt)
    Abruf: libmpeg2-0-0.5.1-3.1.i586.rpm ...................................................................................................................................................[fertig]
    Paket lame-3.99.5-1014.1.i586 wird abgerufen                                                                                                              (2/11),  46,5 KiB ( 87,5 KiB entpackt)
    Abruf: lame-3.99.5-1014.1.i586.rpm .....................................................................................................................................................[fertig]
    Paket libmad0-0.15.1b-1.3.i586 wird abgerufen                                                                                                             (3/11),  70,6 KiB (135,1 KiB entpackt)
    Abruf: libmad0-0.15.1b-1.3.i586.rpm ....................................................................................................................................................[fertig]
    Paket libfaad2-2.7-15.2.i586 wird abgerufen                                                                                                               (4/11), 129,2 KiB (253,5 KiB entpackt)
    Abruf: libfaad2-2.7-15.2.i586.rpm ......................................................................................................................................................[fertig]
    Paket liba52-0-0.7.5+svn613-1.1.i586 wird abgerufen                                                                                                       (5/11),  20,3 KiB ( 38,4 KiB entpackt)
    Abruf: liba52-0-0.7.5+svn613-1.1.i586.rpm ..............................................................................................................................................[fertig]
    Paket libsidplay1-1.36.59-158.1.2.i586 wird abgerufen                                                                                                     (6/11),  74,0 KiB (266,2 KiB entpackt)
    Abruf: libsidplay1-1.36.59-158.1.2.i586.rpm ............................................................................................................................................[fertig]
    Paket libxine2-1.2.6-5.3.1.i586 wird abgerufen                                                                                                            (7/11),   2,4 MiB (  6,1 MiB entpackt)
    Delta wird abgerufen: ./i586/libxine2-1.2.3_1.2.6-5.1.3_5.3.1.i586.drpm, 517,1 KiB
    Abruf: libxine2-1.2.3_1.2.6-5.1.3_5.3.1.i586.drpm ........................................................................................................................[fertig (301,3 KiB/s)]
    Delta wird angewendet: ./libxine2-1.2.3_1.2.6-5.1.3_5.3.1.i586.drpm ....................................................................................................................[fertig]
    Paket libxine2-pulse-1.2.6-5.3.1.i586 wird abgerufen                                                                                                      (8/11),  16,7 KiB ( 21,7 KiB entpackt)
    Abruf: libxine2-pulse-1.2.6-5.3.1.i586.rpm .............................................................................................................................................[fertig]
    Paket gstreamer-0_10-plugins-ugly-0.10.19-15.1.i586 wird abgerufen                                                                                        (9/11), 134,3 KiB (363,2 KiB entpackt)
    Abruf: gstreamer-0_10-plugins-ugly-0.10.19-15.1.i586.rpm ...............................................................................................................................[fertig]
    Paket libxine2-codecs-1.2.6-93.5.i586 wird abgerufen                                                                                                     (10/11), 622,0 KiB (  1,9 MiB entpackt)
    Abruf: libxine2-codecs-1.2.6-93.5.i586.rpm .............................................................................................................................................[fertig]
    Paket gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-15.1.i586 wird abgerufen                                                                            (11/11), 175,3 KiB (539,5 KiB entpackt)
    Abruf: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-15.1.i586.rpm ....................................................................................................................[fertig]
    Test auf Dateikonflikte: ...............................................................................................................................................................[fertig]
    ( 1/11) Installation von: libmpeg2-0-0.5.1-3.1 .........................................................................................................................................[fertig]
    ( 2/11) Installation von: lame-3.99.5-1014.1 ...........................................................................................................................................[fertig]
    ( 3/11) Installation von: libmad0-0.15.1b-1.3 ..........................................................................................................................................[fertig]
    ( 4/11) Installation von: libfaad2-2.7-15.2 ............................................................................................................................................[fertig]
    ( 5/11) Installation von: liba52-0-0.7.5+svn613-1.1 ....................................................................................................................................[fertig]
    ( 6/11) Installation von: libsidplay1-1.36.59-158.1.2 ..................................................................................................................................[fertig]
    ( 7/11) Installation von: libxine2-1.2.6-5.3.1 .........................................................................................................................................[fertig]
    ( 8/11) Installation von: libxine2-pulse-1.2.6-5.3.1 ...................................................................................................................................[fertig]
    ( 9/11) Installation von: gstreamer-0_10-plugins-ugly-0.10.19-15.1 .....................................................................................................................[fertig]
    (10/11) Installation von: libxine2-codecs-1.2.6-93.5 ...................................................................................................................................[fertig]
    (11/11) Installation von: gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-15.1 ..........................................................................................................[fertig]
    Es gibt einige aktive Programme, die Dateien verwenden, die durch die letzte Aktualisierung gelöscht wurden. Sie können einige davon testen und neu starten wollen. Zum Auflisten dieser Programme starten Sie 'zypper ps'.
    linux-afmk:/home/martin #

  7. #17

    Default AW: Re: 13.2: Kaffeine spielt keine mp4-Dateien ab

    Quote Originally Posted by dilbertone View Post
    mein Problem - ich hab hier noch opensuse 13.2 am laufen
    Und wieso ist das ein Problem?

    update: habe dann mal folgendes gemacht: ##
    Das ist ja schon mal der richtige Weg.
    Aber:
    Code:
    #  | Alias                     | Name                               | Aktiviert | Aktualisieren
    ---+---------------------------+------------------------------------+-----------+-------------- 
     1 | All_of_Packman            | Packman                            | Ja        | Nein
    Die automatische Aktualisierung des Packman Repos ist deaktiviert. Dadurch bekommt zypper Änderungen im Repo nicht mit und versucht Pakete zu installieren die es gar nicht mehr gibts.
    Führe "zypper ref" aus und das "Problem" sollte behoben sein.
    Oder noch besser, schalte die automatische Aktualisierung ein, entweder in YaST->Software Repositories oder mit "zypper mr -r 1".

    Das solltest du aber wissen, ganz neu bist du ja auch nicht mehr...

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •