Results 1 to 3 of 3

Thread: ssh localhost failed

  1. #1

    Default ssh localhost failed

    Hello:

    I am trying to make passwordless for ssh login into localhost, but I noticed that it always failed event I didn't do anything for setting:

    Code:
    >ssh localhost
    ssh: connect to host localhost port 22: Connection refused
    However, I don't have any problem ssh to other machine.

    Does anybody have any idea? I am using openSUSE 13.2

    thank you very much.

    Albert

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: ssh localhost failed

    On 2014-11-22 10:26, albumns wrote:

    > However, I don't have any problem ssh to other machine.


    Because you probably did not start the sshd daemon.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,631
    Blog Entries
    3

    Default Re: ssh localhost failed

    Go to Yast Services Manager.
    Enable the sshd service.
    Start the sshd service.

    Alternatively, at the command line (as root)
    Code:
    # systemctl start sshd.service
    # systemctl enable sshd.service
    The "start" will start the service for your current session.

    The "enable" will cause the service to be automatically started on future boots.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •