Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KMixer - Master channel volume

  1. #1

    Default KMixer - Master channel volume

    Hi there!
    Every time I reboot the PC, the master channel's volume is set to 33%. (This is too low for me.)
    Even when I set the volume to 80%, when I reboot the PC, the volume back to 33%.
    I test this condition with the "Start " configuration of KMix has checked or not "Restore volumes on login".

    How can I set the volume in 80% every time I reboot the PC?

    Thank you in advance.
    [Adrián E. Córdoba]

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: KMixer - Master channel volume

    First set the master volume as required

    Then from within konsole
    Code:
    kmixctrl --save
    followed by
    Code:
    kmixctrl --restore
    The volume setting is then saved as the default and should be restored upon login...
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3

    Default Re: KMixer - Master channel volume

    Quote Originally Posted by tannington View Post
    First set the master volume as required

    Then from within konsole
    Code:
    kmixctrl --save
    followed by
    Code:
    kmixctrl --restore
    The volume setting is then saved as the default and should be restored upon login...
    Paul:
    Thanks for answer.
    I follow your procedure, but it didn't work: After I reboot the PC, the volume is set to 33%.
    [Adrián E. Córdoba]

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: KMixer - Master channel volume

    Only other thing I can think of at the moment, is the restore service running?

    Code:
    systemctl status alsa-restore.service
    There was a bug ( https://bugs.kde.org/show_bug.cgi?id=249180 ) related to kmixer not restoring the volume but I thought it had been resolved.

    Could take a look here for anything helpful: https://en.opensuse.org/SDB:Audio_troubleshooting
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5

    Default Re: KMixer - Master channel volume

    Quote Originally Posted by tannington View Post
    Only other thing I can think of at the moment, is the restore service running?

    Code:
    systemctl status alsa-restore.service
    There was a bug ( https://bugs.kde.org/show_bug.cgi?id=249180 ) related to kmixer not restoring the volume but I thought it had been resolved.

    Could take a look here for anything helpful: https://en.opensuse.org/SDB:Audio_troubleshooting
    Code:
    adrian@ASIA:~> systemctl status alsa-restore.service
    alsa-restore.service - Restore Sound Card State
       Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
       Active: inactive (dead) since Sat 2014-11-22 22:12:52 ART; 1h 6min ago
      Process: 856 ExecStart=/usr/sbin/alsactl restore (code=exited, status=0/SUCCESS)
     Main PID: 856 (code=exited, status=0/SUCCESS)
    Is this OK?
    I don't know ALSA.

    Thnks, again.
    [Adrián E. Córdoba]

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,297

    Default Re: KMixer - Master channel volume

    Quote Originally Posted by aecordoba View Post
    Is this OK?
    Yes, the restore service started at boot, (should have) restored the setting, and then exited.

    Only one other thing I can think of... possibly an application is setting it's volume to < master setting. By making the following change applications can have (their own) volume settings independent of the master volume.

    You'll need root privileges, first make a backup copy of "daemon.conf", located at "/etc/pulse/".

    Then find the line:
    Code:
    ; flat-volumes = yes
    uncomment the line and change to no
    Code:
    flat-volumes = no
    Save the file and reboot for the change to become effective.


    Failing that, I'm sorry, I've no further ideas other than to try the suggestions in the bug report I linked to earlier. Specifically https://bugs.kde.org/show_bug.cgi?id=249180#c58 and onwards.

    If that fails still, then I'd open a new bug report.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  7. #7

    Default Re: KMixer - Master channel volume

    Quote Originally Posted by tannington View Post
    Yes, the restore service started at boot, (should have) restored the setting, and then exited.

    Only one other thing I can think of... possibly an application is setting it's volume to < master setting. By making the following change applications can have (their own) volume settings independent of the master volume.

    You'll need root privileges, first make a backup copy of "daemon.conf", located at "/etc/pulse/".

    Then find the line:
    Code:
    ; flat-volumes = yes
    uncomment the line and change to no
    Code:
    flat-volumes = no
    Save the file and reboot for the change to become effective.


    Failing that, I'm sorry, I've no further ideas other than to try the suggestions in the bug report I linked to earlier. Specifically https://bugs.kde.org/show_bug.cgi?id=249180#c58 and onwards.

    If that fails still, then I'd open a new bug report.
    I have tried modify "/etc/pulse/daemon.conf" as you said, but the problem persist.
    Thank you very much.
    [Adrián E. Córdoba]

  8. #8
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: KMixer - Master channel volume

    On 11/23/2014 09:46 PM, aecordoba wrote:
    >
    > tannington;2678359 Wrote:
    >> Yes, the restore service started at boot, (should have) restored the
    >> setting, and then exited.
    >>
    >> Only one other thing I can think of... possibly an application is
    >> setting it's volume to < master setting. By making the following change
    >> applications can have (their own) volume settings independent of the
    >> master volume.
    >>
    >> You'll need root privileges, first make a backup copy of "daemon.conf",
    >> located at "/etc/pulse/".
    >>
    >> Then find the line:
    >>>

    > Code:
    > --------------------
    > > > ; flat-volumes = yes

    > --------------------
    >>>

    >> uncomment the line and change to no
    >>>

    > Code:
    > --------------------
    > > > flat-volumes = no

    > --------------------
    >>>

    >>
    >> Save the file and reboot for the change to become effective.
    >>
    >>
    >> Failing that, I'm sorry, I've no further ideas other than to try the
    >> suggestions in the bug report I linked to earlier. Specifically
    >> https://bugs.kde.org/show_bug.cgi?id=249180#c58 and onwards.
    >>
    >> If that fails still, then I'd open a new bug report.

    >
    > I have tried modify "/etc/pulse/daemon.conf" as you said, but the
    > problem persist.
    > Thank you very much.
    >
    >


    Did you reboot the computer/restart pulseaudio? See any errors?

    --
    openSUSE Factory 64 bit
    KDE 4.14.1

  9. #9
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: KMixer - Master channel volume

    On 11/20/2014 07:16 PM, aecordoba wrote:
    >
    > Hi there!
    > Every time I reboot the PC, the master channel's volume is set to 33%.
    > (This is too low for me.)
    > Even when I set the volume to 80%, when I reboot the PC, the volume back
    > to 33%.
    > I test this condition with the "Start " configuration of KMix has
    > checked or not "Restore volumes on login".
    >
    > How can I set the volume in 80% every time I reboot the PC?
    >
    > Thank you in advance.
    >
    >


    Also have you tried this with veromix? I personally prefer it to kmix
    and using it can help us determine if it is a KMix issue or if it is a
    pulseaudio thing.

    --
    openSUSE Factory 64 bit
    KDE 4.14.1

  10. #10

    Default Re: KMixer - Master channel volume

    Quote Originally Posted by alanbortu View Post
    On 11/20/2014 07:16 PM, aecordoba wrote:
    >
    > Hi there!
    > Every time I reboot the PC, the master channel's volume is set to 33%.
    > (This is too low for me.)
    > Even when I set the volume to 80%, when I reboot the PC, the volume back
    > to 33%.
    > I test this condition with the "Start " configuration of KMix has
    > checked or not "Restore volumes on login".
    >
    > How can I set the volume in 80% every time I reboot the PC?
    >
    > Thank you in advance.
    >
    >


    Also have you tried this with veromix? I personally prefer it to kmix
    and using it can help us determine if it is a KMix issue or if it is a
    pulseaudio thing.

    --
    openSUSE Factory 64 bit
    KDE 4.14.1
    I don't know veromix!
    [Adrián E. Córdoba]

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •