Results 1 to 3 of 3

Thread: Opensuse broken after upgrading to 13.2

  1. #1

    Default Opensuse broken after upgrading to 13.2

    Upgraded from 13.1 to 13.2 and it looks like something has gone horribly wrong.

    The services all appear to start but if I run yast I get the yast menu loaded only there are no modules in it.

    Also if I then try and reinstall yast using rpm or zypper I get:

    zypper: error while loading shared libraries: cannot open shared object file: No such file or directory

    The is present under /usr/lib64/
    I've also tried copying it from a working 13.2 server but to no avail.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Opensuse broken after upgrading to 13.2


    Run a system update, see if that restores consistency and installs latest packages
    zypper update
    If that doesn't work, and particularly if this is a brand new upgrade to 13.2, maybe do an online re-install upgrade
    zypper dup
    As always,
    If there is anything you want to preserve from your current state, do some kind of backup before running either of the above.


  3. #3

    Default Re: Opensuse broken after upgrading to 13.2

    Thanks for the info.

    I tried using the dvd to redo the upgrade - it went through fine but after a reboot I kept getting kernel panics.

    Luckily I had a backup of the data and /etc/ folders. Rebuilt with the latest version and slowly brought everything back to working order.

    Note to self - next time remember to backup the DNS master files (Not in the /etc folder!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts