Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Vuze don't start

  1. #1

    Unhappy Vuze don't start

    Hello,

    I downloaded and installed vuze from here : http://software.opensuse.org/package/Vuze
    (I'm using 13.2)
    but when I click on vuze on the main menu (Internet -> Vuze) it doesn't start

    If someone can help me ...

    Thanks

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Vuze don't start

    do you have a java runtime installed, if so what, vuze is a java app it needs a jre to run, I'm not sure the jre that comes with openSUSE has all the needed classes you might need to download and install oracle's jre
    https://en.opensuse.org/SDB:Installing_Java

    ps try qbittorrent it's a qt c++ app and doesn't need java
    http://software.opensuse.org/package/qbittorrent

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Vuze don't start

    open a terminal and start Vuze from it
    #Vuze
    you'll see if there are some problems with java or other packages,
    note the start-up script starts with a capital V and you must use the proper case.

  4. #4

    Default Re : Vuze don't start

    Result :
    Code:
    Starting Azureus...
    OOPS, you don't seem to have a valid JRE [java = openjdk]
    You need to upgrade to JRE 1.4.x or newer from http://java.sun.com
    Java exec not found in PATH, starting auto-search...
    Java exec found in  /usr/lib64/jvm/jre-openjdk/bin/
    OOPS, you don't seem to have a valid JRE  [/usr/lib64/jvm/jre-openjdk/bin/java = openjdk]
    You need to upgrade to JRE 1.4.x or newer from http://java.sun.com
    I_A said :
    do you have a java runtime installed, if so what, vuze is a java app it needs a jre to run, I'm not sure the jre that comes with openSUSE has all the needed classes you might need to download and install oracle's jre
    https://en.opensuse.org/SDB:Installing_Java

    ps try qbittorrent it's a qt c++ app and doesn't need java
    http://software.opensuse.org/package/qbittorrent
    I know Vuze is using java JRE but I thought mine was sufficient but it seems that I have to update it.
    Yeah for qbittorent I don't like java too but vuze was interesting because it include an option to disconnect the bittorent transfert when vpn disconnect.
    But if you know another client bittorrent wich is doing that ?

  5. #5

    Default Re : Vuze don't start

    I followed this to install/update java :
    https://www.java.com/fr/download/hel...pm_install.xml
    But that says :
    Code:
     % rpm -ivh jre-8u25-linux-x64.rpm                        lib64/java linux-7o7a
    Preparing...                          ################################# [100%]
        package jre1.8.0_25-1.8.0_25-fcs.x86_64 is already installed
     % rpm -Uvh jre-8u25-linux-x64.rpm                        lib64/java linux-7o7a
    Preparing...                          ################################# [100%]
        package jre1.8.0_25-1.8.0_25-fcs.x86_64 is already installed
    I tried to install in /usr/lib64/java

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,387
    Blog Entries
    2

    Default Re: Vuze don't start

    IMO the easiest way to install the Oracle7 JDK (which includes the JRE) is to use the scripts I created
    https://github.com/putztzu/openSUSE_Oracle_Java_Install

    As the instructions say,
    Just download and install the RPM from the Oracle website (link on the page)
    Then for either 32-bit or 64-bit, just run the scripts in order.

    TSU

  7. #7

    Default Re : Re: Vuze don't start

    Quote Originally Posted by tsu2 View Post
    IMO the easiest way to install the Oracle7 JDK (which includes the JRE) is to use the scripts I created
    https://github.com/putztzu/openSUSE_Oracle_Java_Install

    As the instructions say,
    Just download and install the RPM from the Oracle website (link on the page)
    Then for either 32-bit or 64-bit, just run the scripts in order.

    TSU
    I cloned your git in my home.
    I executed installed the rpm and execute scripts but for the five one:
    Code:
    ./5.Install_javac_into_update-alternatives.sh 
    update-alternatives: warning: forcing reinstallation of alternative /usr/lib64/jdk_Oracle/bin/javac because link group javac is broken
    update-alternatives: warning: skip creation of /usr/bin/appletviewer because associated file /usr/lib64/jdk_Oracle/bin/appletviewer (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/appletviewer.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/appletviewer.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/apt because associated file /usr/lib64/jdk_Oracle/bin/apt (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/apt.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/apt.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/extcheck because associated file /usr/lib64/jdk_Oracle/bin/extcheck (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/extcheck.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/extcheck.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jar because associated file /usr/lib64/jdk_Oracle/bin/jar (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jar.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jar.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jarsigner because associated file /usr/lib64/jdk_Oracle/bin/jarsigner (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jarsigner.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jarsigner.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/javac.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/javac.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/javadoc because associated file /usr/lib64/jdk_Oracle/bin/javadoc (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/javadoc.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/javadoc.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/javah because associated file /usr/lib64/jdk_Oracle/bin/javah (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/javah.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/javah.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/javap because associated file /usr/lib64/jdk_Oracle/bin/javap (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/javap.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/javap.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jcmd.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jcmd.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jconsole because associated file /usr/lib64/jdk_Oracle/bin/jconsole (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jconsole.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jconsole.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jdb because associated file /usr/lib64/jdk_Oracle/bin/jdb (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jdb.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jdb.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jhat because associated file /usr/lib64/jdk_Oracle/bin/jhat (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jhat.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jhat.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jinfo because associated file /usr/lib64/jdk_Oracle/bin/jinfo (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jinfo.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jinfo.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jmap because associated file /usr/lib64/jdk_Oracle/bin/jmap (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jmap.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jmap.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jps because associated file /usr/lib64/jdk_Oracle/bin/jps (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jps.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jps.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jrunscript because associated file /usr/lib64/jdk_Oracle/bin/jrunscript (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jrunscript.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jrunscript.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jsadebugd because associated file /usr/lib64/jdk_Oracle/bin/jsadebugd (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jsadebugd.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jsadebugd.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jstack because associated file /usr/lib64/jdk_Oracle/bin/jstack (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jstack.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jstack.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jstat because associated file /usr/lib64/jdk_Oracle/bin/jstat (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jstat.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jstat.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/jstatd because associated file /usr/lib64/jdk_Oracle/bin/jstatd (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/jstatd.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/jstatd.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/native2ascii because associated file /usr/lib64/jdk_Oracle/bin/native2ascii (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/native2ascii.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/native2ascii.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/pack200 because associated file /usr/lib64/jdk_Oracle/bin/pack200 (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/pack200.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/pack200.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/rmic because associated file /usr/lib64/jdk_Oracle/bin/rmic (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/rmic.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/rmic.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/schemagen because associated file /usr/lib64/jdk_Oracle/bin/schemagen (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/serialver because associated file /usr/lib64/jdk_Oracle/bin/serialver (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/wsgen because associated file /usr/lib64/jdk_Oracle/bin/wsgen (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/wsgen.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/wsgen.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/wsimport because associated file /usr/lib64/jdk_Oracle/bin/wsimport (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/wsimport.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/wsimport.1.gz (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/bin/xjc because associated file /usr/lib64/jdk_Oracle/bin/xjc (of link group javac) doesn't exist
    update-alternatives: warning: skip creation of /usr/share/man/man1/xjc.1.gz because associated file /usr/lib64/jdk_Oracle/man/man1/xjc.1.gz (of link group javac) doesn't exist

  8. #8

    Default Re : Vuze don't start

    I tried to start Vuze after that but it doesn't work:
    Code:
    Vuze                    
    Starting Azureus...
    OOPS, you don't seem to have a valid JRE [java = openjdk]
    You need to upgrade to JRE 1.4.x or newer from http://java.sun.com
    Java exec not found in PATH, starting auto-search...
    Java exec found in  /usr/lib64/jvm/jre-openjdk/bin/
    OOPS, you don't seem to have a valid JRE  [/usr/lib64/jvm/jre-openjdk/bin/java = openjdk]
    You need to upgrade to JRE 1.4.x or newer from http://java.sun.com

  9. #9

    Default Re: Vuze don't start

    Vuze worked fine in 13.1, but fails to start in 13.2 for me too. Just install brand new system, download Vuze, start it - get error:

    OOPS, you don't seem to have a valid JRE

    Default JRE that comes out of the box is openjdk 1.8.0_40. For some reason Vuze fails to detect it
    I filed a support question on their forum, waiting for someone to response: http://forum.vuze.com/Thread-openSUS...S-no-valid-JRE

  10. #10

    Default Re: Vuze don't start

    Got reply on the official forum. This little modification of "vuze" startup script will resolve the issue:

    Code:
    --- vuze.old    2014-11-19 23:25:22.000000000 +0200
    +++ vuze        2014-11-23 20:08:10.158406359 +0200
    @@ -93,7 +93,7 @@
     
            JAVA_HEADER=`"${JAVA_PROGRAM_DIR}java" -version 2>&1 | head -n 1`
            JAVA_IMPL=`echo ${JAVA_HEADER} | cut -f1 -d' '`
    -       if [ "$JAVA_IMPL" = "java" ] ; then
    +       if [ "$JAVA_IMPL" = "openjdk" ] ; then
                    VERSION=`echo ${JAVA_HEADER} | sed "s/java version \"\(.*\)\"/\1/"`
                    if echo $VERSION | grep "^1.[0-3]" ; then
                            echo $MSG3 "[${JAVA_PROGRAM_DIR}java = ${VERSION}]" ; echo $MSG4

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •