Results 1 to 5 of 5

Thread: Firefox Opens in Half-Screen

  1. #1

    Default Firefox Opens in Half-Screen

    Anyone know why Firefox now opens every time in a half-windowed screen? Somehow this setting started yesterday, and I have no idea why. I always close out Firefox in a full windowed state, and normally apps are supposed to restart in the same manner in which they last closed. I know Linux doesn't always do this, but didn't know if it was an application setting or a openSUSE OS setting.

    Thanks!

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,325

    Default Re: Firefox Opens in Half-Screen

    Quote Originally Posted by EmpireITtech View Post
    Anyone know why Firefox now opens every time in a half-windowed screen? Somehow this setting started yesterday, and I have no idea why. I always close out Firefox in a full windowed state, and normally apps are supposed to restart in the same manner in which they last closed. I know Linux doesn't always do this, but didn't know if it was an application setting or a openSUSE OS setting.

    Thanks!
    Possibly corrupted "localstore.rdf" ( located below ~/.mozilla/firefox/... )

    Close Firefox, rename the file as f.e. "localstore.rdf.existing", restart Firefox see if the problem persists.

    I've had problems with both Firefox and Thunderbird in the past with regard to window size and placement. If you're using KDE you can set "Window Rules".
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191203) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: Firefox Opens in Half-Screen

    Quote Originally Posted by EmpireITtech View Post
    Anyone know why Firefox now opens every time in a half-windowed screen?
    I'm not quite sure what you mean by "half-windowed screen".

    What I do notice on my desktop, is that if I maximize "firefox", then when I unmaximize it, the result is using only the top half of the screen. So I have to resize it. Perhaps that's similar to what you mean.

    The same thing happens with "konqueror" and "rekonq" and probably others. I don't think it happens on my laptop, with a slightly smaller screen. Hmm, let me try that: no, it doesn't happen on my laptop. Perhaps it depends on the display size.

    This also happened with 13.1.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Firefox Opens in Half-Screen

    Might check the KDE Special windows settings.

  5. #5

    Default Re: Firefox Opens in Half-Screen

    Quote Originally Posted by tannington View Post
    Possibly corrupted "localstore.rdf" ( located below ~/.mozilla/firefox/... )

    Close Firefox, rename the file as f.e. "localstore.rdf.existing", restart Firefox see if the problem persists.

    I've had problems with both Firefox and Thunderbird in the past with regard to window size and placement. If you're using KDE you can set "Window Rules".
    This seems to have worked, cheers mate!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •