Results 1 to 6 of 6

Thread: OS13.2 Glabels 3.2.1 missing GNU Barcode Support

  1. #1

    Default OS13.2 Glabels 3.2.1 missing GNU Barcode Support

    Glabels coming with OpenSUSe 13.2 is unable to use GNU Barcode Library.

    This seems to be the bug mentioned here:

    https://bugs.launchpad.net/ubuntu/+s...131/comments/3

    So I downloaded the source and compiled it according

    http://glabels.sourceforge.net/doc/install-src/

    But the result is, that GNU Barcode still cannot be used, and QR Code is also not any more available.

    Anyone can assist, how to get the support for GNU Barocde back?

    Or is there any Programm that would be as Powerful as Kbarcode (unfortunately not working any more)

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: OS13.2 Glabels 3.2.1 missing GNU Barcode Support

    Hi
    It would appear that the graphics folks dropped the header file (devel package) hence glabels won't include it...weird. I will look at it tomorrow and see about re-adding and doing test builds of both for you to try.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: OS13.2 Glabels 3.2.1 missing GNU Barcode Support

    Thank you

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: OS13.2 Glabels 3.2.1 missing GNU Barcode Support

    On Thu 20 Nov 2014 08:16:02 AM CST, max spam wrote:


    Thank you


    Hi
    I think I have it sorted...
    https://build.opensuse.org/project/s...nches:graphics

    Build options now show;
    Code:
    [  183s] Configuration:
    [  183s]
    [  183s]         Package ................. glabels-3.2.1
    [  183s]         Installation prefix ..... /usr
    [  183s]         Source code location .... .
    [  183s]         Compiler ................ gcc
    [  183s]
    [  183s]
    [  183s] Optional data merge backends:
    [  183s]
    [  183s]         Evolution Data Server ... yes
    [  183s]
    [  183s]
    [  183s] Optional barcode backends:
    [  183s]
    [  183s]         GNU Barcode ............. yes
    [  183s]         QR Code ................. yes
    [  183s]         IEC 16022 ............... no (See http://datenfreihafen.org/projects/iec16022.html)
    [  183s]         Zint .................... no (See http://www.zint.org.uk)
    I've set the build/publish flag for openSUSE 13.2 x86_64 only, so you
    should be able to get both packages from;
    http://download.opensuse.org/reposit.../openSUSE_13.2

    If the link doesn't work or you need a different build, please advise.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: OS13.2 Glabels 3.2.1 missing GNU Barcode Support

    Thanks mate it works.

    An installation issue needs to be said.

    Adding the repository with an simply clicking on install of glabels does not work.

    In Yast you will need to check the option to switch from system packages to those in the repository.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: OS13.2 Glabels 3.2.1 missing GNU Barcode Support

    Quote Originally Posted by max_spam View Post
    Thanks mate it works.

    An installation issue needs to be said.

    Adding the repository with an simply clicking on install of glabels does not work.

    In Yast you will need to check the option to switch from system packages to those in the repository.
    Hi
    Thanks for the feedback, will see about a proper fix for glabels.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •