Results 1 to 2 of 2

Thread: Can't change spamassassin preferences

  1. #1

    Default Can't change spamassassin preferences

    I upgraded to 13.2, and now spamassassin is not reading its preferences file. I had lots of custom scores set up, and I can see in the mail headers that spamassassin is using its default scoring. So, now it's letting through hundreds of messages a day. I used the wizard in Kmail to set up spamassassin, and the spam-handling filters seem to have been created correctly. I tried changing the Kmail filter that pipes mail through spamassassin by adding "--prefspath=/home/dan/.spamassassin/user_prefs", and that didn't help. My custom prefs were used correctly in 13.1.

  2. #2

    Default [SOLVED] Re: Can't change spamassassin preferences

    OK, I finally figured it out. Apparently, spamassassin was exiting with an error every time it ran from within kmail. The scores I could see in the headers were coming from my mail server where I can't change the preferences. To get it to run at home, I had to run sa-update first. That's a new step that was never required before, and not mentioned anywhere obvious like, say, the man page.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •