Results 1 to 6 of 6

Thread: LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

  1. #1

    Default LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

    I am running LibreOffice Base as client for a Mariadb backend under Opensuse 13.2.

    Now a problem has turned up, that was not evident under OpenSuse 13.1.

    Code:
    SQL Status: S1000
    
    An error occurred while creating the report.
    
    An exception of type com.sun.star.uno.RuntimeException was caught.
    
    javaloader error - could not find class com/sun/star/comp/loader/JavaLoader
    What must I do to make the JavaLoader available?

    Cheers
    Harvey

  2. #2

    Default Re: LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

    Quote Originally Posted by hnimmo View Post
    What must I do to make the JavaLoader available?
    Well, I can reproduce that issue here, and not only with MariaDB, but also a native database.
    No idea how to fix it though.

    I guess this might be worth another bug report.

  3. #3

    Default Re: LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

    Quote Originally Posted by wolfi323 View Post
    Well, I can reproduce that issue here, and not only with MariaDB, but also a native database.
    No idea how to fix it though.

    I guess this might be worth another bug report.
    Bug 906688 submitted

  4. #4
    Join Date
    Oct 2009
    Location
    Sweden
    Posts
    1,015

    Default Re: LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

    Quote Originally Posted by hnimmo View Post
    Bug 906688 submitted
    Hi!
    Using oS13.2_64 Harlequin, KDE 4.14.4 and Libreoffice 4.3.5.2.0+ (build ID 430m(Build:2).

    Any news on this?

    I have registred "jtds-1.3.1" "plugin"? for access to MSSQL In Libreoffice, works fine as well to access MySQL trow Libreoffice BASE and can read, sort and export tables.

    Create reports.. No! I receive the errors mentioned above on 2 different computers (config as above in my pors).

    regards
    Last edited by jonte1; 14-Feb-2015 at 06:13. Reason: add info.
    I'm shameless like others in the forum -was I to any help or made sense? If yes: click the on the star below to the left. Written whit a ;-) in my eye.

  5. #5

    Default Re: LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

    As written in the bug report and in https://forums.opensuse.org/showthre...2-installation, install libreoffice from the LibreOffice:4.3 repo (see YaST's Community Repositories list), and it should work.
    You also need the package pentaho-reporting-flow-engine for opening reports, this is probably not installed automatically.

  6. #6

    Default Re: LibreOffice Base / Mariadb cannot find the JavaLoader for executing a report

    Quote Originally Posted by wolfi323 View Post
    As written in the bug report and in https://forums.opensuse.org/showthre...2-installation, install libreoffice from the LibreOffice:4.3 repo (see YaST's Community Repositories list), and it should work.
    An update that fixes the problem has been released today for 13.2.
    And I can confirm that everything works now as it should.

    You also need the package pentaho-reporting-flow-engine for opening reports, this is probably not installed automatically.
    This is still necessary for the standard 13.2 packages for reports to work. But a dependency has been added already in the devel repos, so it will be installed automatically with the next update to 4.3.7 that's probably going to be released in the next few weeks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •