Results 1 to 5 of 5

Thread: "Authentication is required to refresh the system resources",

  1. #1

    Default "Authentication is required to refresh the system resources",

    hi all:

    i have 13.2 and recently start getting this annoying pop message "Authentication is required to refresh the system resources" and asking for root password. it seems to be requested by a package called "The PackageKit Project" and it had been discussed in this forum: < https://forums.opensuse.org/showthre...on-is-required >. from that discussion, supposedly the bug had been supposedly fixed, it seems the bug creep back somehow.

    user@host:~> egrep "(SECURITY|POLKIT_DEFAULT_PRIVS)" /etc/sysconfig/security
    PERMISSION_SECURITY="easy local"
    # PERMISSION_SECURITY. If PERMISSION_SECURITY contains 'secure' or
    POLKIT_DEFAULT_PRIVS=""

    user@host:~> grep system-sources-refresh /etc/polkit*
    grep: /etc/polkit-1: Is a directory
    /etc/polkit-default-privs.restrictiverg.freedesktop.packagekit.system-sources-refresh auth_admin_keep_always
    /etc/polkit-default-privs.standardrg.freedesktop.packagekit.system-sources-refresh auth_admin_keep_always:no:yes

    user@host:~> sudo grep -RA1 system-sources-refresh /etc/polkit-1/
    /etc/polkit-1/rules.d/90-default-privs.rules: 'org.freedesktop.packagekit.system-sources-refresh':
    /etc/polkit-1/rules.d/90-default-privs.rules- [ 'auth_admin_keep', 'no', 'yes' ],

    user@host:~> loginctl
    SESSION UID USER SEAT
    2 1000 mlu
    3 1000 mlu

    2 sessions listed.

    user@host:~> pkaction --action-id org.freedesktop.packagekit.system-sources-refresh --verbose
    org.freedesktop.packagekit.system-sources-refresh:
    description: Refresh system sources
    message: Authentication is required to refresh the system sources
    vendor: The PackageKit Project
    vendor_url: http://www.packagekit.org/
    icon: package-x-generic
    implicit any: auth_admin
    implicit inactive: auth_admin
    implicit active: yes

    thanks.

  2. #2

    Default Re: "Authentication is required to refresh the system resources",

    Quote Originally Posted by ipfreak View Post
    i have 13.2 and recently start getting this annoying pop message "Authentication is required to refresh the system resources" and asking for root password. it seems to be requested by a package called "The PackageKit Project" and it had been discussed in this forum: < https://forums.opensuse.org/showthre...on-is-required >. from that discussion, supposedly the bug had been supposedly fixed, it seems the bug creep back somehow.
    No, that bug should be fixed. And your polkit rules/security settings are ok as well.

    But your user session seems not to be registered with logind, causing missing permissions.
    What does "loginctl" say?

    Let me guess: you are using autofs, right?
    Logout and login again, and the issue should not happen again.
    Or wait a few seconds before logging in the first time.

    There is a problem with autofs.service delaying the start of systemd-logind, so it is not ready when you first login and the session cannot be registered.
    Removing the line "Before=systemd-logind" in /usr/lib/systemd/system/autofs.service should "fix" it.
    http://bugzilla.opensuse.org/show_bug.cgi?id=905639

  3. #3

    Default Re: "Authentication is required to refresh the system resources",

    Quote Originally Posted by wolfi323 View Post
    No, that bug should be fixed. And your polkit rules/security settings are ok as well.

    But your user session seems not to be registered with logind, causing missing permissions.
    What does "loginctl" say?

    Let me guess: you are using autofs, right?
    Logout and login again, and the issue should not happen again.
    Or wait a few seconds before logging in the first time.

    There is a problem with autofs.service delaying the start of systemd-logind, so it is not ready when you first login and the session cannot be registered.
    Removing the line "Before=systemd-logind" in /usr/lib/systemd/system/autofs.service should "fix" it.
    http://bugzilla.opensuse.org/show_bug.cgi?id=905639
    thanks.

    well, as far as i know of, my system uses the default file system (btrfs).

    this popout only happens when i login via remote desktop, not on local machine.

  4. #4

    Default Re: "Authentication is required to refresh the system resources",

    Quote Originally Posted by ipfreak View Post
    well, as far as i know of, my system uses the default file system (btrfs).
    That's irrelevant here.
    I was not talking about any particular file system anyway.

    autofs is a system service that allows you to automatically mount stuff (including remote folders, removeable media, and so on).
    But enabling it can lead to those problems at the moment.

    this popout only happens when i login via remote desktop, not on local machine.
    This is no bug then. These are the default security settings.

    If you are logged in via remote desktop, you do not have the permissions to refresh the software repositories, install updates, or even mount removable media.
    Only a user logged in locally may do that.

    A workaround would be to override the security settings and allow that specifically in /etc/polkit-default-privs.local:
    Code:
    org.freedesktop.packagekit.system-sources-refresh yes
    Or disable "Apper Monitor" in "Configure Desktop"->Startup and Shutdown->Service Management to get rid of those messages.

  5. #5

    Default Re: "Authentication is required to refresh the system resources",

    Quote Originally Posted by wolfi323 View Post
    That's irrelevant here.
    I was not talking about any particular file system anyway.

    autofs is a system service that allows you to automatically mount stuff (including remote folders, removeable media, and so on).
    But enabling it can lead to those problems at the moment.


    This is no bug then. These are the default security settings.

    If you are logged in via remote desktop, you do not have the permissions to refresh the software repositories, install updates, or even mount removable media.
    Only a user logged in locally may do that.

    A workaround would be to override the security settings and allow that specifically in /etc/polkit-default-privs.local:
    Code:
    org.freedesktop.packagekit.system-sources-refresh yes
    Or disable "Apper Monitor" in "Configure Desktop"->Startup and Shutdown->Service Management to get rid of those messages.
    thanks. that worked very well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •