Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Accessing files on /home/myaccount requires a root password

  1. #1
    Join Date
    Oct 2014
    Location
    OKC, OK
    Posts
    54

    Default Accessing files on /home/myaccount requires a root password

    Duders and Duderettes
    Hello all who have helped in the past I do so appreciate it very much! Thank you.

    This is new problem, I was wanting to access some .txt files on my /home/me-account folder and when I did try to open the file it asked for my /root password???? OK,,,I thought just add me to the root group-nope no go.
    This process of accessing a file worked after my 13.2 upgrade from 13.1 so I don’t believe it's from that process, but I believe it might have happened through one of the online updates.

    Any info you need I get let me know.
    system is intel duo Q6600
    Nvidia 9800 gtx+
    Opensuse Harliquin 13.2
    KDE, Gnome, E19, and a few others.
    It does it in all desktop GUI's.

    thnaks
    man
    "I'm sure its a easy fix. It always is."

  2. #2
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: Accessing files on /home/myaccount requires a root password

    On 11/17/2014 02:16 PM, bigtrains67 wrote:
    >
    > Duders and Duderettes
    > Hello all who have helped in the past I do so appreciate it very much!
    > Thank you.
    >
    > This is new problem, I was wanting to access some .txt files on my
    > /home/me-account folder and when I did try to open the file it asked for
    > my /root password???? OK,,,I thought just add me to the root group-nope
    > no go.
    > This process of accessing a file worked after my 13.2 upgrade from 13.1
    > so I don’t believe it's from that process, but I believe it might have
    > happened through one of the online updates.
    >
    > Any info you need I get let me know.
    > system is intel duo Q6600
    > Nvidia 9800 gtx+
    > Opensuse Harliquin 13.2
    > KDE, Gnome, E19, and a few others.
    > It does it in all desktop GUI's.
    >
    > thnaks
    > man
    > "I'm sure its a easy fix. It always is."
    >
    >


    Did you check the permissions for the folder? What are they? Its
    possible you accidentally set them to something strange.

    --
    openSUSE Factory 64 bit
    KDE 4.14.1

  3. #3
    Join Date
    Oct 2014
    Location
    OKC, OK
    Posts
    54

    Default Re: Accessing files on /home/myaccount requires a root password

    Thanks for your enquiry. Yes the folders are owned by me and my group. So is the perticulart .txt file I'm opening. I have never had to enter root password for thus particular file since 13.1.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: Accessing files on /home/myaccount requires a root password

    Oh and you should NOT be in the root group. You will break things.

    Are you absolutely sure that the file is not owned by root or some other user account??

    Does it ask you for the root password or do you just have to become root. Nothing in your home should normally be owned by root or any other user. An old Unix admin trick was to set the rc files owner in the users home to root to keep the user from fiddling with their default settings. But unless you changed it no file or directory should be owned by any but the user and the user group

  5. #5

    Default Re: Accessing files on /home/myaccount requires a root password

    And even if the file was really owned by root, you shouldn't be asked for the root password if you try to open it. It should just fail.
    So can you please explain how exactly you try to open it?
    What exactly are you doing?
    What exact error message/dialog/whatever are you getting?

    Maybe post a screenshot.

  6. #6

    Default Re: Accessing files on /home/myaccount requires a root password

    Is this file possibly marked as executable? So it is an script like issue?

    then try to open with right click open with gedit/kwrite or push it into the opened editor

  7. #7
    Join Date
    Oct 2014
    Location
    OKC, OK
    Posts
    54

    Default Re: Accessing files on /home/myaccount requires a root password/SOLVED!!!

    Max_Spam wrote
    "Is this file possibly marked as executable? So it is an script like issue?

    then try to open with right click open with gedit/kwrite or push it into the opened editor "

    1. I checked the file as executable-no!
    2. script issue-no!
    3. try to open with right click to open with gedit/krite. bingo.
    BUT...
    I learnt, hahaha a new trick today!

    It seems that a right click on the file in question, and go to properties, there is a selection called "file type options" bring up a window with selection named Application Preference Order!
    At the top of my list was guess??? File Manager - Super User. I selected it moved it to the bottom and now all is right with the world.

    This is solved
    Thanks
    everyone

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: Accessing files on /home/myaccount requires a root password

    Not sure that the problem is really solved. It could very well raise it's head again in some other file. You are doing something extremely odd to get things that messed up

  9. #9
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Accessing files on /home/myaccount requires a root password

    Quote Originally Posted by bigtrains67 View Post
    Duders and Duderettes
    Hello all who have helped in the past I do so appreciate it very much! Thank you.

    This is new problem, I was wanting to access some .txt files on my /home/me-account folder and when I did try to open the file it asked for my /root password???? OK,,,I thought just add me to the root group-nope no go.
    This process of accessing a file worked after my 13.2 upgrade from 13.1 so I don’t believe it's from that process, but I believe it might have happened through one of the online updates.

    Any info you need I get let me know.
    system is intel duo Q6600
    Nvidia 9800 gtx+
    Opensuse Harliquin 13.2
    KDE, Gnome, E19, and a few others.
    It does it in all desktop GUI's.

    thnaks
    man
    "I'm sure its a easy fix. It always is."
    You appear to have done something very unusual along the way to permissions, groups, owner, or user.

    ... or a combination of those.

    ... or, are trying to open in some peculiar way.

    The exact operation that you are doing, or full detailed explanation, is required in order to solve the problem permanently. Answer Wolfi's questions, get further help.

    Your little workaround is just that, a workaround. I sense that it will come back to bite you, maybe even quite seriously, down the road.

    Good luck.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  10. #10

    Talking Re: Accessing files on /home/myaccount requires a root password/SOLVED!!!

    Quote Originally Posted by bigtrains67 View Post
    Max_Spam wrote
    "Is this file possibly marked as executable? So it is an script like issue?

    then try to open with right click open with gedit/kwrite or push it into the opened editor "

    1. I checked the file as executable-no!
    2. script issue-no!
    3. try to open with right click to open with gedit/krite. bingo.
    BUT...
    I learnt, hahaha a new trick today!

    It seems that a right click on the file in question, and go to properties, there is a selection called "file type options" bring up a window with selection named Application Preference Order!
    At the top of my list was guess??? File Manager - Super User. I selected it moved it to the bottom and now all is right with the world.

    This is solved
    Thanks
    everyone

    Not a bug, but a feature

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •