Hallo Alle,
ich habe da ein Problem:Ich möchte mit Lunaavr Atmel Attiny und Atmega programmieren, es ist ein Basic-ähnlicher Dialekt.

Die Programmiersprache Lunaavr läuft bei Suse 13.1 64bit aber läßt sich nicht bei 13.2 64 starten.

es kommt die Fehlermeldung :
/home/test/lunaavr-2014r2.4-linux/./RBGUIFramework.so: cannot open shared object

er kann scheinbar nicht auf die Libs zugreifen. Die LIB ist aber unter LunaAVR Libs

---------------------------------

Arbeitsverzeichnis:
est@linux-hkcq:~/lunaavr-2014r2.4-linux> ls -l
insgesamt 84920
drwxr-xr-x 2 test users 4096 8. Dez 2012 avrdude
-rwxr--r-- 1 test users 2201 11. Sep 20:20 CHANGES.TXT
drwxr-xr-x 2 test users 4096 27. Jun 2012 docs
drwxr-xr-x 41 test users 4096 24. Aug 19:01 Examples
drwxr-xr-x 2 test users 4096 18. Nov 2013 Font
drwxr-xr-x 2 test users 4096 26. Nov 2012 Icons
-rw-r--r-- 1 test users 2056 5. Jan 2014 INSTALL.TXT
drwxr-xr-x 2 test users 4096 7. Jan 2013 Language Reference
-rwxr--r-- 1 test users 16683388 11. Sep 20:13 lavrc
-rwxr--r-- 1 test users 21788672 11. Sep 20:10 lavrc.library
drwxr-xr-x 2 test users 4096 4. Jan 2014 lavrc Libs
drwxr-xr-x 4 test users 4096 10. Sep 18:24 Library
-rw-r--r-- 1 test users 2163 11. Nov 2012 LICENSE.TXT
-rw-r--r-- 1 test users 885 11. Nov 2012 LIESMICH.TXT
-rwxr--r-- 1 test users 48391406 11. Sep 20:18 LunaAVR
-rwxr--r-- 1 test users 67 4. Jan 2014 LunaAVR64
-rw-r--r-- 1 test users 12734 10. Sep 18:26 LunaAVR.cfg
drwxr-xr-x 2 test users 4096 19. Jul 14:50 LunaAVR Libs
-rwxr--r-- 1 test users 1004 19. Jul 14:37 LUNASCRIPT.TXT
-rw-r--r-- 1 test users 831 1. Mär 2012 README.TXT
drwxr-xr-x 4 test users 4096 9. Dez 2013 Resources

-----------------------------
einträge export:
declare -x MACHTYPE="x86_64-suse-linux"
~~~~
declare -x PROFILEHOME="/home/test/lunaavr-2014r2.4-linux"
declare -x PROFILEREAD="true"
declare -x PWD="/home/test/lunaavr-2014r2.4-linux"
~~~~

so sieht die Startdatei aus, die den Pfad eigentlich setzen sollte und scheinbar bei 13.2 64 nicht funktioniert.:

test@linux-hkcq:~/lunaavr-2014r2.4-linux> more LunaAVR64
#!/bin/bash

export LD_LIBRARY_PATH=$PWD/LunaAVR\ Libs/
./LunaAVR

--------------------------

ist da ein Problem mit der Pfadverwaltung oder der Bash im Betriebssystem ?
ich kann im Krusader/Dolphin mir den Inhalt des LIB-Verzeichnises ansehen, aber nicht in der Bash/ sh / ksh.

est@linux-hkcq:~/lunaavr-2014r2.4-linux> cd LunaAVR Libs
bash: cd: LunaAVR: Ist kein Verzeichnis

Weiss jemand Abhilfe?

LG sonnnenfee