Results 1 to 4 of 4

Thread: # /sbin/yast2 & ......."Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

  1. #1
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default # /sbin/yast2 & ......."Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

    when I try to launch some application as yast, apper, gparted... I gettin this error, no I'm not in text mode X server is runin every application behave just OK, but when I try to launch apps from terminal I'm gettin this
    Code:
     linux:/home # apper
    apper(12808): KUniqueApplication: Cannot find the D-Bus session server:   "Unable to autolaunch a dbus-daemon without a $DISPLAY for X11" 
    
    apper(12807): KUniqueApplication: Pipe closed unexpectedly.
    I suppose it's problem with some library which handles teh interface D-Bus -> X11. Looked at Xorg logs but nothing suspicious so I guess it should be D-Bus fault but there's another interesting thing - there's no messages file in /var/log ??
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  2. #2

    Default AW: # /sbin/yast2 & ......."Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

    Quote Originally Posted by roberto68 View Post
    when I try to launch some application as yast, apper, gparted... I gettin this error, no I'm not in text mode X server is runin every application behave just OK, but when I try to launch apps from terminal I'm gettin this
    Code:
     linux:/home # apper
    apper(12808): KUniqueApplication: Cannot find the D-Bus session server:   "Unable to autolaunch a dbus-daemon without a $DISPLAY for X11" 
    
    apper(12807): KUniqueApplication: Pipe closed unexpectedly.
    I suppose it's problem with some library which handles teh interface D-Bus -> X11. Looked at Xorg logs but nothing suspicious so I guess it should be D-Bus fault but there's another interesting thing - there's no messages file in /var/log ??
    Looks like you switched to root by running "su" in your user session, right?
    This doesn't work.

    Use kdesu, gnomesu or xdg-su to run graphical applications as root, or "su -".
    And you should not run apper as root anyway. It's designed to be run as user.

  3. #3

    Default Re: # /sbin/yast2 & ......."Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

    Try this:

    Code:
    export $(dbus-launch)
    and make sure that packagekitd is executable

    Code:
    stat -c '%A' /usr/lib/packagekitd
    "Unfortunately time is always against us" -- [Morpheus]

    .:https://github.com/Jetchisel:.

  4. #4
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: # /sbin/yast2 & ......."Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

    you're right wolfi I open the default teminal and did su -s. So I opened terminal in super user mode and it's ok
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •