Results 1 to 6 of 6

Thread: Zypper Update Question

  1. #1

    Default Zypper Update Question

    When I run:
    Code:
    sudo zypper update
    I get the following:
    The following 6 package updates will NOT be installed:
    libfreebl3 libsoftokn3 MozillaFirefox mozilla-kde4-integration mozilla-nss mozilla-nss-certs


    Anyone know why or what this means? Why would it tell me it's not updating those lol

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,504
    Blog Entries
    3

    Default Re: Zypper Update Question

    "zypper update" won't do a vendor change.

    Sometimes a package might exist in several repos with different vendors. If the "newest" version has a different vendor from the installed version, it won't be updated to that "newest" version. I put "newest" in quotes, because zypper can only compare version numbers. So "newest" means "with highest version number". But version numbers between different repos might not be strictly comparable.

    Generally speaking, zypper is doing the right thing. You can override its choice by clicking the "version" tab in Yast, and selecting which version you want.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: Zypper Update Question

    It means one of your repositories has newer versions than you have installed currently, but it won't install them as they come from another provider.

    For example my home repo has nginx that is newer than the distribution version, if you had my repo added and had nginx installed from the OSS repo, it would not automatically update it to mine to prevent vendor change.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  4. #4

    Default Re: Zypper Update Question

    Okay, so here's my current repo list:

    So it looks like the Mozilla browser has a newer version, maybe in the openSUSE BuildServices - Mozilla repo, than the main repo? I do know my current Firefox is at 33.0 whereas the newest version is at 33.1

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,704

    Default Re: Zypper Update Question

    At the bottom-right of the Yast Software management window there are tabs one is version it will tell what is available what is installed and from where

  6. #6

    Default Re: Zypper Update Question

    On 11/13/2014 12:06 PM, nrickert wrote:
    >
    > "zypper update" won't do a vendor change.
    >
    > Sometimes a package might exist in several repos with different vendors.
    > If the "newest" version has a different vendor from the installed
    > version, it won't be updated to that "newest" version. I put "newest"
    > in quotes, because zypper can only compare version numbers. So "newest"
    > means "with highest version number". But version numbers between
    > different repos might not be strictly comparable.
    >
    > Generally speaking, zypper is doing the right thing. You can override
    > its choice by clicking the "version" tab in Yast, and selecting which
    > version you want.
    >
    >


    Or you can use zypper up <package name> to get more detailed info on why
    it is not being updated.

    Ken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •