Results 1 to 3 of 3

Thread: Yast Software management shows weird, unresolvable dependency issues

  1. #1

    Default Yast Software management shows weird, unresolvable dependency issues

    Since I upgraded to openSUSE 13.2, Yast Software Management has been giving me a weird dependency issue that I cannot resolve. Or rather, no matter what I do, it comes back the next time I start the Yast module.

    Those don't look like proper packages. If I elect to uninstall application:Minetest-.noarch and so forth, Yast doesn't make any changes, which confirms to me that those aren't real packages. The KDE packagekit automatic updates utility doesn't seem to get these issues either and works as expected.

    A dependency check in Yast tells me all dependencies are ok.

    I will refrain from posting my repository list here as I'm pretty certain that this has nothing to do with repositories. All I did when I upgraded was to reflect version numbering in my repository list and deactivate those I no longer needed. The problem was almost certainly a result of the upgrade, not of my repositories.

    I appreciate any help!

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,650

    Default Re: Yast Software management shows weird, unresolvable dependency issues

    Probably it is a vendor change that is needed but I don't read German... Perhaps you installed at some point from a now non-existent repo??

    In Yast-Software mangement look up the offendign package see about versions and were the current was installed.

  3. #3

    Default Re: Yast Software management shows weird, unresolvable dependency issues

    I'm sorry, I thought the screenshot was self-explanatory. It says there's a dependency conflict and I should either uninstall the first option, or break dependencies (second option). The missing dependency is "appdata." On the other hand, as I said, Yast doesn't believe there are dependency problems.

    Can you tell me what these names mean? "application:Minetest-.noarch" and so forth? Clearly they're associated with applications, but I've never seen a package name starting with "application:".

    Qupzilla is from the KDE Extra repo, which is active. Firefox is from the current Mozilla repo, same thing. Minetest is from the Games repo, which I have deactivated right now. I just uninstalling Minetest, which reduced the above message to just Firefox and QupZilla.

    I have searched for "appdata" and am installing the packages "appdata-tools", "appdata-tools-lang" and "libzypp-plugin-appdata" from the OSS and Update repos now. They pull three different appstream dependencies. That didn't help.

    The next obvious step was to attempt to delete and reinstall these two browsers. I tested it, but once the package was reinstalled, the error message reappeared. Permanently deleting Firefox is out of the question.

    Any more suggestions? Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •