Results 1 to 6 of 6

Thread: Virtualbox -- no vboxusers to become a member of

  1. #1
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Virtualbox -- no vboxusers to become a member of

    Hi, I'm using opensuse 13.2 and KDE 4.14.2. I installed virtualbox, and at first it didn't load. Then after reading another thread, I removed vboxgtk and python-virtualbox, and installed virtualbox-qt instead. Now, it starts to load, but I get the expected message that I'm supposed to add myself to "vboxusers". However, there is no "vboxusers" group for me to add myself to. Any advice?


    kernel-desktop-3.16.6-2.1.x86_64
    virtualbox-4.3.18-1.6.x86_64
    kernel-macros-3.16.6-2.1.noarch
    kernel-devel-3.16.6-2.1.noarch
    kernel-desktop-devel-3.16.6-2.1.x86_64
    virtualbox-host-kmp-desktop-4.3.18_k3.16.6_2-1.6.x86_64
    virtualbox-qt-4.3.18-1.6.x86_64
    virtualbox-guest-kmp-desktop-4.3.18_k3.16.6_2-1.6.x86_64

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,649

    Default Re: Virtualbox -- no vboxusers to become a member of

    Should have been created at some point. But then you do have root privileges, right? So create the group then add yourself. Since you installed one flavor then changed to another it is possible I guess that the group creation was missed. Maybe has to do with the order you did all that. Uninstalling stuff may have unmade the group

  3. #3

    Default Re: Virtualbox -- no vboxusers to become a member of

    Quote Originally Posted by gogalthorp View Post
    Should have been created at some point.
    Yes, the vboxusers group is created when you install the package virtualbox:
    Code:
    wolfi@linux-lf90:~> rpm -q --scripts virtualbox
    preinstall scriptlet (using /bin/sh):echo "creating group vboxusers..."
    groupadd -r vboxusers 2>/dev/null || :
    ...
    Since you installed one flavor then changed to another it is possible I guess that the group creation was missed. Maybe has to do with the order you did all that. Uninstalling stuff may have unmade the group
    But it is not _removed_ anywhere, at least not in any virtualbox package:
    Code:
    wolfi@linux-lf90:~> 
    rpm -qa --scripts virtualbox* |grep vboxusers
    echo "creating group vboxusers..."
    groupadd -r vboxusers 2>/dev/null || :
    (and vboxgtk does not mess around with groups at all)

    But then you do have root privileges, right? So create the group then add yourself.
    Just creating the group will not suffice, as some of VirtualBox's files have to be _owned_ by that group.

    Can you post the content of /etc/groups?
    Maybe it has in fact been created, but you just didn't see it? How did you try to add yourself to the group?

    Btw, you can uninstall virtualbox-guest-kmp-desktop, this is not needed and useless on the _host_...
    Last edited by wolfi323; 08-Nov-2014 at 10:37.

  4. #4
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Re: Virtualbox -- no vboxusers to become a member of

    Quote Originally Posted by wolfi323 View Post
    Just creating the group will not suffice, as some of VirtualBox's files have to be _owned_ by that group.

    Can you post the content of /etc/groups?
    Maybe it has in fact been created, but you just didn't see it? How did you try to add yourself to the group?

    Btw, you can uninstall virtualbox-guest-kmp-desktop, this is not needed and useless on the _host_...
    You're right, wolfi, it's there but it doesn't show up. When I tried to enter it, the message was there was a conflict between the group name "vboxusers" -- which I was trying to enter --and one that already exists.
    As far as adding myself to a group, I don't find the process very intuitive. Visually, vboxusers was not there, no box to check. Still the contents list shows otherwise.

    Contents of /etc/group:

    root:x:0:
    bin:x:1:daemon
    daemon:x:2:
    sys:x:3:
    tty:x:5:
    disk:x:6:
    lp:x:7:
    www:x:8:
    kmem:x:9:
    wheel:x:10:
    mail:x:12ostfix
    news:x:13:
    uucp:x:14:
    shadow:x:15:
    dialout:x:16:
    audio:x:17ulse
    floppy:x:19:
    cdrom:x:20:
    console:x:21:
    utmp:x:22:
    public:x:32:
    video:x:33:
    games:x:40:
    xok:x:41:
    trusted:x:42:
    modem:x:43:
    ftp:x:49:
    lock:x:54:
    man:x:62:
    users:x:100:
    nobody:x:65533:
    nogroup:x:65534:nobody
    avahi-autoipd:x:499:
    systemd-journal:x:498:
    tape:x:497:
    messagebus:x:496:
    ntp:x:495:
    nscd:x:494:
    tftp:x:493:tftp,dnsmasq
    polkitd:x:492:
    sshd:x:491:
    rtkit:x:490:
    scard:x:489:
    pulse:x:488:
    pulse-access:x:487:
    ntadmin:x:71:
    postfix:x:51:
    maildrop:x:59ostfix
    avahi:x:486:
    kdm:!:485:
    at:x:25:
    mysql:x:484:
    winbind:x:483:
    vboxusers:x:482:

  5. #5

    Default AW: Re: Virtualbox -- no vboxusers to become a member of

    Quote Originally Posted by MoeNeigh View Post
    You're right, wolfi, it's there but it doesn't show up. When I tried to enter it, the message was there was a conflict between the group name "vboxusers" -- which I was trying to enter --and one that already exists.
    _Where_ did you try to enter it?

    As far as adding myself to a group, I don't find the process very intuitive. Visually, vboxusers was not there, no box to check. Still the contents list shows otherwise.

    Contents of /etc/group:
    ...
    vboxusers:x:482:
    In YaST?
    Select your user (in the "Users" tab), click on "Edit", switch to the "Details" tab, and the group "vboxusers" should be on the list to the right ("Additional groups"). Activate the checkbox to add your user to that group.

    You probably switched to the "Groups" tab. It is possible there too, but you have to click on "Set Filter" and choose "System Groups" to see the vboxusers group (it is a system group). Then select it, click on "Edit", and activate your user in the list of group members there.

    AFAIR this hasn't changed in years...



    Or run this:
    Code:
    sudo usermod -aG vboxusers $USER

  6. #6
    Join Date
    May 2012
    Location
    Planet Houston
    Posts
    64

    Default Re: AW: Re: Virtualbox -- no vboxusers to become a member of

    Quote Originally Posted by wolfi323 View Post
    _Where_ did you try to enter it?


    In YaST?
    Select your user (in the "Users" tab), click on "Edit", switch to the "Details" tab, and the group "vboxusers" should be on the list to the right ("Additional groups"). Activate the checkbox to add your user to that group.

    You probably switched to the "Groups" tab. It is possible there too, but you have to click on "Set Filter" and choose "System Groups" to see the vboxusers group (it is a system group). Then select it, click on "Edit", and activate your user in the list of group members there.

    AFAIR this hasn't changed in years...



    Or run this:
    Code:
    sudo usermod -aG vboxusers $USER
    You're right, I did switch to Groups. I started OK, selecting my user, then clicking on Edit, but I failed to move on to the Details tab. I will try to hammer this into my wooden head for future reference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •