Results 1 to 3 of 3

Thread: Power button and suspend on Lock Screen Opensuse 13.2 Gnome

  1. #1

    Default Power button and suspend on Lock Screen Opensuse 13.2 Gnome

    Hi!

    Power off on button and suspend/sleep on button works well on my desktop while the computer is not locked.
    If I lock my computer (Lock Screen), I can't power off on button until I'm logged in again.
    I would like to be able to power off no matter if the lock screen is activated or there are other users logged on as well.

    Can't find info on how to fix this, any one got any idea what to do?

    Help is appreciated!

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,669

    Default Re: Power button and suspend on Lock Screen Opensuse 13.2 Gnome

    Quote Originally Posted by duckmuck View Post
    Hi!

    Power off on button and suspend/sleep on button works well on my desktop while the computer is not locked.
    If I lock my computer (Lock Screen), I can't power off on button until I'm logged in again.
    I would like to be able to power off no matter if the lock screen is activated or there are other users logged on as well.

    Can't find info on how to fix this, any one got any idea what to do?

    Help is appreciated!
    This seems to be the standard "foolproof" behaviour, but the old hard way still works:

    CTRL+ALT+F1
    login as root
    # shutdown -h now

    so it should be possible to devise a script or something that does just that and link it to the pwr button...

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,517
    Blog Entries
    15

    Default Re: Power button and suspend on Lock Screen Opensuse 13.2 Gnome

    Quote Originally Posted by duckmuck View Post
    Hi!

    Power off on button and suspend/sleep on button works well on my desktop while the computer is not locked.
    If I lock my computer (Lock Screen), I can't power off on button until I'm logged in again.
    I would like to be able to power off no matter if the lock screen is activated or there are other users logged on as well.

    Can't find info on how to fix this, any one got any idea what to do?

    Help is appreciated!
    Hi
    Modify the /etc/systemd/logind.conf file and change, by the looks, either of the PowerKey options, read the man page since it explains it better than I could
    Code:
    man logind.conf
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •