Results 1 to 5 of 5

Thread: Howto enable Gnome Shell Extensions in opensuse 13.2 with Firefox

  1. #1

    Default Howto enable Gnome Shell Extensions in opensuse 13.2 with Firefox

    If you try to install Gnome shell extensions in opensuse 13.2 you will get the following warning on the GNOME extensions website:

    "We cannot detect a running copy of GNOME on this system, so some parts of the interface may be disabled. See out troubleshooting entry for more information."

    This is because the Gnome Shell Integration plugin for Firefox is needed to use the Gnome extensions website. The plugin is installed by default, however, Mozilla now has a policy of blocking all plugins, see https://wiki.mozilla.org/Plugins/Firefox_Whitelist. To fix this problem simply click on the "Open menu" button in the upper right corner of the Firefox screen then click the "Add-ons" icon to go to the Mozilla addons website. At the Mozilla addons website type "whitelist" in the search box and search. From the resulting list select and install "Click-to-Play Manager 1.3.1". This Mozilla addon will whitelist the Gnome Shell Integrarion plugin by default; if it does not, just click the "Preferences" button on the "Click-to-Play Manager" and add the Gnome shell extensions website, https://extensions.gnome.org/, to the whitelist. Gnome shell extensions can now be installed.

    The opensuse development team did a great job of leaving this nugget in 13.2. You guys should buy yourself a beer...then fix the problem - you left the Gnome Shell Integration plugin blacklisted by default. 13.2 should have installed with the Gnome shell extensions whitelisted by default. Great job NOT!

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,525
    Blog Entries
    15

    Default Re: Howto enable Gnome Shell Extensions in opensuse 13.2 with Firefox

    Quote Originally Posted by fosdex View Post
    If you try to install Gnome shell extensions in opensuse 13.2 you will get the following warning on the GNOME extensions website:

    "We cannot detect a running copy of GNOME on this system, so some parts of the interface may be disabled. See out troubleshooting entry for more information."

    This is because the Gnome Shell Integration plugin for Firefox is needed to use the Gnome extensions website. The plugin is installed by default, however, Mozilla now has a policy of blocking all plugins, see https://wiki.mozilla.org/Plugins/Firefox_Whitelist. To fix this problem simply click on the "Open menu" button in the upper right corner of the Firefox screen then click the "Add-ons" icon to go to the Mozilla addons website. At the Mozilla addons website type "whitelist" in the search box and search. From the resulting list select and install "Click-to-Play Manager 1.3.1". This Mozilla addon will whitelist the Gnome Shell Integrarion plugin by default; if it does not, just click the "Preferences" button on the "Click-to-Play Manager" and add the Gnome shell extensions website, https://extensions.gnome.org/, to the whitelist. Gnome shell extensions can now be installed.

    The opensuse development team did a great job of leaving this nugget in 13.2. You guys should buy yourself a beer...then fix the problem - you left the Gnome Shell Integration plugin blacklisted by default. 13.2 should have installed with the Gnome shell extensions whitelisted by default. Great job NOT!
    Hi
    I have never had to add anything, yes there is a popup sent via firefox (13.1,13.2, SLED 12) to allow, press that, then a popup to never forget and it's done.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Howto enable Gnome Shell Extensions in opensuse 13.2 with Firefox

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I have never had to add anything, yes there is a popup sent via firefox (13.1,13.2, SLED 12) to allow, press that, then a popup to never forget and it's done.
    Hi Malcolm,

    Firefox never sent the popup so the Gnome extensions site remained blacklisted. The solution was as I posted. This occurred on a fresh install of 13.2, i.e., I completely wiped 13.1 from the system before installing so as to avoid any "upgrade" problems (I really prefer my new set of problems to be unblemished by the old ones).

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,525
    Blog Entries
    15

    Default Re: Howto enable Gnome Shell Extensions in opensuse 13.2 withFirefox

    On Fri 07 Nov 2014 09:26:01 AM CST, fosdex wrote:


    malcolmlewis;2673677 Wrote:
    > Hi
    > I have never had to add anything, yes there is a popup sent via
    > firefox (13.1,13.2, SLED 12) to allow, press that, then a popup to
    > never forget and it's done.


    Hi Malcolm,

    Firefox never sent the popup so the Gnome extensions site remained
    blacklisted. The solution was as I posted. This occurred on a fresh
    install of 13.2, i.e., I completely wiped 13.1 from the system before
    installing so as to avoid any "upgrade" problems (I really prefer my new
    set of problems to be unblemished by the old ones).


    Hi
    Hmmm, well it's a strange one, my SoP is to install adblock, set tls,
    webrtc and peer media connections in about config, then re-add my book
    marks and go the the extensions web site. Did a couple of fresh installs
    of 13.2 from the dvd yesterday (playing with bcache), both times I had
    the pop-up....

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.28-4-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5

    Default Re: Howto enable Gnome Shell Extensions in opensuse 13.2 with Firefox

    While my two stationary workstations have worked ok after 13.2 upgrade/fresh installation, I got this problem on my laptop some time during the 13.2 beta/RC releases. Even not 13.2 fresh installations after removing the Desktop in /home directory did help.

    After I installed the Click-to-play Manager in FF, I also had to add "Gnome Shell Integration" in its settings, because only the IcedTea plugin was there by default. And now happily Gnome shell extenstions are possible to add again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •