Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: mega.co.nz

  1. #1

    Default mega.co.nz

    looking to install sync client for 13.2

    on their website they have 13.1 but if i try this the installation fails in apper with

    Code:
      A package dependency could not be found.
     More information is available in the detailed report.
    
    nothing provides libcares.so.2(CARES_1.2.0)(64bit) needed by megasync-1.0.35-3.1.x86_64
    any ideas?

    thanks

  2. #2

    Default Re: mega.co.nz

    i do have libcares2 installed

  3. #3

    Default Re: mega.co.nz

    Go to this site...
    http://rpmfind.net/linux/rpm2html/se...%29%2864bit%29
    Download the 3rd file down on the list for openSUSE 13.1 "libcares2-1.9.1-2.1.2.x86_64.rpm"
    Install that first, and you're all set.

  4. #4
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: mega.co.nz

    On 11/05/2014 03:26 PM, coolhandlewk wrote:
    >
    > Go to this site...
    > http://tinyurl.com/k6f2bdn
    > Download the 3rd file down on the list for openSUSE 13.1
    > "'libcares2-1.9.1-2.1.2.x86_64.rpm' (http://tinyurl.com/puvycnx)"
    > Install that first, and you're all set.
    >
    >


    Or..
    http://software.opensuse.org/search?...penSUSE%3A13.2

    Which will allow you to keep the package updated.

    --
    openSUSE Factory 64 bit
    KDE 4.14.1

  5. #5

    Default Re: mega.co.nz

    Quote Originally Posted by alanbortu View Post
    On 11/05/2014 03:26 PM, coolhandlewk wrote:
    >
    > Go to this site...
    > http://tinyurl.com/k6f2bdn
    > Download the 3rd file down on the list for openSUSE 13.1
    > "'libcares2-1.9.1-2.1.2.x86_64.rpm' (http://tinyurl.com/puvycnx)"
    > Install that first, and you're all set.
    >
    >


    Or..
    http://software.opensuse.org/search?...penSUSE%3A13.2

    Which will allow you to keep the package updated.

    --
    openSUSE Factory 64 bit
    KDE 4.14.1
    after doing this i was still presented with the same error.

  6. #6

    Default Re: mega.co.nz

    Quote Originally Posted by cliffordjnr View Post
    after doing this i was still presented with the same error.
    Check this package, already installed but also have the same error((

  7. #7

    Default Re: mega.co.nz

    Quote Originally Posted by coolhandlewk View Post
    Go to this site...
    http://rpmfind.net/linux/rpm2html/se...%29%2864bit%29
    Download the 3rd file down on the list for openSUSE 13.1 "libcares2-1.9.1-2.1.2.x86_64.rpm"
    Install that first, and you're all set.
    hmm i was sure i'd replied to this also but maybe not.

    anyway this solution worked for me. thanks guys.

  8. #8

    Default Re: mega.co.nz

    How did you solve the problem?

    I've libcares2 installed as well, but the version installed by OpenSUSE is higher than the version required by megasync:
    Code:
    $ rpm -iv megasync-openSUSE_13.1.x86_64.rpm 
    warning: megasync-openSUSE_13.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 4d70f67a: NOKEY
    error: Failed dependencies:
            libcares.so.2(CARES_1.2.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.3.1)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.4.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.6.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.7.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
    Code:
    ls /usr/lib64/libcar* -la
    lrwxrwxrwx 1 root root    17 Nov 18 17:02 /usr/lib64/libcares.so.2 -> libcares.so.2.1.0
    -rwxr-xr-x 1 root root 68368 Sep 25 14:48 /usr/lib64/libcares.so.2.1.0
    Downgrading would be an option, but it might break something else?

  9. #9

    Default Re: mega.co.nz

    Quote Originally Posted by akirataki7awa View Post
    How did you solve the problem?

    I've libcares2 installed as well, but the version installed by OpenSUSE is higher than the version required by megasync:
    Code:
    $ rpm -iv megasync-openSUSE_13.1.x86_64.rpm 
    warning: megasync-openSUSE_13.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 4d70f67a: NOKEY
    error: Failed dependencies:
            libcares.so.2(CARES_1.2.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.3.1)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.4.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.6.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.7.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
    Code:
    ls /usr/lib64/libcar* -la
    lrwxrwxrwx 1 root root    17 Nov 18 17:02 /usr/lib64/libcares.so.2 -> libcares.so.2.1.0
    -rwxr-xr-x 1 root root 68368 Sep 25 14:48 /usr/lib64/libcares.so.2.1.0
    Downgrading would be an option, but it might break something else?
    i did exactly what i stated above. if i run zypper up it complains about libcares but doesnt give me any problems.

  10. #10

    Default Re: mega.co.nz

    Quote Originally Posted by akirataki7awa View Post
    How did you solve the problem?

    I've libcares2 installed as well, but the version installed by OpenSUSE is higher than the version required by megasync:
    Code:
    $ rpm -iv megasync-openSUSE_13.1.x86_64.rpm 
    warning: megasync-openSUSE_13.1.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 4d70f67a: NOKEY
    error: Failed dependencies:
            libcares.so.2(CARES_1.2.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.3.1)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.4.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.6.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
            libcares.so.2(CARES_1.7.0)(64bit) is needed by megasync-1.0.29-16.1.x86_64
    Code:
    ls /usr/lib64/libcar* -la
    lrwxrwxrwx 1 root root    17 Nov 18 17:02 /usr/lib64/libcares.so.2 -> libcares.so.2.1.0
    -rwxr-xr-x 1 root root 68368 Sep 25 14:48 /usr/lib64/libcares.so.2.1.0
    Downgrading would be an option, but it might break something else?
    do the following

    Go to this site...
    http://rpmfind.net/linux/rpm2html/se...%29%2864bit%29
    Download the 3rd file down on the list for openSUSE 13.1 "libcares2-1.9.1-2.1.2.x86_64.rpm"
    Install that first, and you're all set.
    mega will then work perfectly in 13.2, the only thing you'll get is the following complaint when updating, but if you can live with that then its fine.

    Code:
    sudo zypper up
    Loading repository data...
    Reading installed packages...
    
    The following package update will NOT be installed:
      libcares2 
    
    Nothing to do.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •