Results 1 to 3 of 3

Thread: The 13.2 live rescue system -- what were they thinking?

  1. #1
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default The 13.2 live rescue system -- what were they thinking?

    Before I install 13.2 on my laptop, I want to do some repartitioning.

    So I booted the 13.2 live rescue system (I wrote the iso to a USB).

    Then I found "gparted" in the menu, and selected it.
    Unfortunately, "gparted" never started. The file ".xsession-errors-:0" had a message that "gparted" was unable to connect to the display :0.0 . Failure #1.

    I started an "xterm", and used "su" to become root.
    I then ran "gparted" from the root command line.
    This time, "gparted" did start. But it mounted every partition that it could find. What's the use of that? The whole point of running "gparted" from the rescue image, is to partition a disk when nothing is mounted. Failure #2

    Yes, I'll probably report this as a bug, though it is going to be a bit like closing the barn door after the horses have escaped. And I suppose I should accept some blame for not testing the rescue image during the Beta1 and RC1 test phases.

    Workarounds:

    (a) I rebooted (so that nothing was mounted at the start). Then I logged out from the XFCE session. Next, I logged into an Icewm session. There, I started an xterm, ran su, and started "gparted". When started within "Icewm" it behaves sensibly.

    (b) I tried the live KDE (also written to a USB). Booted to live KDE, "gparted" starts from the menu and does not mount hard drive partitions. Or if I start from a root command prompt, again it does not mount hard drive partitions.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,880
    Blog Entries
    3

    Default Re: The 13.2 live rescue system -- what were they thinking?

    I have reported this as Bug 903885.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: The 13.2 live rescue system -- what were they thinking?

    Quote Originally Posted by nrickert View Post
    And I suppose I should accept some blame for not testing the rescue image during the Beta1 and RC1 test phases.
    Yes, it is all your fault, you know!
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •