Results 1 to 4 of 4

Thread: SEPOLICY is asking for YUM

  1. #1
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default SEPOLICY is asking for YUM

    Hi,

    So I am trying to learn SELinux on my 13.1 box. The sepolicy command ask for yum with every command I do.

    Code:
    Traceback (most recent call last):
      File "/usr/bin/sepolicy", line 456, in <module>
        gen_generate_args(subparsers)
      File "/usr/bin/sepolicy", line 380, in gen_generate_args
        from sepolicy.generate import DAEMON, get_poltype_desc, poltype, DAEMON, DBUS, INETD, CGI, SANDBOX, USER, EUSER, TUSER, XUSER, LUSER, AUSER, RUSER, NEWTYPE
      File "/usr/lib64/python2.7/site-packages/sepolicy/generate.py", line 29, in <module>
        import yum
    ImportError: No module named yum
    I have no idea where to report this, or even, if this is correct and I should install yum on my system. Wouldn't it conflict with zypper?

    What to do?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SEPOLICY is asking for YUM

    On 2014-11-04 12:16, Ricochet wrote:
    >
    > Hi,
    >
    > So I am trying to learn SELinux on my 13.1 box.


    Installed, how, from where?



    > I have no idea where to report this, or even, if this is correct and I
    > should install yum on my system. Wouldn't it conflict with zypper?


    Bugzilla, if an openSUSE package.
    No, No, Yes.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    249

    Default Re: SEPOLICY is asking for YUM

    Thanks for your reply.

    SEPOLICY is found in the package called: policycoreutils-python and this package is from the openSUSE-13.1-Oss repository.

    So I'll report at Bugzilla, thanks!

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: SEPOLICY is asking for YUM

    On 2014-11-04 14:46, Ricochet wrote:
    >
    > Thanks for your reply.
    >
    > SEPOLICY is found in the package called: policycoreutils-python and this
    > package is from the openSUSE-13.1-Oss repository.
    >
    > So I'll report at Bugzilla, thanks!


    Welcome! Thanks for reporting.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •