Results 1 to 5 of 5

Thread: vnc opensuse 13.1 - can only have one GUI login at a time (kdm KDE)

  1. #1

    Default vnc opensuse 13.1 - can only have one GUI login at a time (kdm KDE)

    Hi,

    As a long time Linux and SLES user - as well as a short(ish) time openSUSE user... I'm accustom to being able to have multiple VNC connections (to the same box) active at the same time.

    Here's what I can think of that's relevant:
    • openSUSE 13.1, fully patched
    • physical desktop PC (UEFI mode)
    • Windows 7 (not my choice) running RealVNC 4.1.3
    • Firewall ports 5901, 5902 and 5903 open
    • services vnc1, vnc2 and vnc3 all on/enabled
    • all vnchttpdX services off/disable (I don't need these.)
    • kdm
    • KDE desktop
    • GNOME not installed
    • This has happened on two different (identical) PCs.


    The first thing I encountered is that VNC did not work at all with the configuration I've used successfully on many systems for years.

    In order to get a login screen I had to change /etc/xinetd.d/vnc server_args lines in either (or both) of these ways:

    1. set the color depth to 8 bits ("-depth 8"), or
    2. add "-extension MIT-SHM" to the end of the line


    Since "-extension MIT-SHM" works at color depth > 8 bits, I set that back to 16 bits.
    e.g.:
    server_args = -noreset -inetd -once -query localhost -geometry 1600x1200 -depth 16 -securitytypes none -extension MIT-SHM

    OK, so that's strange, but...

    I can only make one GUI connection at a time. (ssh works normally.) That is, If I connect to the console, :1, :2 or :3 - and they all work - whenever I try to connect to another one without first logging out of the first, the second connection is denied. This even happens when the second connection is the console!

    Another thing that typically works (as a diagnostic tool) is to login on one session (eg, the console), and then launch vncviewer localhost:N. This also normally works (eg, on SLES), but it does not work on openSUSE 13.1 - the second GUI session fails.

    Has anyone seen this? If so, did you find a solution?

    Another odd thing with openSUSE 13.1 is that setting the screen resolution on the VNC client is only effective while logging in. As soon as once logs in, the window expands to the full size of my monitor. I found that it is possible to change the resolution of display "VNC-0" to whatever I want it to be. In the past, I have found it very convenient to have 3 VNC ports active (small :1, medium :2 and large :3) - depending upon what I'm doing. So, is this a feature or a bug?

    ... Let's not get into to VNC passwords (which are a good idea, of course); they appear to work normally...

    I will post some log output(s) as follow-ups...

  2. #2

    Default Re: vnc opensuse 13.1 - can only have one GUI login at a time (kdm KDE)

    Here is /var/log/messages:

    I am logged in on the console as my user - everything is normal.
    I initiate a VNC connection on :1, then I see this:

    2014-10-29T17:09:56.448861+11:00 michigan xinetd[1443]: START: vnc1 from=10.12.25.58
    2014-10-29T17:09:56.535709+11:00 michigan kdm_config[30818]: Multiple occurrences of section [General] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2014-10-29T17:09:56.536047+11:00 michigan kdm_config[30818]: Multiple occurrences of section [X-*-Core] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2014-10-29T17:09:56.536173+11:00 michigan kdm_config[30818]: Multiple occurrences of section [X-*-Greeter] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2014-10-29T17:09:56.536380+11:00 michigan kdm_config[30818]: Multiple occurrences of key 'Language' in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
    2014-10-29T17:09:56.536564+11:00 michigan kdm_config[30818]: Multiple occurrences of section [X-:*-Core] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2014-10-29T17:09:56.536757+11:00 michigan kdm_config[30818]: Multiple occurrences of key 'AllowShutdown' in section [X-:*-Core] of /usr/share/kde4/config/kdm/kdmrc
    2014-10-29T17:09:56.536935+11:00 michigan kdm_config[30818]: Multiple occurrences of section [X-:0-Core] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    2014-10-29T17:09:56.537169+11:00 michigan kdm_config[30818]: Multiple occurrences of key 'AutoLoginEnable' in section [X-:0-Core] of /usr/share/kde4/config/kdm/kdmrc

    A VNC login window (greeter) is displayed, I type in my (correct) username & password, and 1 or 2 of the KDE icons display (successful login) and the VNC window disappears:

    2014-10-29T17:10:10.918745+11:00 michigan kdm: localhost:1[30824]: pam_unix(xdm:session): session opened for user ausijyc by (uid=0)
    2014-10-29T17:10:10.920763+11:00 michigan systemd[1]: Starting Session 41 of user ausijyc.
    2014-10-29T17:10:10.921114+11:00 michigan systemd-logind[730]: New session 41 of user ausijyc.
    2014-10-29T17:10:10.921406+11:00 michigan systemd[1]: Started Session 41 of user ausijyc.
    2014-10-29T17:10:13.416129+11:00 michigan kdm: localhost:1[30824]: pam_unix(xdm:session): session closed for user ausijyc
    2014-10-29T17:10:13.420572+11:00 michigan xinetd[1443]: EXIT: vnc1 status=0 duration=17(sec)

    A few seconds later:

    2014-10-29T17:10:21.046334+11:00 michigan systemd-logind[730]: Removed session 41.

  3. #3

    Default Re: vnc opensuse 13.1 - can only have one GUI login at a time (kdm KDE)

    Quote Originally Posted by jimstaffer View Post
    In order to get a login screen I had to change /etc/xinetd.d/vnc server_args lines in either (or both) of these ways:

    1. set the color depth to 8 bits ("-depth 8"), or
    2. add "-extension MIT-SHM" to the end of the line


    Since "-extension MIT-SHM" works at color depth > 8 bits, I set that back to 16 bits.
    e.g.:
    server_args = -noreset -inetd -once -query localhost -geometry 1600x1200 -depth 16 -securitytypes none -extension MIT-SHM
    Yes. Although I didn't know that you can turn on MIT-SHM for VNC...
    You could also turn off the use of the MIT-SHM extension for Qt, by setting the environment variable QT_X11_NO_MITSHM=1, or setting Qt's default rendering backend to "native" instead of "raster" should help as well.

    Apparently with "raster", Qt4 unconditionally uses MIT-SHM even when it is not available/working.

    This also causes another problem: http://bugzilla.opensuse.org/show_bug.cgi?id=807781

    Quote Originally Posted by jimstaffer View Post
    I am logged in on the console as my user - everything is normal.
    I initiate a VNC connection on :1, then I see this:

    2014-10-29T17:09:56.448861+11:00 michigan xinetd[1443]: START: vnc1 from=10.12.25.58
    2014-10-29T17:09:56.535709+11:00 michigan kdm_config[30818]: Multiple occurrences of section [General] in /usr/share/kde4/config/kdm/kdmrc. Consider merging them.
    ...
    2014-10-29T17:09:56.537169+11:00 michigan kdm_config[30818]: Multiple occurrences of key 'AutoLoginEnable' in section [X-:0-Core] of /usr/share/kde4/config/kdm/kdmrc
    Those messages are "normal", they come from the way openSUSE's kdm merges the settings from /etc/sysconfig/displaymanager. You should also get them for :0 even on local login.
    They are harmless though.

    A VNC login window (greeter) is displayed, I type in my (correct) username & password, and 1 or 2 of the KDE icons display (successful login) and the VNC window disappears:
    Hm. I don't really have an idea there.
    As said, maybe try to disable the use of MIT-SHM globally, by adding QT_X11_NO_MITSHM=1 to /etc/environment, /etc/bashrc.local, or ~/.bashrc or ~/.profile. (not sure at the moment what would be the best place)
    Perhaps that use of shared memory causes problems when more than one session is active?

    And maybe ~/.xsession-errors-:1 (or similar, the :1 stands for the display) would contain a clue?

  4. #4

    Default Re: vnc opensuse 13.1 - can only have one GUI login at a time (kdm KDE)

    Quote Originally Posted by wolfi323 View Post
    ...
    And maybe ~/.xsession-errors-:1 (or similar, the :1 stands for the display) would contain a clue?
    $ cat .xsession-errors-:1
    /etc/X11/xim: Checking whether an input method should be started.
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    Dummy input method "none" (do not use any fancy input method by default)
    startkde: Starting up...
    klauncher(2450) kdemain: Waiting for already running klauncher to exit.
    klauncher(2450) kdemain: Waiting for already running klauncher to exit.
    klauncher(2450) kdemain: Another instance of klauncher is already running!
    kdeinit4: Communication error with launcher. Exiting!
    kdeinit4_wrapper: Warning: connect(/home/ausijyc/.kde4/socket-michigan/kdeinit4__1) failed: : Connection refused
    Could not register with D-BUS. Aborting.
    startkde: Shutting down...
    kdeinit4_wrapper: Warning: connect(/home/ausijyc/.kde4/socket-michigan/kdeinit4__1) failed: : Connection refused
    Error: Can not contact kdeinit4!
    startkde: Running shutdown scripts...
    startkde: Done.


    But I have discovered - like many others over the past few years - that I can login as a different user on a different VNC session. Odd, though, I didn't find a solution - just a lot of people reporting it as a bug.

  5. #5

    Default Re: vnc opensuse 13.1 - can only have one GUI login at a time (kdm KDE)

    Quote Originally Posted by jimstaffer View Post
    But I have discovered - like many others over the past few years - that I can login as a different user on a different VNC session. Odd, though, I didn't find a solution - just a lot of people reporting it as a bug.
    Well, that's probably a clash in user files (.Xauthority maybe?) or the D-BUS user session then.

    I think I read something about this in the KDE forums as well, where the developers said that having two user sessions active at the same time for the same user is just not supported and can lead to many different problems, or something like that.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •