Results 1 to 2 of 2

Thread: OpenSuSE 13.1 disables BlueTooth during boot

  1. #1
    Join Date
    Jul 2010
    Location
    Lucknow, India
    Posts
    46

    Default OpenSuSE 13.1 disables BlueTooth during boot

    Opensuse 13.1 is the most troublesome opensuse release for me. Almong all the issue and glitches I am facing, I am having this strange issue where opensuse 13.1 disables the bluetooth harware.

    System:
    My computer is HP 6720s laptop having integrated bluetooth (I think it is from Broadcom). Opensuse 13.1 x64 is installed in dual boot mode with Windows 7. In opensuse I have installed KDE , MATE and GNOME desktop.

    Problem:
    Whenever I boot into opensuse, it disables the bluetooth and I can't enable it back easily. When bluetooth works in Windows 7, it keeps working there until I boot to opensuse i.e. after booting to opensuse, bluetooth stops working in Windows 7 as well. After that neither Windows 7 not opensuse (KDE, MATE with exception of GNOME) detects bluetooth hardware. GNOME desktop does detects the hardware and can be enabled back from there but this works till I don't restart the system. After restart I have to enable it again from GNOME.

    Workarounds:
    To use bluetooth in Windows 7(when bluetooth hardware is not detected), I have to follow these steps before I can use bluetooth:
    1. Power on the system -> enter BIOS setup -> Reset to defaults and restart.
    2. Boot to Windows 7. Now bluetooth works even after restart (without a need of resetting BIOS). Booting back in opensuse requires all the steps to be repeated again.

    To use bluetooth in Opensuse 13.1:
    1. Power on the system and boot to GNOME desktop in opensuse. By the way I don't prefer using GNOME 3 due to performance issues. I prefer MATE desktop (but it is not working). Currently I use KDE.
    2. In GNOME open bluetooth settings. Gnome bluetooth settings detects bluetooth hardware but display it as disabled. Bluetooth can be enabled from here. After enabling it from Gnome bluetooth settings, bluetooth now starts working in KDE and MATE until system is restarted.


    Is there any solution to this irritating issue? Thanks in advance

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,816

    Default Re: OpenSuSE 13.1 disables BlueTooth during boot

    Report the problem to bugzilla. As I recall gnome and KDE had two different versions of bluetooth so Check what you have installed. One worked and one did not. I do know if it ever got fixed.

    Bluetooth as been a real pain since it first came out. I even had problem in Windows

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •