Page 1 of 7 123 ... LastLast
Results 1 to 10 of 66

Thread: zypper problem with 13.1x64?

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default zypper problem with 13.1x64?

    It seems to get through our proxy fine, but... is something wrong with the repo? I keep getting these a/r/i/? faults...

    Code:
    <<....>>
    920 packages to upgrade, 30 new.
    Overall download size: 1008.9 MiB. After the operation, additional 756.4 MiB will be used.
    Continue? [y/n/? shows all options] (y): 
    Do you agree with the terms of the license? [yes/no] (no): yes
    Retrieving package kdeartwork4-wallpapers-4.11.5-143.11.noarch                                                                      (1/950),  77.0 MiB ( 77.5 MiB unpacked)
    Retrieving: kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm ........................................................................................................[error]
    File './noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a):

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,576
    Blog Entries
    1

    Default Re: zypper problem with 13.1x64?

    Quote Originally Posted by PattiMichelle View Post
    It seems to get through our proxy fine, but... is something wrong with the repo? I keep getting these a/r/i/? faults...

    Code:
    <<....>>
    920 packages to upgrade, 30 new.
    Overall download size: 1008.9 MiB. After the operation, additional 756.4 MiB will be used.
    Continue? [y/n/? shows all options] (y): 
    Do you agree with the terms of the license? [yes/no] (no): yes
    Retrieving package kdeartwork4-wallpapers-4.11.5-143.11.noarch                                                                      (1/950),  77.0 MiB ( 77.5 MiB unpacked)
    Retrieving: kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm ........................................................................................................[error]
    File './noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a):
    That file doesn't exist. Stale cache? Are you sure that you refreshed your repos first, before updating?
    Code:
    zypper clean && zypper refresh

  3. #3
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Thank you very much. I didn't try clean. I get this with YaST also, and the repos all look right... tried rpm --rebuilddb

    Ah, it looks like zypper clean helped but it's still not finding everything it seems to want to find... but at least it seems to be doing most of them now, unlike just doing 15 or so previously, then quitting. Odd, but I guess it's doing what I need - patching.

    Code:
    TYAN4:/home/patti # zypper clean
    All repositories have been cleaned up.
    TYAN4:/home/patti # zypper refresh
    Repository 'openSUSE-13.1-Non-Oss' is up to date.
    Repository 'openSUSE-13.1-Oss' is up to date.
    Retrieving repository 'openSUSE-13.1-Update' metadata ....................................................................................................[done]
    Building repository 'openSUSE-13.1-Update' cache .........................................................................................................[done]
    Repository 'openSUSE-13.1-Update-Non-Oss' is up to date.
    All repositories have been refreshed.
    TYAN4:/home/patti # 
    TYAN4:/home/patti # zypper patch
    Loading repository data...                                                                                                                                      
    Reading installed packages...                                                                                                                                   
    Resolving package dependencies...                                                                                                                               
                                                                                                                                                                    
    The following 30 NEW packages are going to be installed:                                                                                                        
      apper-lang clutter-lang evolution-data-server-lang gdk-pixbuf-lang glib-networking-lang gnome-control-center-color gstreamer-0_10-fluendo-mp3                 
      java-1_7_0-openjdk-headless kdeartwork4-wallpapers kdeartwork4-wallpapers-weather kernel-default-devel-3.11.10-21.1 kernel-desktop-3.11.10-21.1               
      kernel-desktop-devel-3.11.10-21.1 kernel-devel-3.11.10-21.1 kernel-source-3.11.10-21.1 kernel-syms-3.11.10-21.1 kernel-xen-devel-3.11.10-21.1 libpoppler-cpp0 
      libquvi libquvi-scripts libwebkitgtk2-lang libwebkitgtk3-lang libxkbcommon0 libxkbcommon-devel luasocket NetworkManager-kde4-libs-lang                        
      oxygen-icon-theme-large poppler-data totem-pl-parser unrar                                                                                                    
                                                                                                                                                                    
    The following 370 NEW patches are going to be installed:
    <<...>>
    920 packages to upgrade, 30 new.
    Overall download size: 1009.0 MiB. After the operation, additional 756.4 MiB will be used.
    Continue? [y/n/? shows all options] (y): 
    Do you agree with the terms of the license? [yes/no] (no): yes
    Retrieving package poppler-data-0.4.6-5.1.2.noarch                                                                       (1/950),   1.4 MiB ( 11.4 MiB unpacked)
    Retrieving: poppler-data-0.4.6-5.1.2.noarch.rpm ..........................................................................................................[done]
    Retrieving package apparmor-docs-2.8.2-4.13.1.noarch                                                                     (2/950), 288.2 KiB (411.8 KiB unpacked)
    Retrieving delta: ./noarch/apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm, 22.9 KiB
    Retrieving: apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm .................................................................................................[done]
    Applying delta: ./apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm ...........................................................................................[done]
    Retrieving package at-spi2-atk-common-2.10.2-12.1.x86_64                                                                   (3/950),  26.6 KiB (  213 B unpacked)
    Retrieving: at-spi2-atk-common-2.10.2-12.1.x86_64.rpm ....................................................................................................[done]
    Retrieving package digikam-doc-3.5.0-7.3.noarch                                                                          (4/950),  19.3 MiB ( 19.9 MiB unpacked)
    Retrieving delta: ./noarch/digikam-doc-3.5.0-4.1_7.3.noarch.drpm, 272.1 KiB
    Retrieving: digikam-doc-3.5.0-4.1_7.3.noarch.drpm ........................................................................................................[done]
    Applying delta: ./digikam-doc-3.5.0-4.1_7.3.noarch.drpm ..................................................................................................[done]
    Retrieving package file-magic-5.15-4.20.1.x86_64                                                                         (5/950), 302.8 KiB (  3.3 MiB unpacked)
    Retrieving delta: ./x86_64/file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm, 53.1 KiB
    Retrieving: file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm ................................................................................................[done]
    Applying delta: ./file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm ..........................................................................................[done]
    Retrieving package glibc-2.18-4.21.1.x86_64                                                                              (6/950),   1.6 MiB (  6.3 MiB unpacked)
    Retrieving delta: ./x86_64/glibc-2.18-4.4.1_4.21.1.x86_64.drpm, 130.9 KiB
    Retrieving: glibc-2.18-4.4.1_4.21.1.x86_64.drpm ..........................................................................................................[done]
    Applying delta: ./glibc-2.18-4.4.1_4.21.1.x86_64.drpm ....................................................................................................[done]
    Retrieving package gnome-control-center-user-faces-3.10.3-18.2.x86_64                                                    (7/950), 226.1 KiB (114.2 KiB unpacked)
    Retrieving: gnome-control-center-user-faces-3.10.3-18.2.x86_64.rpm .......................................................................................[done]
    Retrieving package gnome-shell-search-provider-seahorse-3.10.2-10.1.x86_64                                                 (8/950),  23.4 KiB (  230 B unpacked)
    Retrieving: gnome-shell-search-provider-seahorse-3.10.2-10.1.x86_64.rpm ..................................................................................[done]
    Retrieving package gnome-user-docs-3.10.3-14.1.noarch                                                                    (9/950),   2.4 MiB (  3.3 MiB unpacked)
    Retrieving delta: ./noarch/gnome-user-docs-3.10.1_3.10.3-1.1_14.1.noarch.drpm, 579.4 KiB
    Retrieving: gnome-user-docs-3.10.1_3.10.3-1.1_14.1.noarch.drpm ...........................................................................................[done]
    Applying delta: ./gnome-user-docs-3.10.1_3.10.3-1.1_14.1.noarch.drpm .....................................................................................[done]
    Retrieving package gnome-version-3.10.2-5.1.x86_64                                                                        (10/950),  32.6 KiB (  167 B unpacked)
    Retrieving: gnome-version-3.10.2-5.1.x86_64.rpm ..........................................................................................................[done]
    Retrieving package gtk2-data-2.24.23-7.1.noarch                                                                         (11/950),  67.1 KiB (  3.9 KiB unpacked)
    Retrieving: gtk2-data-2.24.23-7.1.noarch.rpm ................................................................................................[done (12.6 KiB/s)]
    Retrieving package icewm-1.3.7-26.4.1.x86_64                                                                           (12/950), 232.0 KiB (1016.2 KiB unpacked)
    Retrieving delta: ./x86_64/icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm, 52.7 KiB
    Retrieving: icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm ........................................................................................................[done]
    Applying delta: ./icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm ..................................................................................................[done]
    Retrieving package kdeartwork4-wallpapers-4.11.5-143.11.noarch                                                          (13/950),  77.0 MiB ( 77.5 MiB unpacked)
    Retrieving: kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm .............................................................................................[error]
    File './noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a): i
    Warning: You have chosen to ignore a problem with download or installation of a package which might lead to broken dependencies of other packages. It is recommended to run 'zypper verify' after the operation has finished.
    Retrieving package kdegames4-carddecks-default-4.11.5-106.3.noarch                                                      (14/950), 140.2 KiB (773.1 KiB unpacked)
    Retrieving delta: ./noarch/kdegames4-carddecks-default-4.11.2_4.11.5-1.1_106.3.noarch.drpm, 16.7 KiB
    Retrieving: kdegames4-carddecks-default-4.11.2_4.11.5-1.1_106.3.noarch.drpm ..............................................................................[done]
    Applying delta: ./kdegames4-carddecks-default-4.11.2_4.11.5-1.1_106.3.noarch.drpm ........................................................................[done]
    Retrieving package libkdegames-4.11.5-106.3.x86_64                                                                      (15/950),  28.5 KiB ( 39.6 KiB unpacked)
    Retrieving: libkdegames-4.11.5-106.3.x86_64.rpm ..........................................................................................................[done]
    Retrieving package opensuse-startup_en-13.1-8.1.noarch                                                                  (16/950),   9.6 MiB ( 10.8 MiB unpacked)
    Retrieving: opensuse-startup_en-13.1-8.1.noarch.rpm .....................................................................................................[error]
    File './noarch/opensuse-startup_en-13.1-8.1.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a): i
    Warning: You have chosen to ignore a problem with download or installation of a package which might lead to broken dependencies of other packages. It is recommended to run 'zypper verify' after the operation has finished.
    Retrieving package oxygen-icon-theme-4.11.5-108.1.noarch                                                                (17/950),   9.7 MiB (  9.6 MiB unpacked)
    Retrieving delta: ./x86_64/dosfstools-3.0.22-2.1.2_2.4.1.x86_64.drpm, 13.0 KiB
    Retrieving: dosfstools-3.0.22-2.1.2_2.4.1.x86_64.drpm ....................................................................................................[done]
    Applying delta: ./dosfstools-3.0.22-2.1.2_2.4.1.x86_64.drpm ..............................................................................................[done]
    Retrieving package Mesa-libglapi0-9.2.3-61.9.1.x86_64                                                                   (69/950),  55.5 KiB (146.4 KiB unpacked)
    Retrieving: Mesa-libglapi0-9.2.3-61.9.1.x86_64.rpm .......................................................................................................[done]
    <<...>>i
    Retrieving package kdeartwork4-wallpapers-weather-4.11.5-143.11.noarch                                                  (70/950),   8.3 MiB (  8.4 MiB unpacked)
    Retrieving: kdeartwork4-wallpapers-weather-4.11.5-143.11.noarch.rpm .....................................................................................[error]
    File './noarch/kdeartwork4-wallpapers-weather-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a): i
    
    <<...>>
    
    File './noarch/oxygen-icon-theme-large-4.11.5-108.1.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a): i
    Warning: You have chosen to ignore a problem with download or installation of a package which might lead to broken dependencies of other packages. It is recommended to run 'zypper verify' after the operation has finished.
    Retrieving package readline-devel-6.2-68.12.1.x86_64                                                                    (72/950),  58.2 KiB ( 75.6 KiB unpacked)
    Retrieving: readline-devel-6.2-68.12.1.x86_64.rpm ....

  4. #4
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    I finally noticed this warning... but it seems OK.

    Code:
    <<...>>
    Retrieving package java-1_7_0-openjdk-headless-1.7.0.6-24.13.5.x86_64                                                  (480/950),  41.9 MiB ( 78.5 MiB unpacked)
    Retrieving: java-1_7_0-openjdk-headless-1.7.0.6-24.13.5.x86_64.rpm ......................................................................................[error]
    File './x86_64/java-1_7_0-openjdk-headless-1.7.0.6-24.13.5.x86_64.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    Abort, retry, ignore? [a/r/i/? shows all options] (a): i
    Warning: You have chosen to ignore a problem with download or installation of a package which might lead to broken dependencies of other packages. It is recommended to run 'zypper verify' after the operation has finished.
    
    TYAN4:/home/patti # zypper verify
    Loading repository data...
    Reading installed packages...
    
    Dependencies of all installed packages are satisfied.
    TYAN4:/home/patti #

  5. #5
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Apparently YaST is still trying to download nonexistent packages. Maybe it's because, on a whim, I also installed Gnome desktop environment? I've never done that before. What's a zypper command to remove the Gnome desktop? Seems odd that it won't install openJDK headless...

    EDIT: found it here ... https://forums.opensuse.org/showthre...ling-GNOME-3-0

  6. #6
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    ...for some reason it still wants to download stuff that isn't supposed to exist, like kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm
    and opensuse-startup_en-13.1-8.1.noarch.rpm

    Code:
    TYAN4:/home/patti # zypper clean
    All repositories have been cleaned up.
    TYAN4:/home/patti # zypper refresh
    Repository 'openSUSE-13.1-Non-Oss' is up to date.
    Repository 'openSUSE-13.1-Oss' is up to date.
    Repository 'openSUSE-13.1-Update' is up to date.
    Repository 'openSUSE-13.1-Update-Non-Oss' is up to date.
    All repositories have been refreshed.
    TYAN4:/home/patti # zypper lr
    # | Alias                     | Name                               | Enabled | Refresh
    --+---------------------------+------------------------------------+---------+--------
    1 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes    
    2 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes    
    3 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes    
    4 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes    
    5 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes    
    6 | repo-source               | openSUSE-13.1-Source               | No      | Yes    
    7 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes    
    8 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes    
    TYAN4:/home/patti # zypper patch
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 30 NEW packages are going to be installed:
      apper-lang bundle-lang-gnome-ar clutter-lang gdk-pixbuf-lang glib-networking-lang gtk2-branding-upstream gtk3-branding-upstream java-1_7_0-openjdk-headless 
      kdeartwork4-wallpapers kdeartwork4-wallpapers-weather kernel-default-devel-3.11.10-21.1 kernel-desktop-3.11.10-21.1 kernel-desktop-devel-3.11.10-21.1 
      kernel-devel-3.11.10-21.1 kernel-source-3.11.10-21.1 kernel-syms-3.11.10-21.1 kernel-xen-devel-3.11.10-21.1 libpoppler-cpp0 libquvi libquvi-scripts 
      libwebkitgtk2-lang libwebkitgtk3-lang libxkbcommon0 libxkbcommon-devel luasocket NetworkManager-kde4-libs-lang oxygen-icon-theme-large poppler-data 
      totem-pl-parser unrar 
    
    The following 363 NEW patches are going to be installed:
      openSUSE-2013-1005 openSUSE-2013-1007 openSUSE-2013-1013 openSUSE-2013-1016 openSUSE-2013-1018 openSUSE-2013-1019 openSUSE-2013-1020 openSUSE-2013-1022 
      openSUSE-2013-1031 openSUSE-2013-1032 openSUSE-2013-1033 openSUSE-2013-829 openSUSE-2013-832 openSUSE-2013-834 openSUSE-2013-840 openSUSE-2013-841 
    < snip!>
      openSUSE-2014-92 openSUSE-2014-93 openSUSE-2014-95 openSUSE-2014-97 openSUSE-2014-98 
    
    The following 829 packages are going to be upgraded:
      a2ps aaa_base aaa_base-extras accountsservice aisleriot akonadi akonadi-runtime akregator alsa alsa-devel alsa-oss alsa-utils android-tools apache2 apache2-devel 
      apache2-doc apache2-example-pages apache2-mod_php5 apache2-prefork apache2-utils apparmor-docs apparmor-parser apparmor-profiles apparmor-utils apper ark at 
      at-spi2-atk-common at-spi2-atk-devel at-spi2-atk-gtk2 at-spi2-core autofs avahi avahi-autoipd avahi-compat-mDNSResponder-devel bash bash-doc bijiben bind-libs 
      bind-utils bluez bluez-devel brasero brasero-nautilus ca-certificates ca-certificates-mozilla cairo-devel cervisia choqok claws-mail claws-mail-lang 
      clutter-devel clutter-gst-devel colord coreutils cups cups-client cups-devel cups-libs cups-libs-32bit curl dbus-1 dbus-1-devel dbus-1-x11 dconf devhelp 
      devhelp-lang dhcp dhcp-client digikam digikam-doc dolphin dosfstools e2fsprogs elfutils emacs emacs-info emacs-nox emacs-x11 enblend-enfuse etags evince exo-lang 
      exo-tools fdupes file file-magic file-roller five-or-more five-or-more-lang fontconfig fontconfig-devel freerdp gdk-pixbuf-devel gdk-pixbuf-query-loaders 
      gdmflexiserver gedit gio-branding-openSUSE git-core git-email git-gui gitk git-web glib2-devel glib2-tools glibc glibc-32bit glibc-devel glibc-extra glibc-info 
      glibc-locale glibc-locale-32bit glib-networking gpg2 gpgme grub2 grub2-i386-pc grub2-x86_64-efi gsettings-backend-dconf gstreamer-plugin-gstclutter 
      <snip!>
      typelib-1_0-IBus-1_0 typelib-1_0-JavaScriptCore-1_0 typelib-1_0-JavaScriptCore-3_0 typelib-1_0-NetworkManager-1_0 typelib-1_0-NMClient-1_0 typelib-1_0-NMGtk-1_0 
      typelib-1_0-Pango-1_0 typelib-1_0-Soup-2_4 typelib-1_0-TelepathyGlib-0_12 typelib-1_0-TotemPlParser-1_0 typelib-1_0-Tracker-0_16 typelib-1_0-TrackerExtract-0_16 
      typelib-1_0-TrackerMiner-0_16 typelib-1_0-UpowerGlib-1_0 typelib-1_0-WebKit-1_0 typelib-1_0-WebKit-3_0 udev udev-configure-printer udevmountd udisks udisks2 
      umbrello upower util-linux vala vim vim-data vorbis-tools webkit2gtk-3_0-injected-bundles wpa_supplicant x11-tools xalan-j2 xf86-input-vmmouse 
      xf86-video-modesetting xinetd xorg-x11-server xorg-x11-server-extra xscreensaver xscreensaver-data xscreensaver-data-extra yast2 yast2-add-on yast2-iscsi-client 
      yast2-ldap-client yast2-network yast2-nis-client yast2-ruby-bindings yast2-services-manager yast2-storage yast2-trans-en_US yast2-ycp-ui-bindings yelp zenity zip 
    
    829 packages to upgrade, 30 new.
    Overall download size: 966.9 MiB. After the operation, additional 750.7 MiB will be used.
    Continue? [y/n/? shows all options] (y): 
    Retrieving package bundle-lang-gnome-ar-13.1-2.2.8.noarch                                                                    (1/859), 903.1 KiB (  3.6 MiB unpacked)
    Retrieving: bundle-lang-gnome-ar-13.1-2.2.8.noarch.rpm ..........................................................................................[done (91.1 KiB/s)]
    Retrieving package poppler-data-0.4.6-5.1.2.noarch                                                                           (2/859),   1.4 MiB ( 11.4 MiB unpacked)
    Retrieving: poppler-data-0.4.6-5.1.2.noarch.rpm ..............................................................................................................[done]
    Retrieving package apparmor-docs-2.8.2-4.13.1.noarch                                                                         (3/859), 288.2 KiB (411.8 KiB unpacked)
    Retrieving delta: ./noarch/apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm, 22.9 KiB
    Retrieving: apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm .....................................................................................................[done]
    Applying delta: ./apparmor-docs-2.8.2-4.5.1_4.13.1.noarch.drpm ...............................................................................................[done]
    Retrieving package at-spi2-atk-common-2.10.2-12.1.x86_64                                                                       (4/859),  26.6 KiB (  213 B unpacked)
    Retrieving: at-spi2-atk-common-2.10.2-12.1.x86_64.rpm ........................................................................................................[done]
    Retrieving package digikam-doc-3.5.0-7.3.noarch                                                                              (5/859),  19.3 MiB ( 19.9 MiB unpacked)
    Retrieving delta: ./noarch/digikam-doc-3.5.0-4.1_7.3.noarch.drpm, 272.1 KiB
    Retrieving: digikam-doc-3.5.0-4.1_7.3.noarch.drpm ............................................................................................................[done]
    Applying delta: ./digikam-doc-3.5.0-4.1_7.3.noarch.drpm ......................................................................................................[done]
    Retrieving package file-magic-5.15-4.20.1.x86_64                                                                             (6/859), 302.8 KiB (  3.3 MiB unpacked)
    Retrieving delta: ./x86_64/file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm, 53.1 KiB
    Retrieving: file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm ....................................................................................................[done]
    Applying delta: ./file-magic-5.14_5.15-4.1.2_4.20.1.x86_64.drpm ..............................................................................................[done]
    Retrieving package glibc-2.18-4.21.1.x86_64                                                                                  (7/859),   1.6 MiB (  6.3 MiB unpacked)
    Retrieving delta: ./x86_64/glibc-2.18-4.4.1_4.21.1.x86_64.drpm, 130.9 KiB
    Retrieving: glibc-2.18-4.4.1_4.21.1.x86_64.drpm ..............................................................................................................[done]
    Applying delta: ./glibc-2.18-4.4.1_4.21.1.x86_64.drpm ........................................................................................................[done]
    Retrieving package gtk2-data-2.24.23-7.1.noarch                                                                              (8/859),  67.1 KiB (  3.9 KiB unpacked)
    Retrieving: gtk2-data-2.24.23-7.1.noarch.rpm .................................................................................................................[done]
    Retrieving package icewm-1.3.7-26.4.1.x86_64                                                                                (9/859), 232.0 KiB (1016.2 KiB unpacked)
    Retrieving delta: ./x86_64/icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm, 52.7 KiB
    Retrieving: icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm ............................................................................................................[done]
    Applying delta: ./icewm-1.3.7-26.1.4_26.4.1.x86_64.drpm ......................................................................................................[done]
    Retrieving package kdeartwork4-wallpapers-4.11.5-143.11.noarch                                                              (10/859),  77.0 MiB ( 77.5 MiB unpacked)
    Retrieving: kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm .................................................................................................[error]
    File './noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    
    Abort, retry, ignore? [a/r/i/? shows all options] (a):

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,761

    Default Re: zypper problem with 13.1x64?

    Looking via Yast I see those packages and they list from openSUSE repo

    Are you sure you have correct URLs zypper lr -d will show the URLS

  8. #8
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Quote Originally Posted by gogalthorp View Post
    Looking via Yast I see those packages and they list from openSUSE repo

    Are you sure you have correct URLs zypper lr -d will show the URLS
    Thank you very much for the reply. Zypper downloaded and installed all but 4 or 5 patches, but every time I run it, it wants to install the same patches. Odd. maybe it's failing because I hit "ignore" for those 4 or 5 patches? The console shows that the patches are being "downloaded" and "applied."

    Code:
    TYAN4:/home/patti # zypper lr -d 
    # | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                             | Service          
    --+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------+--------                    
    1 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/  |        
    2 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                 |        
    3 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/         |        
    4 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/    |        
    5 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/        |        
    6 | repo-source               | openSUSE-13.1-Source               | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/ |        
    7 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                       |        
    8 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/               |        
    TYAN4:/home/patti # 
    Code:
     Retrieving package libbluetooth3-5.8-3.9.1.x86_64                                                                                                                               (47/860), 104.3 KiB (210.7 KiB unpacked)
    Retrieving delta: ./x86_64/libbluetooth3-5.8-3.2.1_3.9.1.x86_64.drpm, 40.8 KiB
    Retrieving: libbluetooth3-5.8-3.2.1_3.9.1.x86_64.drpm ............................................................................................................................................................[done]
    Applying delta: ./libbluetooth3-5.8-3.2.1_3.9.1.x86_64.drpm ......................................................................................................................................................[done]
    Retrieving package libavahi-common3-0.6.31-16.6.1.x86_64                                                                                                                        (48/860),  30.2 KiB ( 51.2 KiB unpacked)
    Retrieving delta: ./x86_64/libavahi-common3-0.6.31-16.3.1_16.6.1.x86_64.drpm, 12.8 KiB
    Retrieving: libavahi-common3-0.6.31-16.3.1_16.6.1.x86_64.drpm ....................................................................................................................................................[done]
    Applying delta: ./libavahi-common3-0.6.31-16.3.1_16.6.1.x86_64.drpm ..............................................................................................................................................[done]
    Retrieving package libasound2-1.0.27.2-3.5.1.x86_64                                                                                                                             (49/860), 335.6 KiB (  1.1 MiB unpacked)

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: zypper problem with 13.1x64?

    On 2014-10-21 01:16, PattiMichelle wrote:

    > Code:
    > --------------------

    ....
    > Retrieving package kdeartwork4-wallpapers-4.11.5-143.11.noarch (10/859), 77.0 MiB ( 77.5 MiB unpacked)
    > Retrieving: kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm .................................................................................................[error]
    > File './noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm' not found on medium 'http://download.opensuse.org/update/13.1/'
    >
    > Abort, retry, ignore? [a/r/i/? shows all options] (a):
    >
    > --------------------


    Code:
    cer@Telcontar:~> wget "http://download.opensuse.org/update/13.1/noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm"
    --2014-10-21 13:30:19--  http://download.opensuse.org/update/13.1/noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm
    Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
    Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://fr2.rpmfind.net/linux/opensuse/update/13.1/noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm [following]
    --2014-10-21 13:30:19--  http://fr2.rpmfind.net/linux/opensuse/update/13.1/noarch/kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm
    Resolving fr2.rpmfind.net (fr2.rpmfind.net)... 195.220.108.108
    Connecting to fr2.rpmfind.net (fr2.rpmfind.net)|195.220.108.108|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 80700774 (77M) [application/x-rpm]
    Saving to: ‘kdeartwork4-wallpapers-4.11.5-143.11.noarch.rpm’
    
    1% [>                                                                     ] 876.479     92,6KB/s  eta 14m 35s^C
    cer@Telcontar:~>

    The file does exist. Maybe it was not there, in the actual mirror you get redirected to, the instant you tried.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  10. #10
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,175

    Default Re: zypper problem with 13.1x64?

    Thank you very much for the reply. I keep retrying and getting the same set of errors (on the same 5 patches), while it "downloads" and "applies" about 855 patches, apparently successfully.
    Then, when I rerun zypper update or zypper patch, shouldn’t it say that there are only those 5 left, rather than offering to download/apply all 860 of them again?

    This is what makes me think I'm missing something deeper...

Page 1 of 7 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •